2 Replies Latest reply on May 5, 2011 10:05 AM by Zverodav

    Imported swf file is not showing at all

    Zverodav

      Hello!

      I have custom swf that I have created in Flash Pro CS5, in AS 3.0. It calls upon two .as files which are in an "actionscript" subfolder and it reads a .xml which is in the same path as the custom.swf (no subfolder). The swf works perfectly fine when launched on its own (i.e. loads the .as + the .xml files correctly).

       

      Now, I imported the swf in a brand new Catalyst project, which pretty much just has a square as a background. However, when imported, the .swf shows up as a simple icon with a question mark and has a deafault size of 30x30 instead of 500x500 (unlike other swfs which usually show up with the simple "f" icon and have their correct default sizes). Knowing that on import the Catalyst won't import the .as and .xml files I duly copied them to the "src" folder under C:/users/USERNAME/Application Data/Adobe... etc. I also set up the action sequence "OnApplication Start" to play the .swf

       

      I preview the project and I pretty much get only the gray square with no trace of any swf whatsoever. I decided I might have the paths setup wrong somehow. So I published and copied my .as & .xml files into the same folder where my custom.swf is (i.e. \run-local\assets\images). When i play the custom.swf there on its own it works fine (as expected). However loading the Main.html from the \run-local folder again doesn't show anything but the square. Then, I also copied the .as + .xml in the \run-local root folder where the Main.swf is located (as I read that they need to be in the same path as the top level container). Again there was no effect.

       

      Please help me solve this issue. I believe that the fact that the custom.swf is imported with wrong default dimensions (30x30 instead of 500x500) and the wierd icon might have something to do with it. I can upload the source files somewhere if necessary.

       

      Thanks!

        • 1. Re: Imported swf file is not showing at all
          Chris W. Griffith Adobe Community Professional

          When you published the imported SWFs from Flash Professional, which network access setting do you use? You might be running into some security sandbox issues. You can either access local files or network (without doing some other configurations).

           

          Re-export the swfs with the allow network access option set. This should be in the Publish settings. You might need to have two version of the swf, one to test on the desktop and on for the server.

           

          Hope this helps,

          Chris

          • 2. Re: Imported swf file is not showing at all
            Zverodav Level 1

            Hi, Chris!

             

            Thanks for giving it a thought but that didn't seem to help :/

            I'll try recompiling it tonight in a few different ways to see if anything changes. I'm testing entirelly on the local drive.Still haven't tried uploading anything from that project to the web.

             

            Just a s note - the swf is entirely powered by the two .as files (because it just renders some words from an xml) so maybe there might be an issue if the file doesn't really contain much (although i tried putting some colored boxes inside and it didn't help).

             

            I'll post links to the .fla and the .as files later today.