2 Replies Latest reply on May 4, 2011 8:59 AM by NorthernTechWriter

    Weird scripts in corrupted RH9 project

    NorthernTechWriter Level 1

      Hi!

       

      I'm having trouble with a small 75-topic project in RH9. I just upgraded it from RH7 last month. The application runs on XP, service pack 3. The project file is located on a desktop and has a short access path (c:\RH9Projects\). I have in all 4 small RH projects, and created backups for each before upgrading to RH9. For simplicity purposes, the corrupted project will be identified as project A, and the others as B, C and D.

       

      After I finished tweaking the upgraded files and cleaning up unnecessary html in project A a few weeks ago, I generated my regular webhelp output and published it on the web. Everything was running smoothly. Since that upgrade from 7 to 9 went well, I repeated the steps for projects B, C and D. All was well again. I had also created backups at that time.

       

      Yesterday I went back to project A, and a lot of things are wrong. The TOC pod is empty, images that were in drop-down hotspots have disappeared and weird scripts have appeared in the topics' html. I first noticed those dreaded red squares at the top of all topics, sometimes 1 or 2. They also appear at the bottom of the topics.

       

      I closed project A without saving and tried opening project B. Everything is fine, nothing is missing. Same thing for project C and D. I tried opening a backed up copy of project A and that one too is corrupted. The backup copy was in a different folder but still with a short path. In this one, however, the opning topic is blank and has 6 red squares.

       

      Here's the script corresponding to the red square at the top of the topic:

      <script type="text/javascript" language="javascript1.2">//<![CDATA[
      <!--
      if (window.gbWhTopic)
      {
              var strUrl = document.location.href;
              var bc = 0;
              var n = strUrl.toLowerCase().indexOf("bc-");
              if(n != -1)
              {
                      document.location.href = strUrl.substring(0, n);
                      bc = strUrl.substring(n+3);
              }

       

              if (window.addTocInfo)
              {
              addTocInfo("Aide en ligne JMS");
      addButton("show",BTN_TEXT,"Afficher","","","","",0,0,"","","");

       

              }
              if (window.writeBtnStyle)
                      writeBtnStyle();

       

              if (window.writeIntopicBar)
                      writeIntopicBar(1);

       

             
              document.write("<p style=\"text-align:right\"> ");
      AddMasterBreadcrumbs("H_HLP_FR.htm", "", "&gt;", "Home", "1000.htm");
      document.write("Aide en ligne JMS<\/p>");

       


              if (window.setRelStartPage)
              {
              setRelStartPage("H_HLP_FR.htm");

       

                      autoSync(1);
                      sendSyncInfo();
                      sendAveInfoOut();
              }
      }
      else
              if (window.gbIE4)
                      document.location.reload();

       

      //-->
      //]]></script>

       

      Here's the script corresponding to the red square at the bottom of the topic:

      <script type="text/javascript" language="javascript1.2">//<![CDATA[
      <!--
      if (window.writeIntopicBar)
              writeIntopicBar(0);

       


      highlightSearch();
      //-->
      //]]></script>

       

      In some cases I also see this script - from a second red square:

      <script src="../../../ehlpdhtm.js" type="text/javascript" language="JavaScript1.2"></script>(top)

      <script type="text/javascript" language="JavaScript1.2">//<![CDATA[
              if( typeof( TextPopupInit ) != 'function' ) TextPopupInit = new Function();
              TextPopupInit('a1','POPUP386155265');
              TextPopupInit('a2','POPUP386287878');
      //]]></script>
      (bottom)

       

      All RH9 versions of project A, original file and backup files, have this problem. If I open project A backup file using RH7, the file is okay. I know I can still start over with a new upgrade if need be, but I'm trying to figure out what happened. Everything was fine on April 20

       

      Aside from a techsupport guy, I am the only one who accesses this computer. There are no known technical issues with it. It is not connected to the Internet, only to the company's network, and security is thight.

       

      Does anyone have any clue as to what might have happened?

       

      Thank you in advance

       

      Nathalie