6 Replies Latest reply on May 5, 2011 2:56 PM by nwhite9327

    Robohelp 8 - Not searching PDF




      I know this has been discussed in multiple threads as I have been through every single one.



      Robohelp is not searching content (text) in PDF files.


      I am not a computer logged into a network..  I'm trying to figure out what the problem is.

      Running Robohelp 8.02

      Project is WebHelp "not Pro"

      Output is to local C:\ drive


      Here is a sample PDF that i'm trying to make searchable (I have many more)


      Download Link:



      I've created a new project and tried just putting that particular PDF file as a baggage and linking and it still wouldn't find information on the PDF.


      I'm starting to think it has to do something with Robohelp being installed on administrator account and me being on a different account, is not providing the correct search results.  The compile goes so fast that it seems its not even attempting to create search terms.

      Any suggestions would be awesome.  If someone wants to test the PDF in the above link on their own and see what results they get, that would probably tell me where the issues is.



        • 1. Re: Robohelp 8 - Not searching PDF
          kmaddox1 Level 1

          Hi Nathan,


          I just imported your PDF into my webhelp project (RH8), generated it, and searched for "dog" (which appears in your PDF but not in my web help!). I got one hit, which took me directly to your PDF. So I don't think it's a Robohelp problem.


          Here's how I linked to the PDF--is this what you did?


          1. Insert text for the link.

          2. Select the text.

          3. Insert Hyperlink.

          4. Link To: File.

          5. Navigate to the PDF on your hard drive (does not need to be in the project yet).

          6. Click OK.

          7. When prompted if you want to add the file to the project, click Yes. (this is what adds the file to the Baggage Files).


          When I generated the output, there was a step for "Processing Full-text-search data," which took 20 seconds" (my help system has 186 topics plus your PDF).


          Hope this helps,



          • 2. Re: Robohelp 8 - Not searching PDF
            nwhite9327 Level 1

            Hi Kathy,

            Thanks for testing it out.  Yes that is the exact process that I did.


            So after you compiled and then you searched "dog" in Robohelp, it brought the .pdf as a search result?


            Hmm.  Ya I'm starting to believe it has something to do with how Robohelp was installed, full rights or something.  It doesnt make sense to me but has been driving me nuts trying to figure out why it does that.



            • 3. Re: Robohelp 8 - Not searching PDF
              kmaddox1 Level 1

              yup. I searched for "dog" in the output and there was one result. I clicked the result and your pdf opened.


              BTW, I am an admin for my computer and I was the person who installed RH. That may be why it is working for me but not you.


              Also, what Additional Options do you have selected for the WebHelp layout? I have W3C Compliant Topics selected, but nothing else. Are your settings the same?




              • 4. Re: Robohelp 8 - Not searching PDF
                nwhite9327 Level 1

                Here are the settings I am using, actually, I didnt have the W3C Compliance checked, but I just tried it and it still didnt find anything within the PDF.


                This is a project I just created to test the specific PDF file.


                • 5. Re: Robohelp 8 - Not searching PDF
                  kmaddox1 Level 1

                  your settings are equivalent to what I have, and PDF search works for me. Go figure. Maybe try reinstalling RH or getting some additional rights to your PC.


                  BTW, did you look at the SALIdxSvc12.xml file in the Program Files (x86) > Adobe > AdobeRobohelp 8 > RoboHTML directory? (referenced in a related post).


                  Mine looks like this. I think the circled line is what allows PDFs to be indexed for search:


                  5-5-2011 3-39-03 PM.png













                  (BTW, the only issues I've had with PDF search is when we generate the help in batch from the command line...for some reason, we can't do PDF search when we use that process.)


                  Good luck with it!



                  • 6. Re: Robohelp 8 - Not searching PDF
                    nwhite9327 Level 1

                    Ya I read a previous post about that the SALIdxSvc12.xml  file, it indeed

                    is also the first item in the list (*.pdf*)


                    I just compiled a sample project on a different computer under a different user and it found the word in the PDF file...so it definately is something with the installation of Robohelp.  I think tomorrow I'll reinstall Robohelp again and see if that resolves the issue and I'll let you know what happens.


                    Thanks for all the help =)