10 Replies Latest reply on Jan 19, 2012 8:38 AM by mSantirso

    XML version of design.xml: Expected XML version: 2

    jgolsteyn Level 1

      Hello all,

       

      I upgraded to Flash Builder 4.5 and now I get a warning/error for every library project that we have. But it seems to be a warning as I can use the custom library components in Design Mode.

       

      The error is in the tab: "Design Mode Problems"

       

      SWC Configuration issue:

      The XML version of design.xml and the expected XML version do not match.Some Design Mode features will not be available for components defined within the SWC
      Expected XML version : 2
      Actual XML version:  Unknown

       

       

      The design.xml document starts with:

      <?xml version="1.0" encoding="utf-8"?>

       

      I tried changing it to:

      <?xml version="2.0" encoding="utf-8"?>

       

      but no effect...

       

      Anyone has the same problem and knows how to fix it?

       

      Thanks!