5 Replies Latest reply on May 10, 2011 6:46 AM by precepts

    Can't open project

    precepts Level 1

      Using RH 8 with SourceControl with primarily one other user. We've been working successfully on a project until 2 days ago. I got message that cpd file was corrupt and deleted it.  Since around that time I haven't been able to open the project -- it tries to open, asks to get files from server, then hangs up while Reloading Files.  After searching the forum and seeing a similar issue, I went to Peter Grainge's site and tried to follow instructions for opening RH projects, beginning with installing service pack 8.0.2. Followed steps for Projects Under Source Control through Step 5 "You will be prompted to check out the FPJ files."  Instead, got error message:  "An error occurred while trying to save data to <each local fpj file>." Clicked okay, but then RH hung up again while progress bar for "reloading files."

        • 1. Re: Can't open project
          Peter Grainge Adobe Community Professional (Moderator)

          It works against your interests to put someone's name in the title of a thread as it tends to put off people who could otherwise help. By all means put a name in replies once someone has started as that does help grab our attention.

           

          The problem here is that I don't use source control, that section of the article was written by others who do. Hopefully one of them will pick up this thread so let's see what happens on Monday. If no one replies, post again and do start the body with "Peter". I will then see if I can get someone to take a look.

           


          See www.grainge.org for RoboHelp and Authoring tips

           

          @petergrainge

          • 2. Re: Can't open project
            Amebr Level 4

            It sort of sounds like a permissioning problem.

             

            Have you checked that the fpj files are checked out in source control? If not, perhaps manually check out a couple and see if the message goes away for those ones.

             

            If they are checked out already, check the properties of the files in Windows Explorer - are they Read Only? If so, untick the checkbox on a few and see if the message persists.

             

            Where are you getting the files to? I assume a local drive, but thought I'd check anyway.

            • 3. Re: Can't open project
              precepts Level 1

              Thank you, Amebr.

               

              When I look at the fpjs in RoboSource Control Admin, Local Copy Default Attributes is set to Read-Only.  Should I change it to Read-Write?  On my local drive, the properties for fpjs are Read-Only, although they show a current date, which is also set as a default in Admin.  

               

               

              Freda Brackley

              Training Specialist

              Dow Jones Training & Quality

              Chicopee, MA 01020

              413-598-2541

              • 4. Re: Can't open project
                Amebr Level 4

                Hmm I don't know how it should be set in RoboSourceControl as I don't use it. Hopefully someone who does can chime in about the correct admin settings.

                 

                In the meantime, if you check out the files, are the properties on your local drive still Read Only? You should be able to unset that property manually for a few files to check if it solves the error message. I don't think it will affect checking in/out of source control or anything.

                • 5. Re: Can't open project
                  precepts Level 1

                  Thanks for your help.  This was happening on two out of three PCs connected to the RoboSource Server, and the fix turned out to be copying the updated local files of the person who wasn't having the problem to the other local drives.  Doesn't seem logical, but it worked.