5 Replies Latest reply on May 16, 2011 7:47 AM by James G Maker

    New build RAID 0 frustration, need help please

    James G Maker

      After successfully assembling a new computer and installing Win7/64Pro on a SamsungF4-320g, I plugged in my 4 new Samsung F3 1TB into my ASUS p8p67pro.  Trying to create 2 RAID 0 sets with these F3s.  Spent too long on the phone talking to ASUS support and here's where they told me to plug the drives into.

       

      Marvell serial ATA 6.0Gb/s connectors.  (I have my 2 front case ports plugged in here)  ASUS said these won't support RAID

       

      4 Intel serial ATA 3.0Gb/s connectors    (I have 2- 1TB F3s plugged into these and my F4 for OS&Programs and my BD/DVD drive)

       

      2 Intel serial ATA 6.0Gb/s connectors  (I  have 2- 1TB F3s plugged into these)

       

      Powered up and got into the "bios" and under advanced menu>SATA config, set the SATA mode to (RAID mode), saved changes exit.

       

      A note under these instructions in the user guide says:

      "Due to chipset limitation, when set any of SATA ports to RAID mode, all SATA ports run at RAID mode together."

      I can't make enough sense of that.  Ignorance does have a cure, I just haven't found it yet.

       

      After powering up again entered the Intel Rapid Storage Tech Option ROM utility.  This utility showed my 5 hard drives and I created 2 RAID 0 volumes from the 1TbF3 drives with 128KB strip size.  Not sure if the strip size should be the same for both size, but blindly forged ahead.  Saved and reboot.......

       

      Computer went into a error screen giving 2 options,  Repair Windows and Start windows.  Tried (start windows) first and all it would do is come back to the error screen.  Tried (Repair windows) and after 15 min or so, it couldn't fix the problem either.

       

      Powered up and got into the "bios" and under advanced menu>SATA config, set the SATA mode back to  (AHCI mode), saved changes exit.

       

      Powered back up and win7 loaded fine, but no Raid 0 found.

       

      Not sure if I need to do something in Disk Management, or just head to the bar?

       

      Any help would be much appreciated.

        • 1. Re: New build RAID 0 frustration, need help please
          JEShort01 Level 4

          James,

           

          Intel makes a Matrix RAID manager application that runs from within windows. If you can download it from either Asus or Intel, possibly that utility would be able to "find" the missing drives / RAID 0's?

           

          Good luck!

           

          Jim

          • 2. Re: New build RAID 0 frustration, need help please
            Bill Gehrke Adobe Community Professional & MVP

            Be careful I think the Matrix RAID Storage Manager is for up to x58 based motherboards and the newer boards the Rapid Storage Manager is for use,  I do not know if they can be used interchangably.

            • 3. Re: New build RAID 0 frustration, need help please
              RjL190365 Level 4

              James,

               

              The "chipset RAID limitation" notice is worded incorrectly. It should have meant "you cannot enable RAID without also enabling AHCI", and that setting the chipset's controller to RAID mode will automatically enable AHCI. In other words, any non-RAID disk on a PCH controller set to RAID mode will operate in AHCI mode. If that limitation notice were true, each of the drives on that controller must be RAIDed with another drive in an array - a configuration that would not have supported any optical drives whatsoever. Plus, the Marvell SATA controller does not support optical drives at all - only hard drives. And since at least ICH10R (and probably the ICH9R as well), you can have a non-RAID disk on an ICH/PCH SATA controller set to RAID mode unless that system has a really old Matrix driver version that doesn't support non-RAID disks in RAID mode.

               

              And the second reply is partially correct: The Intel Matrix Storage Controller is usable only up to the ICH10 series SATA controllers. The SATA controller in the LGA 1156 and LGA 1155 chipsets' PCH must use the newer Intel Rapid Storage Technology driver (which is also compatible with earlier Intel SATA controllers).

              • 4. Re: New build RAID 0 frustration, need help please
                framednoise

                Hi James!

                 

                The problem is that you installed Windows 7 while the BIOS for the Intel controller was set to AHCI rather than RAID. When you then change from AHCI to RAID Windows won't start since it can't find the correct values in the registry/drivers. I did this too and was quite surprised as I initially thought that RAID was just AHCI with well, just an extra option that sure as heck wouldn't break my Windows installation.

                 

                However, this is a solution to this without having to re-install Windows (with the BIOS set to RAID this time). I haven't tried it myself but people in other forums have reported success with this method and you won't screw up anything anyway so it might well be worth a try.

                 

                Move your boot HDD from the Intel SATA controller port to a Marvell SATA controller port and make SURE that the Marvell controller is set to AHCI, NOT RAID. Keep the Intel controller in RAID mode. Change the boot order to point to the system disk on the Marvell controller. This way Windows should boot again and you can re-install the Intel Rapid Storage drivers, Windows will discover the Intel RAID controller and add the needed registry changes. Then turn off everything and move the boot HDD back to the Intel controller again. Windows should now load with the Intel controller set to RAID in BIOS.

                 

                And RjL, the Marvell controller DOES support optical drives, I'm running my DVD-burner off the Marvell controller on my P67-board without any problems (so far).

                1 person found this helpful
                • 5. Re: New build RAID 0 frustration, need help please
                  James G Maker Level 1

                  Little update.

                   

                  I did get the raid working a few days back.  Had to install Win7 2 or 3 more times with bios set to RAID first.

                  Windows decided to put a system reserved partition on one of my raid sets on my second install.

                  Had to disconnect them and install again on the C: drive ONLY.