7 Replies Latest reply on May 12, 2011 11:47 AM by adiabatic

    _movie.go question

    adiabatic Level 1

       

      Is there a limit on the length of a file name OR what characters cannot be in it? Other wise I don't

      understand why a _movie.go doesn't work. For example, this _movie.go works

       

      _movie.go(1,"@/Chapter_1/W1.1/W1_1sim")

       

      BUT this one does not.

       

      _movie.go("1,@Chapter_1/Exploration-1_2-CKS/Ex1-2CKSintro-5-6")

       

      and the buttons for these reside as sprites in the same column in the score.  Both are directed into

      the third folder.

       

      I am a retired faculty completing a textbook with interactive video in which I have used this response

      to a button click that I have not had trouble with before.  I would greatly appreciate any help on what

      is a frustrating problem with what should be a simple step.

       

      Fred Tabbutt

       

        • 1. Re: _movie.go question
          Production Monkey Level 3

          First Quote mark is in the wrong place.

          • 2. Re: _movie.go question
            adiabatic Level 1

            Thanks for your quick response.  But I'm afraid I mistyped the second one.

             

            This worked

             

            movie.go(1,"@Chapter1/W1_1sim <mailto:1@Chapter_1/W1_1sim> ")

             

            but this one didn't.

             

            movie.go(1,"@Chapter1/Exploration-1_2-CKS/Ex1-2CKSintro-5-6")

             

            I apologize for the confusion.  As a 79 year old I probably shouldn't be doing this anymore.

             

            Fred Tabbutt

            • 3. Re: _movie.go question
              Production Monkey Level 3

              I was hopeful that it was just a misplaced quote mark.

               

              I tried your code on my XP SP3 system and it works fine. I created the folders, the Director files, and used:

               

              on mouseDown me
                go(1,"@Chapter1/Exploration-1_2-CKS/Ex1-2CKSintro-5-6")
              end

               

               

              I have no idea why the code does not work for you. Do you get an error message?

               

               

              Perhaps there is a typo that you are not seeing. You should have someone else take a look at it. In my past I have wasted countless hours searching for a bug that I was blind to. I ask someone else to read the code and instantly they can see the typo that I was blind to.

              • 4. Re: _movie.go question
                adiabatic Level 1

                To demonstrate how wierd this problem is I have attached copies of the screen where in the first one Lingo is asking where the file is that is right below it and then in the second frame that follows the first is the inability to find it.

                 

                I will create new alternative files with more comact names and see if that is the problem.  But it takes a while to do that.

                 

                Thanks again for your support.

                 

                Fred Tabbutt

                • 5. Re: _movie.go question
                  Jim Wiley Level 1

                  Hi All,

                  If I remember correctly some objects don't like certain characters in their names.

                  You might want to try removing the hyphens.

                  ~

                  Jim

                  • 6. Re: _movie.go question
                    adiabatic Level 1

                    Problem Solved  ... Cause remains a mystery

                     

                    I am happy to report that I got the Director program to work like it should.  I have two major folders for this project: one where the projector is created that includes script files for it all photos and video ... some of which may not appear in the final version and when I get the projector to work I copy it into the final folder along with accompanying QT movies.  So I finally gave up on the previous projector in the final folder and recopied a copy (with a different name) into the final folder, then used exactly the same _movie.go... command and everything worked!  So I moved the troublesome projector into the trash but never really understood what the problem was.

                     

                    At any rate, I appreciate the effort you put into this and your helpful suggestions.

                     

                    Fred Tabbutt

                    • 7. Re: _movie.go question
                      adiabatic Level 1

                      Thanks Jim.  I was worried about that as well.  But then I  replaced it with a different projector using the same name protocol and it worked. So I don't know what was going on but the good news is that the problem is solved.

                       

                      Thanks for your comment.

                       

                      Fred