4 Replies Latest reply on May 12, 2011 9:24 PM by RoboAsh

    Robohelp 9 stops responding every 20 minutes

    NHLAGB

      Hello,

       

      My company recently upgraded from RoboHelp X3 to RoboHelp 9. On one writer's machine, RoboHelp is crashing every 20 minutes or so. Here are the specs:

       

      Windows 7

      Intel Core 2 Duo CPU T9300 @ 2.50 Ghz

      4 GB RAM

      64-bit operating system

      232 GB hard drive with 176 GB of free space

       

      The project the writer is working on has been upgraded from an X3 project with the old .mpj file extension. Microsoft's Event Log reports that the file shortcut.oxc is causing RoboHelp to stop interacting with Windows. Here's a screenshot from the MS Windows Action Center.

       

      Scrren1.jpg

       

      FWIW, another writer on an XP machine is not running into any crashing issues. Both writers are working on local copies of the same upgraded project.

       

      Any ideas?

       

      Thanks!

        • 1. Re: Robohelp 9 stops responding every 20 minutes
          Peter Grainge Adobe Community Professional (Moderator)

          The error message is probably something only an Adobe engineer would be able to follow.

           

          It's unusual for different authors to work on copies of the same project because later the two have to be brought into one. That makes me wonder if there is some little nugget of information related to this that would be relevant. Maybe some comment on the process woudl help.

           

          Otherwise...

           

          1. Try the old trick of deleting the CPD file and reopening the project.
          2. Is the project located in My RoboHelp Projects? If it is move it to C:\ProjectName to shorten the path.
          3. Does this happen with the sample projects. Click Open on the RoboHelp Starter page and then click Samples in the ribbon on the left.

           


          See www.grainge.org for RoboHelp and Authoring tips

           

          @petergrainge

          • 2. Re: Robohelp 9 stops responding every 20 minutes
            NHLAGB Level 1

            Hi Peter,

             

            Thanks for the advice. We tried all three of your options, but RoboHelp still stops responding, even in the sample projects.

             

            The writers here do not typically work on different copies of the same project; we did in this case to see if we could reproduce the problems we are having on the Windows 7 64-bit machine. As mentioned, we have had no issues on the XP machine.

             

            We are having our IT department uninstall and re-install RoboHelp on the Win 7 machine sometime today, hopefully, just in case something didn't install correctly the first time around.

             

            The other possibility is that some problem was introduced in the 9.01 RoboHelp update. The RoboHelp install on the XP machine has not been upgraded to 9.01 yet; the Win 7 machine has been upgraded. We'll have IT reinstall RoboHelp on the Win 7 machine without applying the update to see if that makes a difference.

            • 3. Re: Robohelp 9 stops responding every 20 minutes
              Peter Grainge Adobe Community Professional (Moderator)

              That sounds like a good idea. Having said that I do know of users on Windows 7 64 bit who are working without such a problem.

               

              Please let us know how it goes.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

              @petergrainge

              • 4. Re: Robohelp 9 stops responding every 20 minutes
                RoboAsh Level 2

                Hi,

                    just to update the new patch 9.0.1 does not have anything which could cause this crash if properly installed. Please go ahead and update RoboHelp on the XP machine (it will confirm if this is creating an issue).

                 

                One info needed here is that were you guys using the .chm output and if yes are you having HTML Help controls in the project (these are the one which uses the shortcut.ocx file) so this can be the issue so try to remove them in a copy of the project and see if it helps.

                 

                Can you please share the crash dump of RoboHelp when it crashes in Win 7 (In Win 7 on any application crash you can open the Task manager and RightClick on the process which crashed and created Dump File) and mail it to me  - ashishchandra.gupta@gmail.com.

                 

                One more thing that can be tried is to install RoboHelp on any other Win 7 64 bit machine and see if it is not a machine specific issue.

                 

                Hope this helps

                Ashish