31 Replies Latest reply: May 14, 2011 7:30 PM by DaveMcKeen RSS

    PS CS5(64) OpenGL Drawing Not Enabled by Default

    DaveMcKeen Community Member

      Hello!  I have a PC I built last fall (PC2) I'm now grooming to be my main PC.  I'm preparing to rebuild my current main PC (PC1).  PC2 will soon have to do the heavy lifting.  PC2 has a performance problem;  I noticed when I was going through Photoshop CS5 (64-bit) preferences.  On the Performance page, GPU Settings area, Enable OpenGL Drawing is not checked by default.  (In my retiring PC1 Enable OpenGL Drawing is checked by default and the video adapter is listed in the area.)

       

      I have this related oddity I hope we can troubleshoot:  When I drag to move or resize a window in PC2 only the outline moves or resizes until the mouse button is released.  (In my PC1, the windows move /resize as they are dragged.)  Any ideas where to start looking for the cause?

      I had the identical nVidia driver on both PCs.  Just this afternoon I did a clean install of the latest nVidia driver, 270.61 on PC2.  It made no difference.

       

      BTW, the motherboard, CPU, GPU (ZOTAC  ZT-98GES3M-FSL) and data HDD are the same model on both PCs.

       

      Here's my PC2 List:
      ASUS  P7P55D Deluxe  LGA 1156 Intel P55
      CPU  Intel  Core i7-870  2.93GHz LGA 1156
      DRAM  Corsair  CMX8GX3M4A1333C9  4 x 2GB DDR3 1333 (PC3 10666)
      GPU  ZOTAC  ZT-98GES3M-FSL  GeForce 9800 GT 512MB 256-bit GDDR3
      PSU  Corsair  CMPSU-750TX  750W
      Drive 0  (O/S) OCZ  OCZSSD3-2AGT90G  3.5" 90GB SATA II
      Drive 1  (Data) Hitachi  0F10452  2.0TB SATA 3.0Gb/s 7200 RPM 32MB
      Drive 2  (Apps, Web site, Pgms & Updates) OCZ  OCZSSD3-2AGT90G  3.5" 90GB SATA II
      CPU Heat Sink  ARCTIC COOLING    Freezer 7 Pro rev 2  92mm CPU Cooler
      O/S  Microsoft  GFC-00019  Windows 7 Home Premium 64-bit
      Monitor  NEC   LCD2190 UXi  LCD 'twist' tech.

       

      I'll appreciate any help that gets this resolved.

       

      Thanks - Dave

        • 1. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
          Noel Carboni Community Member

          It sounds like it might be a physical failure of part of the GPU in your second system.  Try swapping the cards between the system to see if the problem follows a particular card.

           

          -Noel

          • 2. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
            PECourtejoie CommunityMVP

            It looks like 270.73 fixes some openGL issues for the video applications, but it might only be available for QUADRO cards. Still, it's  worth researching.

            • 3. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
              DaveMcKeen Community Member

              Hi Noel,

               

              Sounds like a plan.  However I have a ZOTAC  ZT-40503-10L GeForce GTS 450 (Fermi) 1GB 128-bit GDDR5 for the rebuild of the older PC.  I uninstalled everything nVidia I could see then installed the GTS 450.  Now Photoshop enables OpenGL Drawing by default and lists the nVidia details in the GPU Details section.  However when I drag any window I see I'm dragging only the window outline, not the entire graphic of the window.  Do you think I should still try my main PC's 9800 GT in the newer PC (PC2)?

               

              I have been using the newer build to process proofs from photo sessions.  There are usually 800-1000 images (from a Canon 5D MKII) after a shoot.  I've been using ACDSee to quickly generate a Web gallery.  Then I have a batch I run in Photoshop (after hitting Tab to clear the screen) to add a Proof stamp and do a little sharpening.  Before "bulking up" PC2 to make it ready for main use the batch process would literally fly- about three images per second.  All I could see on the screen was a flash of the original (Web-size) image and mostly the transparency mesh.  I was afraid that when I started adding complexity to the PC the batch would slow down.

               

              It did slow down.  It runs about half as fast now.  I can see each step in the batch process and never see the transparency checkerboard.

               

              So..., I reinstalled the suspect 9800 GT card.  Photoshop recognizes it, has OpenGL Drawing enabled by default and has the GPU details in the GPU Details box.  I just could have re-seated the sucker!  But dragging a window still only drags its outline.

               

              But guess what?  The batch runs at the slower speed like I described above for the GTS 450.  It's got to be that I've given the computer more to do- like more services running in the background.  I kind of suspected this would be the case.  That's why I kept this newer PC "pristine" and didn't make it 'main" since last September because it was processing proofs so fast.

               

              Maybe the newest build will run the batch really fast- until I load it up to make it main!

               

              Thanks, - Dave

              • 4. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                Noel Carboni Community Member

                Honestly, I have not experienced a slowdown since my initial Windows 7 install, but then I have tweaked my Windows 7 setup a good bit.  That may say something I tweak avoids the slowdown you're seeing.  And I may know what...

                 

                One thing I often advise people to do is to disable Windows 7 Indexing.  This virtually always frees up computer time and resources for your apps with very little downside (and even some upside).

                 

                Somewhere here I have a thread where I describe exactly how to do that.  Basically it's a matter of stopping the indexing service, deleting the index, and setting a few other things so that they don't expect indexing to be available.

                 

                Since I'm not sure where that thread has gone, I'll reprint some tweaks from the "how to" guide I've put together in subsequent posts here...  Give me a few minutes...

                 

                -Noel

                • 5. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                  Noel Carboni Community Member

                  Disable Indexing

                   

                  Indexing is supposed to make it quick and easy to find things on your computer using Windows Search (that little box at the upper-right of Explorer windows).

                   

                  But when you think about it, does it make sense to read all the files on your disk, extract everything you could possibly want to search for, and store it on that same disk another way?  To even consider indexing providing better performance than just searching the files, Microsoft must be picking and choosing the data they think you'll want to look for (excluding data you WON'T want to search for), where you'll want to search, and in what kinds of files, and in fact they are.  How could they know everything you'll ever want to search for? 

                   

                  They can't.  Not everything is indexed, and never will be!

                   

                  Try this:  Create a simple text file on your disk, in a temporary folder.  Call it "FindMe.log" and put in the text "This file contains important tax information".  Now navigate to that folder with Explorer and enter the word "tax" into the Search box at the upper-right.  Enter any of the words in that file!  Windows Search will not find the file, because it simply does not LOOK in .log files by default, and there's no fallback strategy - Windows Search simply does not index nor search for information for some kinds of files. Incredible!

                   

                  All it takes is ONE TIME searching for something you know is there and NOT finding it to destroy your confidence in Windows Search.

                   

                  And so they scan through your files endlessly, pick out the strings you might someday search for, and store them in yet another set of files (the "index").  As though your computer has nothing better to do.

                   

                  Not only is the basic premise of this wrong, but it's not even implemented very well.  The index often becomes corrupted, and so Microsoft has provided functions for you to clear and regenerate it.  Just what you wanted to be doing - NOT.

                  Consider these shortcomings:


                  • Some file types are simply not indexed or searched by default – e.g., .log files, and there's no fallback.  If you create a new file type no one's seen before, its contents will not be indexed.

                   

                  • Only strings they think you are likely to search for are indexed.

                   

                  • Because of poor implementation, indexing will miss things in some file types that are indexed – e.g., older Microsoft Word documents or files containing Unicode text (Microsoft's own invention).

                   

                  • Indexes often become corrupted and the Windows Search results fall out of date or it stops finding things entirely.

                   

                  • Indexing operations use computer time, increase disk wear, and interfere with your own access to your files.

                   

                   

                  In summary, indexed Windows Search operations in Windows 7 simply can't be trusted to find your data in your files when it's critical, and so they're essentially useless.  Searching for filenames using Windows Search actually can be occasionally useful (though the syntax to ensure it searches only filenames is a bit tricky), but this doesn't require indexing.

                   

                  Moreover, indexing can actually interfere with file operations, causing your system to report disk corruption, because of an implementation error in indexing and NTFS (search the web for "Atomic Oplock", for example).

                   

                  So indexing should simply and utterly be disabled.  This won't actually stop you being able to try Windows Search - on the contrary with indexing off Windows 7 will actually search your actual files (within the limitations listed above) just when you tell it to, and (since indexing isn't implemented very well) it may actually INCREASE the probability that you might find what you're looking for.

                   

                  Here's how to disable indexing:

                   

                  1. Click Start and enter services in the search box.
                  2. When Services (with little gears) comes up, click it.
                  3. Scroll down to the Windows Search service.
                  4. Right click it and choose Properties.
                  5. Change the Startup type to Disabled.
                  6. Click [ Stop ] to stop the service.
                  7. Click [ OK ].
                  8. Click Start and enter index in the search box.
                  9. When Indexing options comes up, click it.
                  10. Click the Advanced button.
                  11. Click the [ Rebuild ] button to delete the index.
                  12. It is a good idea to reboot after this.

                   

                  So your searches work properly and you're not nagged by Windows to reenable indexing:

                   

                  1. Open a Windows Explorer window.
                  2. Choose ToolsFolder Options.
                  3. Click the Search tab.
                  4. Click the button next to "Don't use the index when searching in file folders for system files (searches might take longer)".
                  5. Click Start and type group policy into the search box.
                  6. When Edit Group Policy comes up, click it.
                  7. Navigate to User ConfigurationAdministrative TemplatesWindows ComponentsWindows Explorer.
                  8. Enable the Turn off Windows Libraries features that rely on indexed file data entry.
                  9. If you do not have the Group Policy Editor on your version of Windows, change this registry entry:

                    HKCU\Software\Policies\Microsoft\Windows\Explorer

                    DisableIndexedLibraryExperience = 1

                  • 6. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                    Noel Carboni Community Member

                    Here's another performance tweak:

                     

                    Improve Disk Cache Efficiency

                    Windows 7 does not enable one of its best features out of the box:  The ability to cache disk writes in RAM then write the data to the disk as efficiently as it can.

                     

                    Instead, Windows 7 runs with write-cache buffer flushing enabled by default. This essentially makes applications wait for the hard drive to finish writing their data before allowing them to continue, which slows things way down.

                     

                    They probably don't enable this feature by default because you risk losing more data on a crash or power loss.

                     

                    With this function disabled, however, and the full power of the disk cache brought to bear, the OS is free to batch together disk writes and schedule them to maximize throughput and minimize seeking.  You will hear a physical difference as the drive will not seek nearly as much.

                     

                    If your computer is stable and reliable, you have battery backup, and you have sufficient RAM, you can confidently disable write-cache buffer flushing to really speed disk writes up.  Do this for each internal disk drive for which you want to speed up access.

                     

                    To Turn Off Write-Cache Buffer Flushing

                     

                    1. Open an Explorer Window.
                    2. Right click on your C: drive and choose Properties.
                    3. Click the Hardware tab.
                    4. Click on the physical hard drive for which you want to change the setting to highlight its name.
                    5. Click the [ Properties ] button.
                    6. Click the Policies tab.
                    7. Check the box next to Turn off Windows write-cache buffer flushing on the device.

                     

                    -Noel

                    • 7. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                      Noel Carboni Community Member

                      Another tweak...

                      Speed Up NTFS File Access

                       

                      When Windows accesses a directory or file on an NTFS volume, whether just for reading or not, it updates the "Last Accessed" time stamp.  Since many files are typically accessed in a read-only fashion, this results in a lot more disk writes than you'd expect.

                       

                      Very few programs rely on the "Last Accessed" time stamp, and if you don't personally plan to use it (via the Properties menu for a file or folder), then you can disable this update:

                       

                      Execute this command:

                       

                         fsutil behavior set DisableLastAccess 1

                       

                      Alternatively, add or change this registry value, if it is not already set:

                       

                      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]

                       

                          "NtfsDisableLastAccessUpdate"=dword:00000001

                       

                       

                      ---------------------

                       

                      The Windows 7 file system also still generates old 8.3 format file names for each file you store on your disk.  Unless you have old (ancient) applications that require 8.3 filenames, you can disable creation of the 8.3 format filename to increase performance a little more:

                       

                      Execute this command:

                       

                          fsutil 8dot3name set 1

                       

                      Alternatively, add or change this registry value:

                       

                      [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]

                       

                          "NtfsDisable8dot3NameCreation"=dword:00000001

                       

                      -Noel

                      • 8. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                        DaveMcKeen Community Member

                        Wow, that's a treasure of info!  I'm working on implimenting it all.  Just finished Rebuild the index to delete it.  I'll report back.

                         

                        - Dave

                        • 9. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                          DaveMcKeen Community Member

                          I hit s couple of snags.  One is that nothing I type into Start/Search returns any results.  Haven't we disabled this thing?  In properties for the hard drives I have indexing turned off for each one.  That wasn't in your tips.  Should I enable it for C:\?

                           

                          In regedit I don't see 'Explorer' in HKCU\Software\Policies\Microsoft\Windows\.  Only 'Current Version'.  I'm running Home Premium.

                           

                          - Dave

                          • 10. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                            Noel Carboni Community Member

                            You do not need indexing on to be able to search the Start menu.  In fact, I find it works quickly and if anything more reliably with it off.

                             

                            Did you complete the very last steps of the "Disable Indexing" section, and have you logged-off and on again?

                             

                            -Noel

                            • 11. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                              Noel Carboni Community Member

                              Oops, I noticed the second half of your question.

                               

                              If you need to, create a new Key under HKCU\Software\Policies\Microsoft\Windows called Explorer, then create the DisableIndexedLibraryExperience value.

                               

                              -Noel

                              • 12. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                DaveMcKeen Community Member

                                OK, I completed all the steps in "Disable Indexing" including creating "DisableIndexedLibraryExperience" with a value of 1 in HKCU\Software\Policies\Microsoft\Windows\Explorer.  I restarted the PC.  I still don't get any results in Start/Search on search terms like regedit or group policy.  Let me know if you want dialog box screen shots.

                                 

                                I've completed 'Improve Disk Cache Efficiency'.  I will now continue following your instructions with the two steps in 'Speed Up NTFS File Access'.

                                 

                                - Dave

                                • 13. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                  DaveMcKeen Community Member

                                  I've done the steps in Speed Up NTFS File Access using the Command Prompt.  I went into regedit and verified that the keys and values are the way you show them.  Your format, eg. "NtfsDisable8dot3NameCreation"=dword:00000001 is different than the way I see it in regedit but I

                                  believe they are the same.

                                   

                                  I ran my "proof stamp" batch again.  It looks like I have my speed back.  (Yay!)  Maybe a little faster, like closer to four (Web-size) images per second.  Photoshop still displays all the steps in the processing of each image rather than showing the transparency mesh most of the time, but the difference might be due to the re-seating of the 9800 GT card and the resulting additional functionality.

                                   

                                  Many thanks!  I will keep the "speed up my PC" instructions handy to use with my latest build.

                                   

                                  Please let me know if you can think of steps I can take to get Start/Search to return results.

                                   

                                  - Dave.

                                  • 14. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                    Noel Carboni Community Member

                                    Oh, I believe you that you're not seeing the search results.

                                     

                                    There's clearly something I've done that you have not - or a difference between Windows 7 Ultimate (which I'm running) and your version.  I don't really believe the latter.

                                     

                                    After having disabled indexing, did you delete the index?  Start - Control Panel, [Advanced] button, then [Rebuild] (which clearly will only delete).

                                     

                                    I'll be very curious to hear whether these tweaks boost your image generation process speed back up to what you saw before.  I suspect the disk caching will help a lot.

                                     

                                    -Noel

                                    • 15. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                      DaveMcKeen Community Member

                                      I was anxious to report my results but for some reason I sat on my reply while I was doing other things.  By the time I discovered my mistake I got my reply posted only a munite before your last one.  I hope this puts us back in sync.

                                       

                                      I did follow the instructions to delete the index via rebuild, but was not sure if it "took".  I will repeat the steps and report back.

                                       

                                      - Dave

                                      • 16. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                        Noel Carboni Community Member

                                        Very glad to hear these tweaks have helped speed things up.

                                         

                                        I probably won't be online any more tonight, but I will definitely scout around tomorrow to see if I can figure out what's different regarding our Search boxes.  I'm confident we can get it to work.

                                         

                                        Good night.

                                         

                                        -Noel

                                        • 17. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                          DaveMcKeen Community Member

                                          I am very happy with the results!  I will run through the Indexing steps again in the morning and see if I can find where I went off the beaten path.

                                           

                                          Good night!  - Dave

                                          • 18. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                            DaveMcKeen Community Member

                                            Noel, I went through all the steps in your tips again and I can't find where I"ve gone wrong.  Still no results in Start>Search.  When I do the Rebuild to delete the index, the list "Index these locations > Included Locations" is empty.  Is that proof the index has been deleted?

                                             

                                            When we stop the Windows Search service do we not stop search results from showing up in Start/Search?

                                             

                                            Here is a screen shot of Folder Options > Search.  Do have the settings right?

                                            Folder Options Search Tab.JPG

                                             

                                            Thanks, - Dave

                                            • 19. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                              Noel Carboni Community Member

                                              DaveMcKeen wrote:

                                               

                                              When we stop the Windows Search service do we not stop search results from showing up in Start/Search?

                                               

                                              No, I promise.  I would not stand for that.

                                               

                                              StartMenuSearch.jpg

                                               

                                              In your Search tab that you've shown above, try setting the "Always search file names and contents (this might take several minutes).

                                               

                                              This is what I have set:

                                               

                                              SearchSettings.jpg

                                               

                                              If changing these settings doesn't work, I suspect there may have been a problem with that Explorer key you had to add to the Registry.  Can you open that key and do a screen grab please?  Maybe something's not quite right there.  Here's what mine looks like:

                                               

                                              RegistryKey.jpg

                                               

                                              -Noel

                                              • 20. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                DaveMcKeen Community Member

                                                Noel,

                                                 

                                                I changed "What to search" in Folder Options > Search.  Here is my DisableIndexedLibraryExperience screen:

                                                 

                                                DisableIndexedLibraryExperience.JPG

                                                How about if I run Microsoft's "Fix Windows Search when it crashes or is not showing results"?  If it restores my search then I can go through your steps and see what it changed.  If it restores indexing I could then go through your steps one at a time, rebooting and testing to see where the search stops working.

                                                 

                                                - Dave

                                                • 21. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                  Noel Carboni Community Member

                                                  Nope, I see the problem.

                                                   

                                                  Your DisableIndexedLibraryExperience value in the registry is a string, not a DWORD.

                                                   

                                                  Delete it and add it again as a new DWORD value.

                                                   

                                                  -Noel

                                                  • 22. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                    DaveMcKeen Community Member

                                                    I never would have caught that.  Good eyes!  Here's what it looks like now:

                                                     

                                                    DisableIndexedLibraryExperience-DWORD.JPG

                                                    I'm not seeing any difference in Start/Search.  What do you think I could try next?

                                                     

                                                    BTW, thanks for sticking with me on this.  I appreciate it very much.

                                                    • 23. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                      Noel Carboni Community Member

                                                      Did you log off and on again after making that change?

                                                       

                                                      -Noel

                                                      • 24. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                        Noel Carboni Community Member

                                                        If the above doesn't work, I've some other information:

                                                         

                                                        Open Regedit and look in this HKEY_CURRENT_USER key:

                                                         

                                                          \Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

                                                         

                                                        Look for these values:

                                                         

                                                          Start_SearchFiles

                                                          Start_SearchPrograms

                                                         

                                                        Do they exist?  If so, what are their values.

                                                         

                                                        From what I've been reading, they should both be DWORD values of 0x00000002.

                                                         

                                                        -Noel

                                                        • 25. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                          Noel Carboni Community Member

                                                          Even something else to check...

                                                           

                                                          Under HKEY_CURRENT_USER:

                                                           

                                                            \Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

                                                           

                                                          Do you see any values of the following form?

                                                           

                                                            NoSearchXXXXXXInStartMenu

                                                           

                                                          -Noel

                                                          • 26. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                            DaveMcKeen Community Member

                                                            In the PC we're diagnosing the two keys are in \Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced with values of 1 and 0 respectively:

                                                             

                                                            Explorer-Advanced(MyNewerPC).JPG

                                                            In my older PC I'm preparing to replace only  Start_SearchFiles appears and that has a value of 2:

                                                             

                                                            Explorer-Advanced(MyOlderPC).JPG

                                                            In \Software\Microsoft\Windows\CurrentVersion\Policies\ I have no 'Explorer' on either PC.

                                                             

                                                            - Dave

                                                            • 27. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                              Noel Carboni Community Member

                                                              Change that Start_SearchPrograms value to 2.

                                                               

                                                              This is the meaning of the various values:

                                                               

                                                              Don't search: 0

                                                              Search with public folders: 2

                                                              Search without public folders: 1

                                                               

                                                              I don't think there are any public folders in the Start menu, but 2 seems the most liberal setting.

                                                               

                                                              -Noel

                                                              • 28. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                                DaveMcKeen Community Member

                                                                OK, I will do that.  I have an all day shoot tomorrow and have to start preparing now.  I will be back on this Sunday morning.  I will report back.  Thanks again.

                                                                 

                                                                - Dave

                                                                • 29. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                                  DaveMcKeen Community Member

                                                                  Eureka!  I was cleaning up the Start Menu in a laptop after I signed off last night.  Near the bottom of the Configure tree I saw radio buttons under 'Search other files and libraries'.  So I fired the subject PC back up and sure enough, the radio button next to 'Don't search' was selected.  I changed it to Search with public folders' and sure enough, I can not search in the Start/Search box!  Not only that, but in the registry Start_SearchFiles now = 2 and Start_SearchPrograms

                                                                  now = 1.  So I wound up backing into your last instruction.  All appears to be working.

                                                                   

                                                                  I am forever grateful for the outside of Photoshop help!  If you need any additional feedback please let me know.

                                                                   

                                                                  - Dave

                                                                  • 30. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                                    Noel Carboni Community Member

                                                                    That's great news.

                                                                     

                                                                    I'll add checking that setting to my instructions for next time. 

                                                                     

                                                                    -Noel

                                                                    • 31. Re: PS CS5(64) OpenGL Drawing Not Enabled by Default
                                                                      DaveMcKeen Community Member

                                                                      Thaks again!  I see a couple of potential stickies here.   

                                                                       

                                                                      - Dave