4 Replies Latest reply: May 13, 2011 10:15 AM by stuart905905 RSS

    Help! Can't use Text tool in Photoshop CS5

    alansky1 Community Member

      When I launched Photoshop this morning and opened a file containing text and an image, I got the following error message:

       

      "The type layers in this document were rasterized because something prevented the text engine from being initialized."

       

      When I created a new, empty Photoshop document and selected the Text tool, I got this error message:

       

      "Could not complete your request because of a program error."

       

      The Photoshop text tool is useless at the moment. I tried relaunching Photoshop and restarting my computer to no avail.

       

      Nothing has changed in my Photoshop installation except that I recently installed FontExplorer X Pro on this computer and activated the Photoshop CS5 plugin that comes with the program. I have now uninstalled the plugin, but the Photoshop text tool still doesn't work.

       

      Suggestions greatly appreciated. I need access to a fully-functional Photoshop ASAP. Thanks!

        • 1. Re: Help! Can't use Text tool in Photoshop CS5
          alansky1 Community Member

          UPDATE: I was able to restore Photoshop to normal operation by reinstalling the Photoshop CS5 application.

           

          Since I installed FontExplorer X Pro shortly before discovering this Photoshop problem, I suspect FontExplorer's Photoshop plugin as the possible cause of the problem. I would appreciate hearing from anyone who is successfully using FontExplorer X Pro with the Photoshop CS5 plugin installed.

          • 2. Re: Help! Can't use Text tool in Photoshop CS5
            stuart905905 Community Member

            I am now getting the same errors on one of my computers, I am running an imac which is giving me that error but on my macbook pro i am not getting it. I have the exact same software on each of them. I cant figure out why it is fine on the macbook pro but wont work on the imac. I am running suitcase fusion 3 on both computers. Any help would be appreciated.

            • 3. Re: Help! Can't use Text tool in Photoshop CS5
              alansky1 Community Member

              Since you're having the same problem with a different font manager installed, it looks like the problem may lie with Photoshop rather than the font management software. I'm going to file a bug report with Adobe.

               

              Meanwhile, you might want to uninstall Photoshop CS5 (Utilities/Adobe Installers/Adobe Creative Suite 5 Design Premium) and reinstall it from the original disc. You do not need to deactivate anything before doing this.

              • 4. Re: Help! Can't use Text tool in Photoshop CS5
                stuart905905 Community Member

                I just did a bit of playing around, I managed to get it to work but i had to turn all my fonts in suitcase fusion 3. The problem might actually be the font managers plug ins, right now the only fonts i am using in it are the system fonts. I'm going to explore more when i get a chance but at least its a quick fix for anyone with the same issue.