4 Replies Latest reply on May 13, 2011 7:58 AM by Captain Slocum

    Avoiding preview stuttering problems

    Captain Slocum Level 1

      I am creating a new post here as I marked the last one I posted on this subject as answered.

       

      In that post I asked would a new graphics card help to eliminate the severe stuttering caused by my windows xp machine (2 intel P4 processors 3.2) failing to decompress the MP4 files from my Sony NEX-5 quickly enough? The answer was an unequivocal NO as it was the processors, not the card.

       

      Since then I have been doing some experimentation:


      I downloaded trial versions of Cyberlink Power Director and Sony Vegas Movie Studio HD Platinum 10. The latter stuttered worse than PE but the Cyberlink app had almost faultless previews - no stuttering. Unfortunately it is a pretty horrible programme otherwise, and any case I am used to Premiere having use an early version of PP for years, so I experimented some more:


      In PE I created a project with a project setting of PAL-AVCHD-HD 1081i25, loaded some MP4 clips taken with theNEX 5 on the MP4 1440 x 1080 setting and then burnt the project to DVD.

       

      I then saved the movie as an AVI, removed the original MP4 clips and imported the AVI file I had just made. The project asked me if I wanted to change the project settings to match the clip and and I said yes. I then burned this to a DVD.

       

      I then deleted the AVI clip and imported the original MP4 clips (into what is now effectively a PAL-DV-Widescreen 48KHz project setting I imagine). This time I was not asked if I wanted to change the settings but a red line appeared above the clips indicating they needed rendering. I rendered them and  - voila! No stuttering - perfectly smooth preview of the MP4 clips. I then burned this to DVD.

       

      Next I compared the DVDs on a Sony 42inch HD TV. No difference! All three of very good quality, at least to my eyes..


      So what is happening here? When I rendered the clips in the PAL DV project was it turning them into  AVI files because of the project settings? And is it that the first DVD (with the MP4 clips straight from the camera), which I would have expected to be of better quality than the other two, was not actually producing a HD DVD inspite of the camera and project setting?

       

      Is the only way I am going to get true HD to set the camera to AVCHD and burn to Blu-Ray?

       

      If any one has knowledge of these things I would love to hear from you as while I seem to have found an answer to the stuttering I would love to know what is going on and if I am fooling myself. Many thanks.

        • 1. Re: Avoiding preview stuttering problems
          Steve Grisetti Adobe Community Professional

          Overall, you seem to be doing MOST of the right things.

           

          Is your video really coming out as MP4s? That camera should be producing M2T or MTS video, if you are using Premiere Elements Get Media tool to download it from the camera.

           

          That said, when you place your video on your timeline, is there a red line above it? If your project specs match your video, you should see no red line above the clips until you add effects or transitions to it.

           

          It's a good plan to use Share/Computer/AVI to output a DV-AVI from your AVCHD project. But you should start a new project (using DV settings) and import that AVI of your finished project into it rather than re-using the AVCHD project. It's quite possible this will eliminate your problem.

           

          Stuttering is most often caused by an interlacing conflict -- using an AVI in an MPEG project or vice versa. If you're putting the DV-AVI into your AVCHD project, you are causing an interlacing conflict.

           

          Starting a new DV project and using your DV-AVI in it will eliminate your conflict and your DVD results should not stutter.

           

          Remember: AVIs only in DV projects: MPEGs (which include M2Ts, ,MTSs and AVCHD video) only in MPEG projects.

          1 person found this helpful
          • 2. Re: Avoiding preview stuttering problems
            Captain Slocum Level 1

            Thanks for the reply.

             

            I have not explained myself very well.

             

            There is no problem with the DVDs - whatever settings I use to edit, the DVDs play very well, smooth and reasonably high quality in my estimation..

             

            And as far as I know there is no interlacing going on as I am not using the camera's highest avchd setting (which is interlaced), only the 1440x1080 MP4.

             

            The problem is with the editing previews, which when I open an HD project and import my MP4 camera files is very jerky to the point of being almost unusable at times, with long waits during operations. A look in Window Task Manager shows both CPUs maxing out all the time. According to the reply I had from an earlier post, this is because my CPUs are not up to the job of decompressing the MP4 files on the fly.

             

            What I have found is that if I import my MP4 files into a project with DV settings, I get a red line above the timeline. If I then render the clips, the editing improves dramatically - no stuttering at all and no long waits after mouse clicks or key presses and the CPUs only working at about 50%. Of course it can take a while to render a number of clips, but I can go and do something else while that is happening and when I return the editing goes like clockwork.

             

            My question is - what is happening to the quality of the video? I cannot see any difference in output (DVDs) whatever project settings I use, they all seem equally good. So hopefully I have found an answer to the preview stuttering problem. But I suspect I am not getting real HD from any of them. To do this I imagine I need to set the camera to AVCHD rather than 1440x1080 MP4 and burn to Blu-ray. This I have not tried yet as I do not have a Blu-Ray burner.

             

            My problem is my ignorance of what PE is doing to the MP4 files when it renders them. And why, if I set the project settings to HD 1080i25 instead of PAL DV and work directly on the unrendered MP4 clips (and put up with the stuttering) do I not see a visible increase in quality when I burn the DVD? Is there some sort of levelling going on during the DVD coding?

            • 3. Re: Avoiding preview stuttering problems
              Ted Smith Level 3

              If you are going to Blue Ray and watch it on a Full HD set, you need to best shoot your original in 1900x1080i and import as AVCHD,

              You get no stuttering in preview even on an old Dual Core with 4mb ram with 2 or 3 hard disks (see many other posts on this). You have to render the area around any complicated effects. Keep the preview window size small.

               

              Share your finished  project to a AVCHD M2TS file.

               

              Use another program to burn this file to BD. PE9 doesn't work with all disks and TV players and you can't set the speed to match the blank disk..

               

              I recently bought an 8x LG burner for $110 that came with Cyberlink Power Director for free. (Umart.com.au in Aussieland)

              Edited and burnt BD video is virtually the same quality as playing the Sony camera directly via HDMI close up on a Sony Bravia 40".

               

              I believe Sony Architect is very good for burning but I havent tried it yet.

               

              I also found no problem mixing old SD AVI files (730x576 PAL) form DV tape with AVCHD in the same project on two different tracks.

               

              Biggest problem with a slow computer is rendering takes a long time but you only need to render the areas in red, not the whole project.(many other posts on this)

              1 person found this helpful
              • 4. Re: Avoiding preview stuttering problems
                Captain Slocum Level 1

                Trouble is I DO get preview stutter with .mts and .MP4 files (not with .avi though). And I have found a way to get round this as I said - import the MP4 or .mts file into a DV project, place it on the timeline and when asked if I want to convert the project to match the file answer no and then render the timeline. This then gives me a stutter free preview.

                 

                But my question remains: what has happened to the HD clip? Is it no longer HD but DV? As I said, when burned to disc I can see no difference between a DVD burned from an HD project and one burned on a DV project when HD clips have been used in both, but maybe there is a difference I am not seeing (viewed on a Sony 42" HD TV).

                 

                But if someone knows how to stop the preview stutter short of buying a new computer all the better. In a previous post I was given the advice that it was not the graphics card but the twin P4 3.2 processors and I needed a new computer with i7 CPUs. But you are saying that others are not getting stuttering with older computers so perhaps there is something I could do. The full details are Twin CPUs Intel P4 3.2GHz, Radeon 9600 graphics card with 256MB, 4 MB RAM (3.2 effectively), Asus P5P800 SE motherboard, Windows XP Pro SP.

                 

                Incidentally, as mentioned previously, I tried a trial version of Cyberlink PowerDirector and got previews with the same clips with no stutter at all, so it cannot all be down to my computer.