2 Replies Latest reply on Oct 11, 2011 9:06 AM by Citizen 1982

    Adobe reader 9.4.0 requires Internet Explorer 6.0 or greater

    JRWilliams308

      Hello,

       

      I have a user who has reported Adobe Reader was not installed on his PC, which we complete via GPO as default for all our computers, and has never been an issue (WinXP and Win7 (x64) ).  When attempting to install the reader manually, I received "Adobe reader 9.4.0 requires Internet Explorer 6.0 or greater"  This is a Win7 box.  It comes with IE 8!  Can anyone point me to the registry path the installer is looking for to determine the version of IE?  I've checked HKLM\Software\Microsoft\Internet Explorer and verified both "Version" and "W2kVersion" read 8.0.7601.17514.

       

      I realize Reader X is available.  We're not ready to deploy it yet.  So any suggestion other than simply "install Reader X"  is greatly appreciated!

       

      Thanks for your time.

        • 1. Re: Adobe reader 9.4.0 requires Internet Explorer 6.0 or greater
          vsh07 Level 2

          It seems there is some problem with versioning of shdocvw.dll.

          Try this:

          1. Open Notepad.

          2. Type in the following commands in it:

              regsvr32 shdocvw.dll /i /s
              regsvr32 shdocvw.dll /s

              pause

          3. The pause statement will enable you to see the errors (if any)

          4. Save the file as "abc.bat". Make sure to include the filename in the double quotes.

          5. Double click on the file. If all goes well, you wont see any errors and the commands will execute successfully. Restart your system and then try installing Reader.

          • 2. Re: Adobe reader 9.4.0 requires Internet Explorer 6.0 or greater
            Citizen 1982

            I know I'm considerably late to the reply here, but I had the same issue with a Reader X install done via GPO.  This may be relavent info for the future, and may work for Reader 9 as well

             

            I read that someone had tried running the command line uninstall for an older version of reader, as it seemed to have not been removed completely.  I threw together a batch file to attempt to remove all the reader installs we had available along with the font packs.  Some of the font packs won't remove unless reader is present, so it re-installs the latest reader, removes the font packs again (to get whatever it missed) then reloads the font packs.

             

            So far this approach is 1 for 1.  Hopefully it helps out if you still need it.

             

            rem For ease of use, run this from an elevated command prompt
            rem Try to remove all adobe reader related items
            msiexec /x "\\deployment\adobe reader\font packs 10\adberdrsd1000_all.msi" /passive
            msiexec /x "\\deployment\adobe reader\font packs 10\fontpack1000_ja_jp.msi" /passive
            msiexec /x "\\deployment\adobe reader\font packs 10\fontpack1000_ko_kr.msi" /passive
            msiexec /x "\\deployment\adobe reader\font packs 10\fontpack1000_zh_cn.msi" /passive
            msiexec /x "\\deployment\adobe reader\font packs 10\fontpack1000_zh_tw.msi" /passive
            msiexec /x "\\deployment\adobe reader\10\acroread.msi" /passive
            msiexec /x "\\deployment\adobe reader\10.0.1\acroread 10.0.1.msi" /passive
            msiexec /x "\\deployment\adobe reader\10.1.0\acroread.msi" /passive
            msiexec /x "\\deployment\adobe reader\10.1.1\acroread.msi" /passive
            
            rem Install most recent version of adobe reader
            rem This must be updated manually to reflect the new version.
            msiexec /i "\\deployment\adobe reader\10.1.1\acroread.msi" /passive
            
            rem Try to remove font packs again because some of them fail if reader isn't installed
            msiexec /x "\\deployment\adobe reader\font packs 10\adberdrsd1000_all.msi" /passive
            msiexec /x "\\deployment\adobe reader\font packs 10\fontpack1000_ja_jp.msi" /passive
            msiexec /x "\\deployment\adobe reader\font packs 10\fontpack1000_ko_kr.msi" /passive
            msiexec /x "\\deployment\adobe reader\font packs 10\fontpack1000_zh_cn.msi" /passive
            msiexec /x "\\deployment\adobe reader\font packs 10\fontpack1000_zh_tw.msi" /passive
            
            rem Reinstall all the font packs
            msiexec /i "\\deployment\adobe reader\font packs 10\adberdrsd1000_all.msi" /passive
            msiexec /i "\\deployment\adobe reader\font packs 10\fontpack1000_ja_jp.msi" /passive
            msiexec /i "\\deployment\adobe reader\font packs 10\fontpack1000_ko_kr.msi" /passive
            msiexec /i "\\deployment\adobe reader\font packs 10\fontpack1000_zh_cn.msi" /passive
            msiexec /i "\\deployment\adobe reader\font packs 10\fontpack1000_zh_tw.msi" /passive