4 Replies Latest reply on May 25, 2011 3:01 PM by *Q

    Mask a filter

    JNDPNT

      Dear adobe community,

       

      For a project I tried to mask a filter. More concrete this is the situation:

       

      I have a few particles in a MovieClip and applied a blur filter on it. In another MovieClip I added this MovieClip and applied a filter on it so that the blur will not come outside the frame I want it to be in. This frame is reconstructed as a Mask... So according to logic when I apply the mask it should give me blurred particles only under my mask. When I tested this, it works fine...

       

      The problem occurs when I export the SWF file. In the real deal the blur isn't masked at all. So either flash does not support it and is showing me this wrong in the design mode (because there it's right), or flash can do this but somehow with exporting a bug or error occurs.

       

      Does anyone know more about this problem or knows a solution to fix this? Is this a bug or perhaps something I do wrong?

       

      With kind regards,

       

      JNDPNT

        • 1. Re: Mask a filter
          *Q Level 3

          Hi,

          I can't reproduce your issue. Which version of Flash are you using? Which platform (Mac or Window)? Can you please post your fla so I can look it over?

           

          Thanks,

          Quynh

          Flash Authoring, QA

          • 2. Re: Mask a filter
            JNDPNT Level 1

            Hi *Q and thanks for replying. I am running Windows (7) with Flash professional CS5.

             

            I have tried myself to reproduce my issue, but I can't. I just have one animation which really doesn't want to do it properly.

             

            Filtered FLA download: http://www.megaupload.com/?d=AV21A5O0

             

            I deleted all other content but still this little parts doesn't want to work.

            • 3. Re: Mask a filter
              JNDPNT Level 1

              Looks like nobody knows why it isn't working? Is there a way to report this as a bug to adobe staff because aparently they are not on their own forums...

              • 4. Re: Mask a filter
                *Q Level 3

                Hi JNDPNT,

                I've looked over your file and I didn't see any movieclip with a blur filter applied to it. Which symbol on which layer were you having issue with? There were 5 masks on your main timeline and they all seems to be working correctly.

                 

                Q