6 Replies Latest reply on Jun 14, 2011 1:09 PM by dunferml1ne

    Cannot get Elonex 621EB authorized

    Why is this so hard?
      I have seen similar problems but no solution.
      I have an Elonex 621EB (I think this is the same as a Cooler) Digital Editions is installed and appears to work but when in connect the e-book I get E_ADEPT_BAD_ELEMENT_VALUE http://adeactivate.adobe.com/adept/Activate fingerprint NmQ74RAmlTw= urn:uuid:9fa98588-c076-4edc-bfd0-b3e9dd6dfbea
      The fingerprint seems to come from a device.xml file on the e-book but I don't know of any better values to try.
      I have tried reinstalling, resetting. There has to be a way to get these two to talk to each other - HELP!
        • 1. Re: Cannot get Elonex 621EB authorized
          dunferml1ne

          There is a file on the ereader called device.xml - You can see the offending fingerprint value there.

          I returned the machine to Elonex and when it came back the device.xml file contained only a comma.

          ADE did nothing at all when I connected.

          I followed the hint in one of the other forum posts and chose setting/default to restore manufacturer's default.

          It appears to work now. Though that did not work before the machine went back to Elonex.

           

          Nobody in Elonex ar Adobe seem to be able to suggest appropriate xml values but I think that is all that is needed.

          • 2. Re: Cannot get Elonex 621EB authorized
            Frustrated in AZ Level 4

            Did you register the device with Elonex?  I didn't see anything in your post

            that said you did.  As you can see

            HERE<http://www1.elonex.com/support/products/ebook/digital-editions-ebook.shtm>,

            doing so will activate ADE and also get any updates to the reader.

             

            ====================

            • 3. Re: Cannot get Elonex 621EB authorized
              vickyhill

              Please visit the Elonex website www.elonex.com then click on support.

              On here you will see a list of eBooks. Click on your product. Then download the latest firmware to your eBook. Once the firmware has been applied plug you eBook into your PC and when it says "USB connected" then open your adobe digital editions. You should get a message asking you to authorize the device. The device MUST be authorized before it allows you to read your books. If you do not get this message, then restart your PC and also remove the eBook from the PC. Then, again open adobe digital editions and this time whilst adobe is open, then plug your eBook into the computer and the messgae should now appear.

              • 4. Re: Cannot get Elonex 621EB authorized
                dunferml1ne Level 1

                Thank you for your reply.

                The machine had a problem and was sent to Elonex. It was returned with the

                firmware update.

                However ADE would not pick up when the book was connected.

                I reset the machine using settings/default and it worked.

                My husband had to work this out as nobody suggested it.

                • 5. Re: Cannot get Elonex 621EB authorized
                  dunferml1ne Level 1

                  Thanks for the reply.

                  It was registered, everything done.

                  It has been very frustrating. There are similar problems to those I had on

                  the forum but no replies.

                  We also tried  Adobe support and Elonex. Adobe didn't reply to the web case

                  we opened.

                   

                  After a second web case we were sent a detailed XML fix from Adobe but we

                  had already fixed it.

                  We will post this on the forum in case it helps somebody else.

                   

                  In case this comes up again:

                  There was an initial issue that an XML value was generating an error when we

                  tried to authorise the e-reader.

                  Nobody would suggest an XML fix. They suggested a firmware update. The

                  machine froze after the update

                  and was returned to Elonex. When it returned the XML device file was empty

                  and ADE did nothing.

                  This was fixed by settings/default to reset. It created a new device file

                  with a value that was OK.

                  Thanks to the forum for that one.

                  • 6. Re: Cannot get Elonex 621EB authorized
                    dunferml1ne Level 1
                    In case this is of use to other forum readers.
                    I got this from adobe support. It sheds some light on the XML use though not on the fingerprint tag
                    Solution 1)

                     

                    1) Open Digital Editions.
                    2) Connect the Reader
                    5) There you will find a new drive created similar to C or D drive under "My computer".
                    6) Open the Readers Drive and you will find a folder with name "adobe.digital.editions".
                    7) Delete this folder and plug off and re plug in the Reader.
                    8) Authorize Reader from the same Adobe ID which you used to Authorize Adobe Digital Editions.
                    9) Now try to transfer books to your Reader

                     

                    Solution 2) Modify the manifest.xml file located in C:\Usres\Username\My Documents\My Digital Editions:
                    1) Quit Digital Editions
                    2) Make a backup copy of the manifest.xml (call it something like manifest.good)
                    3) Open manifest.xml in notepad
                    4) It will appears as one big long line of xml, and you are looking for a tag called start at the begginning of this
                    and select until you the end of the tag that looks called </de:deviceID>
                    5) If you have attached more than one Reader there may be multiple of these. Delete all of them to make sure.
                    6) Save the file (manifest.xml) and quit out of notepad
                    7) Ensure you have the Reader plugged in
                    8) Launch Digital Editions
                    9) The Device Setup Assitant should come up.
                    a) Do NOT click on the "Don't ask again for this device" checkbox.
                    b) Do click on the "Authorize Device" button.