5 Replies Latest reply on Jul 14, 2017 10:13 AM by franco.dimgson

    Keyframe keyboard shortcut not working

    Sean Booth Level 1

      Apologies for the really noob question but I’m new the AE and for the life of me trying I can’t get any Functions keys to perform their commands and it’s driving me nuts having to go through menus to do simple things like add a keyframe.

       

      So far I’ve tried:

      • check/uncheck the standard function box on keyboard prefs

      • Unchecked Exposé

      • Turning off itunes so it doesn’t conflict with AE

      • Adding my own keyboard shortcut (which won’t work anyway because the menu description changes for each type of keyframe)

       

      Please help – this is driving me insane!

       

      iMac 10.6.7 – Extended Keyboard CS5

        • 1. Re: Keyframe keyboard shortcut not working
          Todd_Kopriva Level 8

          What shortcuts, exactly, are you having trouble with?

           

          > So far I’ve tried:

          • check/uncheck the standard function box on keyboard prefs

          What is the exact name of the preference that you're referring to here?

           

          Have you tried turning off the Use System Shortcut Keys preference in the General categoru in After Effects preferences?

          • 2. Re: Keyframe keyboard shortcut not working
            Sean Booth Level 1

            I’m not sure what you mean...

             

            Lets say I have a document open and I want to scale an object – I first have to ‘Add Scale Keyframe’ if I want to do this I have to go to the menu every time rather than just press the F9 key. no combinations of F9+shift +cntrl +cmd work.

             

            I think this is a conflict between the way a Macs function keys are set by default and what AE wants to use them for and I just can’t resolve it. The preferences I was referring to was the Mac System prefs.

             

            Thanks for the reply

            • 3. Re: Keyframe keyboard shortcut not working
              Rick Gerard Adobe Community Professional & MVP

              F9 converts a selected keyframe temporal interpolation. IOW, F9 toggles between ease and no ease.

               

              If you want to set a scale keyframe press Option + S. From there on every time you change the scale value you'll get a new keyframes. If there is no keyframe under the CTI pressing Option + S (or A for anchor point, or T for Opacity, or P for position) will set a new one. If there is a keyframe under the CTI then pressing Option + S will remove the keyframe.

              • 4. Re: Keyframe keyboard shortcut not working
                ramak96082263

                i had the same problem, please switch off all the adobe programs and restart your after effects. I hope this will help

                • 5. Re: Keyframe keyboard shortcut not working
                  franco.dimgson Level 1

                  Hi, you asked your question 7 years ago, but i had the same problem and I could resolve it. So I´m going to tell you my solution.
                  There are some apps in windows that could use the shortcuts like shift+f9 or just f9 too... When I realized it, I closed some open apps in backgrownd like "Teamviewer" make sure to close all those apps that you don´t need to use at the moment. So it theorically should enable the function again to after effects. It worked for me.

                   

                  Sorry for my bad english, best wishes from Argentina!

                  1 person found this helpful