6 Replies Latest reply on Jan 18, 2012 7:46 AM by gregpking

    Puppet Tool Out of Memory (23 :: 40)

    DevelopThings Level 1

      I've imported an Illustrator file with layers as a composition with retain layer size. There are 8 layers and it's a basic human form that I'm attempting to animate using the Puppet Tool. I can add Puppet Pins to the layers, but as soon as I start to move a pin I get an "Out of Memory ( 23 :: 40 )" error and the layers disappear from the Preview. Any subsequent attempts to scrub the timeline, position a pin, add a new pin, etc. also result in the same error. If I delete some pins, eventually the layers reappear in the preview, but once I try to add pins or move pins, I again receive the same error. Closing the project, quitting AE, re-opening will also reveal the error as soon as the project is opened. I've rebuilt the project many times all with the same result of the error.

       

      I'm running After Effects 10.0.2.4 on a MacBook Pro with 8 GB RAM. I've got 6 GB allocated to the Premier Suite. Any help would be appreciated.

        • 1. Re: Puppet Tool Out of Memory (23 :: 40)
          Dave LaRonde Level 6

          I hope you're not trying to use multiprocessing in AE, because you're light on memory on that laptop, and you can't really fix that.

           

          At work I have a dual quad-core machine with 8 gigs; I don't use multiprocessing because I don't have enough memory to make multiprocessing work efficiently.  At home I have a dual quad-core machine, but with 24 gigs; multiprocessing works just fine.

          • 2. Re: Puppet Tool Out of Memory (23 :: 40)
            DevelopThings Level 1

            No, I'm not using multiprocessing. I'm starting to wonder if it's the Illustrator file, but I hate to think about recreating it after laboring for a day on the illustration.

            • 3. Re: Puppet Tool Out of Memory (23 :: 40)
              Dave LaRonde Level 6

              Let's eliminate the obvious.  Your illustrator document doesn't contain any layer styles that you could flatten, does it?  Another obvious one: it's RGB and not CMYK, right?

              • 4. Re: Puppet Tool Out of Memory (23 :: 40)
                Todd_Kopriva Level 8

                Is your layer based on the Illustrator file continuously rasterized?

                • 5. Re: Puppet Tool Out of Memory (23 :: 40)
                  jmatasov Level 1

                  I am also on a Macbook Pro w/ 8GB of ram (spring 2011 MBP).  I was getting the exact same error.  I turned off multiprocessing, but it didn't help. 

                   

                  The thing that helped me was in the Mesh properties.

                  - expand the properties on the item with the pins attached.

                  - expand Effects.

                  - expand Puppet.

                  - expand Mesh 1.

                  - change triangles value to 200.

                  - change expansion to 4.

                   

                  Changing the triangles and expansion values was what solved it for me.  If I put triangles back up to 300, I get the error. If I lower triangles the error goes away. If I didn't adjust the expansion the mesh got a bit wonky and didn't look right.

                   

                  Anyways, hope that helps someone else that might have this error.

                  /jim

                  • 6. Re: Puppet Tool Out of Memory (23 :: 40)
                    gregpking Level 1

                    I was having the same issue with an illustrator file and puppet tool. It had nothing to do with the amount of RAM I had available. It was only requesting 1K when I new I had GBs available. It turned out to be a problem with the 3d layering. Basically I had non-3d layers sandwiched between other 3d layers. Once I made all layers 3d, the problem went away. I noticed this sandwiching also caused issues with shadows from lights on the 3d layers above the non-3d layers.

                     

                    Hope that helps someone.