3 Replies Latest reply on Mar 30, 2009 4:48 PM by Ned Murphy

    Complete N00b need help

    dwarfer
      Hello I am new to all of this and I want to make an easter e-card, I want a button (part of the egg) to jump to a new frame. First few frames will be the easter egg, when you click on a hotspot on the egg it jumps to a different scene.

      I have tried all sorts (eg release{goto ("scene1")) - example, I can get it to STOP on frame 1 to stop the movie jumping to next frames but just want the button to goto a new frame or scene, on that note how do I create a scene?

      Thanks for your help
        • 1. Re: Complete N00b need help
          Ned Murphy Adobe Community Professional & MVP
          Don't bother using scenes if you aren't already familiar with them... they are often problematic, so you'll save yourself from potential problems. Just build things into one scene's timeline.

          For the button, click on it to select it and place the following code in the actions panel:

          on(release){
          gotoAndStop(#);
          }

          where # is the number of the frame you want to go to. If you use a label for that frame, use quotes for the frame label in that code.
          • 2. Re: Complete N00b need help
            dwarfer Level 1
            thanks for reply but remember im a complete newbe on this...

            i created a squair and made it a button, i click it and click Action but it wont let me insert that code because it says


            "Current Selection cannoy have actions applied to it."

            The only way I can insert the code is if i click on Layer 1 : Frame 1 or Scene 1, etc... but that has compile errors

            "1087: Syntax error: extra characters found after end of program."


            I understand this is a very lame response and you know exactly what I'm doing wrong and you think im a nob but I've tried for 6hrs to get this thing working.

            Thanks again
            • 3. Re: Complete N00b need help
              Ned Murphy Adobe Community Professional & MVP
              First, check your Publish Settings, in the Flash section, make sure you have Actionscript 2.0 selected and not Actionscript 3.0. What you are showing in your response reflects AS3, while your original posting reflects AS2-ish stuff.