1 Reply Latest reply on Aug 12, 2011 10:40 AM by jtsli

    AIR App Update fails with ApplicationUpdater (IOErrorEvent 2032)

    sascha/hdrs

      I hope somebody can help me with this issue as I'm completely clueless of what could be the problem...

       

      I've integrated the AIR ApplicationUpdater into my app and doing update tests but they fail if I download the update for my app and then press "Install" so that the app exits and tries to install the update. there I get the following message:

       

      Sorry, an error has occured.

      The application could not be installed because the installer file is damaged. Try obtaining a new installer file from the application author.

       

      If I postpone the update install until the app is restarted, all works fine. This happens on Windows 7 as well as on Mac OSX. And I tried it too with uninstalling both AIR and my app and re-install it all freshly but this didn't help.

       

      Here's part of the install log I'm getting:

       

      [2011-05-31:02:51:30] Application Installer begin with version 2.6.0.19140 on Windows 7 x86
      [2011-05-31:02:51:30] Commandline is: -update "c:\program files (x86)\test\test application\test application.exe" "C:\Users\user\AppData\Roaming\testappid\Local Store\#ApplicationUpdater\update.air" 1.0.1
      [2011-05-31:02:51:30] Installed runtime (2.6.0.19140) located at c:\Program Files (x86)\Common Files\Adobe AIR
      [2011-05-31:02:51:30] Installed app (testappid) located at c:\program files (x86)\test\test application\test application.exe
      [2011-05-31:02:51:30] Unpackaging file:///C:/Users/user/AppData/Roaming/testappid/Local%20Store/%23ApplicationUpdater/updat e.air to C:\Users\user\AppData\Local\Temp\flaD894.tmp
      [2011-05-31:02:51:30] Got an unexpected fatal error while unpackaging: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032" errorID=2032]
      [2011-05-31:02:51:54] Launching subprocess with commandline c:\program files (x86)\test\test application\test application.exe
      [2011-05-31:02:51:54] Application Installer end with exit code 7

       

      ... Anyone have any clue what could be the source of the trouble? It's very important for me that this all works flawless.