20 Replies Latest reply on Oct 11, 2012 5:15 AM by Peter Spier

    Urgent! "Unwanted characters break" in InDesign

    Ramesh Sapkota Level 1

      Hi!


      I am using InDesign to layout pages in Asian text (Nepali). There are unwanted characters breaks? Is there any solution?

      Thanks.

      char break.jpg

        • 1. Re: Urgent! "Unwanted characters break" in InDesign
          Karthikeyan Selvaraj Level 1

          just you click the hupernate option in the paragaraph pallete

          just you wiil try this one methodScreen shot 2011-05-31 at 12.13.50 PM.jpg

          Screen shot 2011-05-31 at 12.14.01 PM.jpg

          • 2. Re: Urgent! "Unwanted characters break" in InDesign
            Peter Spier Most Valuable Participant (Moderator)

            I don't know if you have a Nepali dictionary of some sort installed, but my version of ID didn't come with one, meaning there is no way to do a Nepali spell check, which means you could also just select all the text and assign the langauge to None in the character panel. The None setting has no hyphenation rules associated with it, and I think that would keep all text from breaking except at a space.

            • 3. Re: Urgent! "Unwanted characters break" in InDesign
              Peter Spier Most Valuable Participant (Moderator)

              Actually, the best place to either turn off hyphenation or change the language to none would be in the paragraph styles.

              • 4. Re: Urgent! "Unwanted characters break" in InDesign
                Ramesh Sapkota Level 1

                Hyphenation and language are turned off. It didn't solve.

                Although the same text does not break in MX Freehand.

                What may be the problem?

                • 5. Re: Urgent! "Unwanted characters break" in InDesign
                  John Hawkinson Level 5

                  Does it help to set Character > No Break on the text?

                   

                  I would export the textframe as a Snippet and look at the XML it produces for clues.

                  • 6. Re: Urgent! "Unwanted characters break" in InDesign
                    John Hawkinson Level 5

                    So, Ramesh sent me a sample snippet file.

                    If I place in his snippet, I get this:

                     

                    d.png

                    And the snippet itself looks like this:

                    <Story Self="ucb" AppliedTOCStyle="n" TrackChanges="false"
                    StoryTitle="$ID/" AppliedNamedGrid="n">
                      <StoryPreference OpticalMarginAlignment="false"
                      OpticalMarginSize="12" FrameType="TextFrameType"
                      StoryOrientation="Horizontal"
                      StoryDirection="LeftToRightDirection"/>
                      <InCopyExportOption IncludeGraphicProxies="true"
                      IncludeAllResources="false"/>
                      <ParagraphStyleRange
                      AppliedParagraphStyle="ParagraphStyle/$ID/NormalParagraphStyle"
                      Composer="HL Single" Hyphenation="false">
                        <CharacterStyleRange
                        AppliedCharacterStyle="CharacterStyle/$ID/[No
                        character style]" PointSize="16">
                          <Properties> <AppliedFont
                               type="string">Preeti</AppliedFont>
                          </Properties>
                    <Content>s;n] xfd|f] b]z dfly cfFvf nufpg ;S5 &lt;</Content>
                        </CharacterStyleRange>
                      </ParagraphStyleRange>
                    </Story>
                    

                     

                    So, basically, it looks completely normal to me. Ramesh, does it look different to you? Obviously I don't have the correct script font (Preeti) installed. But it looks like it is unrelated to any formatting applied. So perhaps to the font.

                     

                    What happens if you change the font or resize the box?

                    • 7. Re: Urgent! "Unwanted characters break" in InDesign
                      [Jongware] Most Valuable Participant

                      Apparently, he isn't using a correct font for this script (Devanagari?), and so all bets are off. All hyphenation and word/line breaking routines from InDesign are based on Unicode, and this is clearly not a Unicode-compliant font.

                       

                      ... So all you can do is create a GREP style that assigns No Break to every string of not-whitespace.

                       

                      Or tackle the (probable) source of the problem and use a Unicode-compliant font.

                      • 8. Re: Urgent! "Unwanted characters break" in InDesign
                        Joel Cherney Adobe Community Professional & MVP
                        Apparently, he isn't using a correct font for this script (Devanagari?), and so all bets are off. All hyphenation and word/line breaking routines from InDesign are based on Unicode, and this is clearly not a Unicode-compliant font.

                         

                        ... So all you can do is create a GREP style that assigns No Break to every string of not-whitespace.

                         

                        Or tackle the (probable) source of the problem and use a Unicode-compliant font.

                         

                        This is pretty much the only answer. I have obscenely complicated GREP styles set up to preserve No Break in particular places in hacky pre-Unicode fonts where a Burmese glyph has been mapped onto a character (like the square bracket in the example) that will break because InDesign thinks it's Latin-script. The "no-break on all non-whitespace" will make legible Nepali, I guess, although it won't necessarily work in other scripts that feature (uh, require) use of a  zero-width space that breaks correctly. However, when I get Nepali in a pre-Unicode font I just tell my translator "Hey, we agreed that you were going to give me correctly-encoded text" and he says "Oh yeah, Joel, sorry I forgot" and converts to Windows 7 system fonts with his homebrew VB script.

                        • 9. Re: Urgent! "Unwanted characters break" in InDesign
                          John Hawkinson Level 5

                          Err, can't he just apply no-break to all contiguous runs of non-whitespace characters?

                          • 10. Re: Urgent! "Unwanted characters break" in InDesign
                            Joel Cherney Adobe Community Professional & MVP

                            Yeah.

                             

                            "The "no-break on all non-whitespace" will make legible Nepali, I guess, although it won't necessarily work in other scripts."
                            • 11. Re: Urgent! "Unwanted characters break" in InDesign
                              John Hawkinson Level 5

                              "Oh yeah, Joel, sorry I can't read."

                              • 12. Re: Urgent! "Unwanted characters break" in InDesign
                                Joel Cherney Adobe Community Professional & MVP

                                No harm, no foul. Besides, I hid the definitive this-is-okay statement about it in a thicket of caveats.

                                • 13. Re: Urgent! "Unwanted characters break" in InDesign
                                  [Jongware] Most Valuable Participant

                                  So can we agree on this stop-gap solution?

                                   

                                  * Create a character style that only applies "No Break"

                                  * Using a GREP style, assign this style to the matching string "\S+"

                                   

                                  .. even though we also agree that it's a dirty fix, and best thing to do for several very good reasons is replace this make-shift font with a real Devanagari one (when pressed, we might enumerate these reasons by way of an encore).

                                  1 person found this helpful
                                  • 14. Re: Urgent! "Unwanted characters break" in InDesign
                                    Joel Cherney Adobe Community Professional & MVP

                                    [Jongware] wrote:

                                     

                                    So can we agree on this stop-gap solution?

                                     

                                    * Create a character style that only applies "No Break"

                                    * Using a GREP style, assign this style to the matching string "\S+"

                                     

                                    .. even though we also agree that it's a dirty fix, and best thing to do for several very good reasons is replace this make-shift font with a real Devanagari one (when pressed, we might enumerate these reasons by way of an encore).

                                     

                                    I can say "yes" without reservation but I have been biting my lip to keep myself from delivering the encore before the applause. For all I know, the audience has already left the building.

                                    • 15. Re: Urgent! "Unwanted characters break" in InDesign
                                      Ramesh Sapkota Level 1

                                      Joel Cherney wrote:

                                       

                                      Apparently, he isn't using a correct font for this script (Devanagari?), and so all bets are off. All hyphenation and word/line breaking routines from InDesign are based on Unicode, and this is clearly not a Unicode-compliant font.

                                       

                                      ... So all you can do is create a GREP style that assigns No Break to every string of not-whitespace.

                                       

                                      Or tackle the (probable) source of the problem and use a Unicode-compliant font.

                                       

                                      This is pretty much the only answer. I have obscenely complicated GREP styles set up to preserve No Break in particular places in hacky pre-Unicode fonts where a Burmese glyph has been mapped onto a character (like the square bracket in the example) that will break because InDesign thinks it's Latin-script. The "no-break on all non-whitespace" will make legible Nepali, I guess, although it won't necessarily work in other scripts that feature (uh, require) use of a  zero-width space that breaks correctly. However, when I get Nepali in a pre-Unicode font I just tell my translator "Hey, we agreed that you were going to give me correctly-encoded text" and he says "Oh yeah, Joel, sorry I forgot" and converts to Windows 7 system fonts with his homebrew VB script.

                                       

                                      Hi Joel,

                                       

                                      Can u write a step by step method for this"no-break on all non-whitespace" will make legible Nepali" .

                                      How to apply "no-break on all nonwhitespace" on a paragraph?

                                       

                                      Did u mean? "Select broken words and from character pallete from drop down list, select 'no break'? If yes, It's not handy for long pages of text.

                                       

                                      Thanks.

                                      • 16. Re: Urgent! "Unwanted characters break" in InDesign
                                        John Hawkinson Level 5
                                        Did u mean? "Select broken words and from character pallete from drop down list, select 'no break'? If yes, It's not handy for long pages of text.

                                        No, GREP styles are automated, that is their beauty.

                                        First, create a character style called NO BREAK that applies only the No Break attribute:

                                        nepali1.png

                                         

                                        Then, create a paragraph style (or modify an existing paragraph style) that applies NO BREAK as a GREP Style for the expression \S+.

                                         

                                        nepali2.png

                                        Apply the paragraph style to your text. You are done.

                                        1 person found this helpful
                                        • 17. Re: Urgent! "Unwanted characters break" in InDesign
                                          Ramesh Sapkota Level 1

                                          No tricked work.


                                          Thanks for all the InDesigners/participants.

                                          • 18. Re: Urgent! "Unwanted characters break" in InDesign
                                            GunjjuSen

                                            1. Create New Style

                                            2. Go to GREP

                                            3. Create new character style from Apply Style drop down menu

                                            1.jpg

                                            4. New dialog box appears. | Click on Basic Character Format |< select No Break and type the name for you to understand.

                                            2.jpg

                                            5. Click OK

                                            6  Type /S+ in InText box

                                            3.jpg

                                            7. Click on

                                            8. Select the Paragraph and Apply the style.

                                             

                                            ** Remember You have to create  GREP from the GREP option itself. If you create GREP from the Style, it wont work.

                                             

                                            Thanks

                                            • 19. Re: Urgent! "Unwanted characters break" in InDesign
                                              sirutar11

                                              when i used this, my text disappears

                                               

                                              1.jpg

                                              • 20. Re: Urgent! "Unwanted characters break" in InDesign
                                                Peter Spier Most Valuable Participant (Moderator)

                                                Your text disappeared becasue you applied No Break to a string that is too wide to fit in the frame.