5 Replies Latest reply on Jun 21, 2011 6:11 AM by Peter Spier

    After MiniBridge, can't type in InDesign (Solid Insertion Cursor)

    bjele Level 1

      Hello

       

      This one is an incredibly minor annoyance, but I've run into it 400 times and will run into it for another 1100 times during this book, so I finally decided to see if anyone can help me figure out what is going on.

       

      Symptom: I can not type characters in InDesign.

       

      Steps to Reproduce.

      1. Type some text in InDesign. The Minibridge panel is visible on a second monitor.

      2. Click on an image in MiniBridge.

      3. Open the menu at the top right of MiniBridge. Choose Place, In Indesign.

      4. The image is placed at the insertion point. Control certainly appears to return to InDesign.

       

      At this point, several keys on the keyboard work. I can use the arrow keys to move up, down, left, right in the text. I can use Shift+Arrow keys to select text. I can use the Enter key to add some paragraph marks. I can press Ctrl+Num+3 to change the paragraph style. Backspace works.

       

      However, none of the letters work! I almost always go down, select some caption text, then press Ctrl+C to copy that text. Since the letters are not working, Ctrl+C does nothing. Sometimes I need to type the caption. Again, the letters are not working.

       

      One hint: the Insertion Point is not flashing at this point. It is solid and visible, but it is not flashing.

       

      I thought that perhaps I somehow was not in Text mode, but the "T" icon is still selected. Nonetheless, I did try to press T and I still can't type.

       

      There are two solutions that I've found.

      Solution 1: grab the mouse and click in the vicinity of the solid insertion point. After that mouse click, I can begin typing.

      Solution 2: Press Alt-Tab twice to switch to another application then switch back to InDesign. The insertion point starts flashing and I can type again.

       

      Thanks for reading this. I am hoping to find what strange mode I am in that I can navigate with the keyboard but not type. Also, is there a simple hotkey to toggle out of this mode?

       

      Bill

        • 1. Re: After MiniBridge, can't type in InDesign (Solid Insertion Cursor)
          bjele Level 1

          In the process of documenting the issue for the above post, I discovered the Alt+Tab, Alt+Tab keystroke combination. This switches to any other app and then back to InDesign. This corrects the problem.

           

          For the last few hundred images, I've gotten used to immediately doing Alt+Tab, Alt+Tab after placing each image from MiniBridge. This allows ALL of the keys on the keyboard to work.

           

          In case this is happening to anyone else, add the Alt+Tab, (release Alt between after the first one) Alt+Tab to the workflow.

           

          Now, if we could just get a keyboard shortcut assign to the Place, In InDesign command in Minibridge...

           

          Bill

          • 2. Re: After MiniBridge, can't type in InDesign (Solid Insertion Cursor)
            Peter Spier Most Valuable Participant (Moderator)

            You can just drag the image from minibridge into ID. Does that help?


            1 person found this helpful
            • 3. Re: After MiniBridge, can't type in InDesign (Solid Insertion Cursor)
              bjele Level 1

              Dragging the image to InDesign creates a new frame for the image. That frame stays in one location and does not flow with the text.

               

              I need the image to be inserted between paragraph 1 and paragraph 2 and flow with the text.

               

              The only way that I've found to do this is to use the Place, In InDesign command from the MiniBridge right-arrow menu. This places the image at the insertion cursor.

               

              However, just now, based on your suggestion, I tried dragging the image to the Pasteboard, then using Ctrl+X to cut, T for Text Mode, click on the empty paragraph mark between the two paragraphs, Ctrl+V to paste. This does solve the issue of the letters no longer working.

               

              Is there any way to drag the image to the story and then essentially do a Paste In Place at the cursor?

               

              Bill

              • 4. Re: After MiniBridge, can't type in InDesign (Solid Insertion Cursor)
                Eugene Tyson Adobe Community Professional & MVP

                I can't reproduce the issue here. It works just fine for me.

                 

                Have you updated to the latest patch of InDesign, that did fix some issues.

                 

                 

                Also have you tried exporting your document to IDML and reopening it (opens as untitled) that can clear some corruption.

                 

                Also try trashing/replacing your prefs http://forums.adobe.com/thread/526990

                 

                 

                I too randomly get the keyboard stop working - and I have to go to File>Save to get things working again properly.

                 

                I have yet to track down the problem. I have got my InDesign on English International (at install) , and my keyboard is set to English UK region. Not sure if there is a problem with that. There was never before. But I've yet to test this.

                • 5. Re: After MiniBridge, can't type in InDesign (Solid Insertion Cursor)
                  Peter Spier Most Valuable Participant (Moderator)

                  I suppose you could make an empty frame, then cut and paste that into the text and drop from bridge into that frame, but there's no advantage.

                   

                  I'm inclned to think, though, that you have a system configuration issue of some sort that out to be solveable so it will work using Place.