8 Replies Latest reply on Jul 20, 2011 9:38 AM by Heidi Williams

    No Repository Found - conflicting dependency

    DBarranca Level 4

      Hello,

      I've run into an error, trying to update FlexBuilder 4.5 - I don't know whether it's related to ExtensionBuilder or not, anyway here it goes.

      I select the Help - Software Updates menu entry in FB 4.5, and after a while it appears this window:

       

      Schermata 2011-06-06 a 11.31.35.png

      The details seems to be:

       

      Schermata 2011-06-06 a 11.32.36.png

      The ugly path you see is where I did unzip the ExtensionBuilder package.

      Actually, that folder was missing (I moved it), but even restoring the original path and files leads to nothing better: the red ! warning disappears, but I still have the conflicting dependency error.

      Any hint?

      Thanks

       

      Davide

        • 1. Re: No Repository Found - conflicting dependency
          david_a_clark Adobe Employee

          Davide

           

          The first error you're getting is about being unable to update some non-ExtBuilder plug-ins (the first I think is an LCDS related plugin, the latter I'm not sure about). Usually Eclipse should be able to show you more details on the dependency conflict in the Details panel, are you able to scroll down from "Cannot complete the install because of a conflicting dependency"?

           

          To install the new Extension Builder plug-ins, you should be able to go to Help > Install New Software... and select the unzipped Extension Builder update site from the dropdown list (or Add it if it isn't there already). Eclipse should then display all the ExtBuilder features and you can go on to complete the wizard

           

          Let me know if that doesn't work for you.

           

          David.

          1 person found this helpful
          • 2. Re: No Repository Found - conflicting dependency
            david_a_clark Adobe Employee

            On re-reading your post I'm not sure if you're trying to install Extension Builder itself. If not, please ignore the second half of my post

            • 3. Re: No Repository Found - conflicting dependency
              DBarranca Level 4

              David,

              thanks for the reply.

              No, I don't want to install EB, it's already there. And yes, there is some additional info (being displayed in one line only, it took me a while - and your hint - to notice that the text was scrollable). It says:

               

              Cannot complete the install because of a conflicting dependency.

                Software being installed: RDS Core and Database Components 4.5.501000.v311934-20110521 (com.adobe.rds.feature.feature.group 4.5.501000.v311934-20110521)

                Software currently installed: Shared profile 1.0.0.1301933628200 (SharedProfile_epp.package.java 1.0.0.1301933628200)

                Only one of the following can be installed at once:

                  RDS Core and Database Components 4.5.501000.v311934-20110521 (com.adobe.rds.feature.feature.jar 4.5.501000.v311934-20110521)

                  RDS Core and Database Components 4.5.304901.v20110217 (com.adobe.rds.feature.feature.jar 4.5.304901.v20110217)

                Cannot satisfy dependency:

                  From: Shared profile 1.0.0.1301933628200 (SharedProfile_epp.package.java 1.0.0.1301933628200)

                  To: com.adobe.rds.feature.feature.jar [4.5.304901.v20110217]

                Cannot satisfy dependency:

                  From: RDS Core and Database Components 4.5.501000.v311934-20110521 (com.adobe.rds.feature.feature.group 4.5.501000.v311934-20110521)

                  To: com.adobe.rds.feature.feature.jar [4.5.501000.v311934-20110521]

               

              Which is close to Chinese to me, but seems to be unrelated to EB.

              Anyway, do you happen to know whether Flash Builder is updated via Adobe Application Manager or not?

              (I'm waiting for FB to update some iOS related stuff - see the comments at the page end here so I'd like to be ready)

              Thank you,

               

              Davide

              • 4. Re: No Repository Found - conflicting dependency
                david_a_clark Adobe Employee

                That is correct, Flash Builder is updated using Adobe Application Manager rather than the Eclipse update site mechanism.

                 

                As you say, the dependency conflict seems unrelated to ExtBuilder. It looks like the update you are doing wants to install a new version of com.adobe.rds.feature.feature.jar, but you already have a feature installed which depends on an earlier version of it.

                • 5. Re: No Repository Found - conflicting dependency
                  david_light

                  I get the exact same error on a fresh install of 4.5.

                   

                  1. Install 4.5 on my Mac
                  2. Configure/do nothing
                  3. Run Update
                  4. Get the following:

                  Screen shot 2011-06-09 at 4.43.20 PM.png

                   

                  I understand there is a conflict, but how do I fix it??

                  • 6. Re: No Repository Found - conflicting dependency
                    david_a_clark Adobe Employee

                    I'd recommend asking on the Flash Builder forums. http://forums.adobe.com/community/flash_builder/

                     

                    But let me know if no one is able to help you there.

                     

                    In general, I think you'd need to uninstall the conflicting features (and features that depend on them) before performing the update.

                    • 7. Re: No Repository Found - conflicting dependency
                      david_light Level 1

                      I have added it to that forum:

                      http://forums.adobe.com/message/3732184#3732184

                       

                      I know the conflicts need to be resolved but there shouldn't be any conflicts in a clean vanilla install of 4.5. Hopefully someone there can answer it for me.

                      • 8. Re: No Repository Found - conflicting dependency
                        Heidi Williams

                        On the Mac, this is a known issue with Eclipse and shared configurations. The message you see is slightly misleading (and is a symptom of several other issues) but if the issue you're seeing is specific to Mac then this technote explains how you can get your plugins on Mac to be installed or updated:

                         

                        http://kb2.adobe.com/cps/895/cpsid_89514.html

                         

                        Hope that helps!

                        -Heidi