16 Replies Latest reply on Aug 10, 2011 2:31 PM by Justin_19

    FB 4.5 BlazeDS Bug ?

    WebTrauma Level 1

      I deleted and re-added some BlazeDS services to my Flex project which was started with Flex 4 and migrated to Flex 4.5.

       

      BlazeDS generates this line of code: _serviceControl.convertResultHandler = mx.data.TypeUtility.convertResultHandler;

       

      ...which throws this error in the IDE:

       

      Description    Resource    Path    Location    Type
      1119: Access of possibly undefined property convertResultHandler through a reference with static type Class.

       

       

      The error goes away when I manually replace the offensive line of code with this:

       

      _serviceControl.convertResultHandler = com.adobe.serializers.utility.TypeUtility.convertResultHandler;

       

       

      Some other people seem to be having this problem as well:

       

      http://forums.adobe.com/thread/860130?tstart=0

       

       

      Is there a fix available for this so I don't have to manually hack my generated BlazeDS classes ?

       

      Thanks!

        • 1. Re: FB 4.5 BlazeDS Bug ?
          WebTrauma Level 1

          I just found another interesting thing about this bug.

           

          If I delete/re-add one service, ALL my services are regenerated instead of just the one I specified...which means I have to go the _Super class for every single service and add the hack again.

          • 2. Re: FB 4.5 BlazeDS Bug ?
            byNeutral

            Same issue here immediatly after a software update!

             

            In fact my previous _Super_Service.as code was generated correctly using the "com.adobe.serializers.utility.TypeUtility"... and only after the update it has started generating the code using the wrong "mx.data.TypeUtility" class that seem not exist.

             

            It's now becoming a very annoying thing because the compiler continue to modify the service class!!!

             

            Any fix?

             

            Edit: I'm currently using the PHP services features

             

            Thanks a lot.

            • 3. Re: FB 4.5 BlazeDS Bug ?
              aubryvn

              Same here after software update !

              • 4. Re: FB 4.5 BlazeDS Bug ?
                WebTrauma Level 1

                Hey, can someone from Adobe chime in here ?

                • 5. Re: FB 4.5 BlazeDS Bug ?
                  Shylendra H V

                  We are investigating it.

                   

                  Btw, what is the version of the new update you received?

                   

                  You can find this by going to Help > About Flash Builder > Installation Details > Installed Software Tab.

                   

                  What are the versions of

                   

                  1. Adobe Data Modeling Core Components
                  2. RDS Core and Database Components

                   

                  -Shylendra
                  1 person found this helpful
                  • 6. Re: FB 4.5 BlazeDS Bug ?
                    aubryvn Level 1

                    Hi Shylendra,

                     

                    1.   Adobe Data Modeling Core Components 4.5.501000.v311934-20110521 com.adobe.model.feature.core.feature.group

                     

                    2.  RDS Core and Database Components 4.5.501000.v311934-20110521 com.adobe.rds.feature.feature.group

                     

                    I hope this will help.

                     

                    Aubry

                    • 7. Re: FB 4.5 BlazeDS Bug ?
                      byNeutral Level 1

                      Same here.

                       

                      From my installation history i see such software updates...

                       

                      From:

                      Adobe Data Modeling Core Components 4.5.304901.v20110217

                      RDS Core and Database Components 4.5.304901.v20110217

                       

                      To:

                      Adobe Data Modeling Core Components 4.5.501000.v311934-20110521

                      RDS Core and Database Components 4.5.501000.v311934-20110521

                       

                      Thanks

                       

                      .Mat

                      • 8. Re: FB 4.5 BlazeDS Bug ?
                        WebTrauma Level 1

                        Thank you, Shylendra.

                         

                        For the Plugin version of FB on the Mac:

                         

                        1. Click 'Eclipse' or in my case 'SpringSource Tool Suite' from the app menu bar
                        2. Click 'About SpringSource Tool Suite'
                        3. Click on 'Installation Details'
                        4. 'Installed Software' tab

                         

                          Adobe Data Modeling Core Components    4.5.501000.v311934-20110521    com.adobe.model.feature.core.feature.group
                          RDS Core and Database Components        4.5.501000.v311934-20110521    com.adobe.rds.feature.feature.group

                        • 9. Re: FB 4.5 BlazeDS Bug ?
                          Shylendra H V Level 1

                          A bug is created for tracking this.

                           

                          http://bugs.adobe.com/jira/browse/FB-31218

                           

                          Meanwhile, as a workaround, you can revert to the previous known good revesion by following the steps defined in the bug.

                           

                          Thanks

                          Shylendra

                          • 10. Re: FB 4.5 BlazeDS Bug ?
                            byNeutral Level 1

                            Thank for the suggestion to rollback in the versdion history but... for me it doesn't work.

                             

                            The error it give me is:

                             

                            An error occurred while collecting items to be installed
                            session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
                            No repository found containing: org.eclipse.update.feature,com.adobe.model.feature.core,4.5.304901.v20110217
                            No repository found containing: org.eclipse.update.feature,com.adobe.rds.feature,4.5.304901.v20110217

                             

                            Is my only option to reinstall FB again?

                            It's about the 3th time i've to reinstall it -_-"

                            • 11. Re: FB 4.5 BlazeDS Bug ?
                              Shylendra H V Level 1

                              Did you follow the steps exactly as mentioned in the bug? If yes in which step did you hit this error?

                               

                              And also do you see these files in your file system?

                               

                              "C:\Program Files\Adobe\Adobe Flash Builder 4.5\eclipse\plugins\com.adobe.rds.core_4.5.304901.v20110217.jar"
                              "C:\Program Files\Adobe\Adobe Flash Builder 4.5\eclipse\plugins\com.adobe.rds.dataview_4.5.304901.v20110217.jar"
                              "C:\Program Files\Adobe\Adobe Flash Builder 4.5\eclipse\plugins\com.adobe.model.core_4.5.304901.v20110217.jar"

                               

                              or on mac they will be under /Applications/Adobe Flash Builder 4.5/eclipse/plugins/

                              • 12. Re: FB 4.5 BlazeDS Bug ?
                                byNeutral Level 1

                                Dunno why but the zip's files was not in the "eclipse\features" folder.

                                My mistake sorry :'(

                                 

                                Now the fix seem to work perfectly.

                                Thanks a lot!

                                • 13. Re: FB 4.5 BlazeDS Bug ?
                                  charlie.sin Level 1

                                  Hi,

                                   

                                  I am experiencing the same issue with Adobe Flash Builder 4.5 but unable to revert.

                                   

                                  I get the same error message "No repository found containing: ....."

                                   

                                  I added the 2 unzipped folders from http://bugs.adobe.com/jira/browse/FB-31218 to "C:\Program Files\Adobe\Adobe Flash Builder 4.5\eclipse\features\".

                                   

                                  I do NOT have the following files in my file system:

                                  "C:\Program Files\Adobe\Adobe Flash Builder 4.5\eclipse\plugins\com.adobe.rds.core_4.5.304901.v20110217.jar"

                                  "C:\Program Files\Adobe\Adobe Flash Builder 4.5\eclipse\plugins\com.adobe.rds.dataview_4.5.304901.v20110217.jar"

                                  "C:\Program Files\Adobe\Adobe Flash Builder 4.5\eclipse\plugins\com.adobe.model.core_4.5.304901.v20110217.jar"

                                   

                                  Any help appreciated.

                                   

                                  Thanks,

                                  Charlie

                                  • 14. Re: FB 4.5 BlazeDS Bug ?
                                    aubryvn Level 1

                                    Hi,

                                     

                                    Same here :

                                     

                                    An error occurred while collecting items to be installed

                                    session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

                                    No repository found containing: osgi.bundle,com.adobe.model.core,4.5.304901.v20110217

                                    No repository found containing: osgi.bundle,com.adobe.rds.core,4.5.304901.v20110217

                                    No repository found containing: osgi.bundle,com.adobe.rds.dataview,4.5.304901.v20110217

                                    No repository found containing: org.eclipse.update.feature,org.tigris.subversion.clientadapter.javahl.feature,1.6.15

                                    No repository found containing: org.eclipse.update.feature,org.tigris.subversion.subclipse,1.6.17

                                    • 15. Re: FB 4.5 BlazeDS Bug ?
                                      charlie.sin Level 1

                                      I did not figure out how to rollback FB.

                                       

                                      I replaced the offending line that was not compiling:

                                      _serviceControl.convertResultHandler = mx.data.TypeUtility.convertResultHandler;

                                       

                                      With this:

                                      _serviceControl.convertResultHandler = com.adobe.serializers.utility.TypeUtility.convertResultHandler;

                                       

                                      I only have 1 service I connect to. Not a big deal for me if I re-gen the service/proxy. If you have many services, could be a pain.

                                       

                                      A fix should be released in the near future. For now, this works.

                                      • 16. Re: FB 4.5 BlazeDS Bug ?
                                        Justin_19

                                        Good Afternoon,

                                        I am still having this problem, I was unable to rall back FB. I always says revert configuration has encountered a problem is they any other solutions to this problem?

                                        Thanks in advance!

                                        Can't what till adobe gets this fixed am tired of typing _serviceControl.convertResultHandler = com.adobe.serializers.utility.TypeUtility.convertResultHandler; every time i make a change.