26 Replies Latest reply on Feb 3, 2012 6:40 AM by Phil.Bart

    A sharing violation occurred...

    Level 7
      A sharing violation occurred while accessing C:...\MFC136.tmp

      This happens nearly every time I edit a page and then F12 it to preview
      (and save it).

      It then brings up the Save As dialog box and I have to save the file as
      if it doesn't exist. Weird.

      Any way to get rid of this error?
        • 1. Re: A sharing violation occurred...
          Level 7
          What version of DW? What OS? What does your site definition look like
          (Local, Remote, Testing)? Does it happen with all files? Does it happen
          with new files?


          --
          David Alcala
          Adobe Product Support


          • 2. Re: A sharing violation occurred...
            Level 7
            David Alcala - Adobe wrote:
            > What version of DW? What OS? What does your site definition look like
            > (Local, Remote, Testing)? Does it happen with all files? Does it happen
            > with new files?
            >
            >

            DW8 on XP Pro SP2.

            It happens on all sites and all files.
            • 3. Re: A sharing violation occurred...
              Level 7
              ryansebiz wrote:
              > A sharing violation occurred while accessing C:...\MFC136.tmp
              >
              > This happens nearly every time I edit a page and then F12 it to preview
              > (and save it).
              >
              > It then brings up the Save As dialog box and I have to save the file as
              > if it doesn't exist. Weird.
              >
              > Any way to get rid of this error?

              Can anyone please help me?
              • 4. Re: A sharing violation occurred...
                Level 7


                > ryansebiz wrote:
                >> A sharing violation occurred while accessing C:...\MFC136.tmp
                >>

                are you using BitDefender as the A/V?

                does the error stop if you temp disable the a/v?

                if it does- go into the bitdefender settings and exclude the folders
                containing your site files from being scanned.

                • 5. Re: A sharing violation occurred...
                  DJ ram
                  Hi all,

                  Even i have the same problem. When i try to save a file it shows a error "A sharing violation occurred while accessing E:\.....\MFC107.tmp. Also, it deletes the file which i try to save. So i need to save the file in the same location again. It happens both in DW 8 and DW MX.

                  Can anybody help in this issue?
                  • 6. Re: A sharing violation occurred...
                    GrantHorizons
                    quote:

                    Originally posted by: DJ ram
                    Hi all,

                    Even i have the same problem. When i try to save a file it shows a error "A sharing violation occurred while accessing E:\.....\MFC107.tmp. Also, it deletes the file which i try to save. So i need to save the file in the same location again. It happens both in DW 8 and DW MX.

                    Can anybody help in this issue?


                    -----------------------------------------------------
                    Exact same problem. System WAS working fine for many months, no changes other than usual MS patches.

                    Details:

                    WinXP with all patches.
                    My "local files" is on a network box running win2k with the website files in a shared folder, to my computer it's W:. Whenever I save a file in DW8, same as above:

                    A sharing violation occurred while accessing w:\mysite\MVFxxx.tmp

                    Click ok, and the file I was saving is wiped out. Re-saving as a new file works fine. Save it again, and all over again. I have DW MX on a separate computer, and it works fine, no problems, accessing the same files etc.

                    Interestingly, sometimes - usually - it takes a minute or two or more to finally get around to announcing the violation, (hourglass in the meantime,) with one of two DIFFERENT windows sounds. A "tink" and a "dum!" - best I can do... ;)

                    Anything that seems to use the win explorer module is also "stuck" in the meantime. Other programs work fine.

                    No, I don't have the file open anywhere else with any other program. Only possible culprit is antivirus, Trend Micro Internet Security on all three computers. BUT I turned it off completely on the server, and no help, so unlikely.

                    Since it works fine on the other computer running DWMX, why not on mine? DW8...

                    So I uninstalled and reinstalled DW8, and installed the two patches, one at a time, and same problem - though I didn't test without a patch at all - it WAS working!

                    Searching the net this seems to be a common problem going back for years, intermittently. And I've yet to see an answer.

                    Perhaps time Adobe took a look at it?

                    thanks for any ideas and assistance,

                    Grant

                    • 7. Re: A sharing violation occurred...
                      Level 7
                      I recommend you contact Macromedia directly and use one of your one-on-one
                      support incidents.

                      http://www.macromedia.com/support/email/complimentary/main.cgi


                      --
                      Murray --- ICQ 71997575
                      Adobe Community Expert
                      (If you *MUST* email me, don't LAUGH when you do so!)
                      ==================
                      http://www.dreamweavermx-templates.com - Template Triage!
                      http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
                      http://www.dwfaq.com - DW FAQs, Tutorials & Resources
                      http://www.macromedia.com/support/search/ - Macromedia (MM) Technotes
                      ==================


                      "GrantHorizons" <webforumsuser@macromedia.com> wrote in message
                      news:ed4n6v$fne$1@forums.macromedia.com...
                      >
                      quote:

                      Originally posted by: DJ ram
                      > Hi all,
                      >
                      > Even i have the same problem. When i try to save a file it shows a error
                      > "A
                      > sharing violation occurred while accessing E:\.....\MFC107.tmp. Also, it
                      > deletes the file which i try to save. So i need to save the file in the
                      > same
                      > location again. It happens both in DW 8 and DW MX.
                      >
                      > Can anybody help in this issue?

                      >
                      > -----------------------------------------------------
                      > Exact same problem. System WAS working fine for many months, no changes
                      > other
                      > than usual MS patches.
                      >
                      > Details:
                      >
                      > WinXP with all patches.
                      > My "local files" is on a network box running win2k with the website files
                      > in a
                      > shared folder, to my computer it's W:. Whenever I save a file in DW8,
                      > same as
                      > above:
                      >
                      > A sharing violation occurred while accessing w:\mysite\MVFxxx.tmp
                      >
                      > Click ok, and the file I was saving is wiped out. Re-saving as a new file
                      > works fine. Save it again, and all over again. I have DW MX on a separate
                      > computer, and it works fine, no problems, accessing the same files etc.
                      >
                      > Interestingly, sometimes - usually - it takes a minute or two or more to
                      > finally get around to announcing the violation, (hourglass in the
                      > meantime,)
                      > with one of two DIFFERENT windows sounds. A "tink" and a "dum!" - best I
                      > can
                      > do... ;)
                      >
                      > Anything that seems to use the win explorer module is also "stuck" in the
                      > meantime. Other programs work fine.
                      >
                      > No, I don't have the file open anywhere else with any other program. Only
                      > possible culprit is antivirus, Trend Micro Internet Security on all three
                      > computers. BUT I turned it off completely on the server, and no help, so
                      > unlikely.
                      >
                      > Since it works fine on the other computer running DWMX, why not on mine?
                      > DW8...
                      >
                      > So I uninstalled and reinstalled DW8, and installed the two patches, one
                      > at a
                      > time, and same problem - though I didn't test without a patch at all - it
                      > WAS
                      > working!
                      >
                      > Searching the net this seems to be a common problem going back for years,
                      > intermittently. And I've yet to see an answer.
                      >
                      > Perhaps time Adobe took a look at it?
                      >
                      > thanks for any ideas and assistance,
                      >
                      > Grant
                      >
                      >
                      >


                      • 8. Re: A sharing violation occurred...
                        Level 7
                        Does it happen with a new site definition setup something like this (local
                        folder on your C: drive, no remote folders)?:

                        Local Root Folder: C:\dw_sites\my_site
                        Remote Folder: none
                        Testing Server: none

                        Have you tried uninstalling and reinstalling Dreamweaver following the steps
                        in these TechNotes?:

                        Uninstalling Studio 8 applications on Windows
                        http://www.adobe.com/go/4e7826b7

                        Installing Studio 8 products in Selective Startup mode on Windows XP
                        http://www.adobe.com/go/d2b5934d

                        As Murray mentioned, please contact tech support. It would also be helpful
                        if you could submit a bug report:

                        http://www.adobe.com/go/wish


                        --
                        David Alcala
                        Adobe Product Support


                        • 9. Re: A sharing violation occurred...
                          GrantHorizons Level 1
                          quote:

                          Originally posted by: Newsgroup User
                          Does it happen with a new site definition setup something like this (local
                          folder on your C: drive, no remote folders)?:

                          Local Root Folder: C:\dw_sites\my_site
                          Remote Folder: none
                          Testing Server: none




                          Yes, same result when it's on the server.

                          NO problem when it's on MY computer.


                          quote:

                          Originally posted by: Newsgroup User
                          Have you tried uninstalling and reinstalling Dreamweaver following the steps
                          in these TechNotes?:

                          Uninstalling Studio 8 applications on Windows
                          http://www.adobe.com/go/4e7826b7

                          Installing Studio 8 products in Selective Startup mode on Windows XP
                          http://www.adobe.com/go/d2b5934d

                          As Murray mentioned, please contact tech support. It would also be helpful
                          if you could submit a bug report:

                          http://www.adobe.com/go/wish

                          --
                          David Alcala
                          Adobe Product Support




                          No, just did a basic Windows uninstall and reinstall. Did not delete all user info etc. Will try all that later. $&(*%#

                          Also put in a report to Adobe for support - we'll see.

                          rant
                          Why is it always so flippin' hard? I've been dealing with computers heavy since 1986, and I think it's getting worse not better. Maybe I'll go back to being a mechanic, at least then problems were always solvable!
                          /rant - still depressed.
                          • 10. Re: A sharing violation occurred...
                            Level 7
                            Hi GrantHorizons

                            Thanks for the additional info. Yes, please try doing the 'full'
                            uninstall/reinstall using the TechNotes.

                            It'd be great if you could file a bug report too, so I can get your contact
                            info and track your tech support incident. Also, if you submit a bug
                            report, it'll be read by some engineers who may have some helpful input.
                            When you file the bug report, please include your forum username, so we can
                            link your bug report to your forum posts.

                            Are you working in a group? If so, is anyone else in your group having the
                            same problem? You mentioned you had another computer running DW MX. Can
                            you install the DW 8 trial on it and see if it has the same problem? You
                            can have both DW MX and 8 on the same PC.

                            Thanks,

                            David Alcala
                            Adobe Product Support


                            • 11. Re: A sharing violation occurred...
                              Level 7
                              Alan wrote:
                              >
                              >> ryansebiz wrote:
                              >>> A sharing violation occurred while accessing C:...\MFC136.tmp
                              >>>
                              >
                              > are you using BitDefender as the A/V?
                              >
                              > does the error stop if you temp disable the a/v?
                              >
                              > if it does- go into the bitdefender settings and exclude the folders
                              > containing your site files from being scanned.
                              >

                              Alan - thanks for your reply.

                              Yes, I do have BitDefender 9 Standard. I have had this problem for a
                              couple weeks before I bought BitDefender though. I also have Webroot Spy
                              Sweeper 5 and AVG Free 7.1.

                              I completely exited out of all three programs and I still have the
                              "sharing" problem.

                              Like Grant mentioned, I don't have the files open on any other
                              computers. When I save the file it deletes the original - then I have to
                              save where the original file was for things to work. It also plays one
                              of two error sounds in XP.

                              So no one knows how to fix this problem?
                              • 12. Re: A sharing violation occurred...
                                Level 7
                                David Alcala - Adobe wrote:
                                > Does it happen with a new site definition setup something like this (local
                                > folder on your C: drive, no remote folders)?:
                                >
                                > Local Root Folder: C:\dw_sites\my_site
                                > Remote Folder: none
                                > Testing Server: none
                                >
                                > Have you tried uninstalling and reinstalling Dreamweaver following the steps
                                > in these TechNotes?:
                                >
                                > Uninstalling Studio 8 applications on Windows
                                > http://www.adobe.com/go/4e7826b7
                                >
                                > Installing Studio 8 products in Selective Startup mode on Windows XP
                                > http://www.adobe.com/go/d2b5934d
                                >
                                > As Murray mentioned, please contact tech support. It would also be helpful
                                > if you could submit a bug report:
                                >
                                > http://www.adobe.com/go/wish
                                >
                                >

                                David - thanks for your reply.

                                I followed the instructions exactly and I still have the same problem.

                                Now I have reinstall all my extension and reconfigure my settings, but
                                that was a necessary risk.

                                Is there no way to fix this?
                                • 13. Re: A sharing violation occurred...
                                  DJ ram Level 1
                                  Hi all,

                                  I had the same problem and posted it in the same thread. I fixed the problem now. Its something crazy ;-) . But it works. Its nothing to do with dreamweaver(I excatly dont know who the problem is).

                                  I have all the site files in a server which is accesed by all my team members. All had the same problem(Even though we use different version of DW). I just formatted the server machine and opened and saved files using DW. There is no problems now. Everthing is working fine. But i still dont know who caused the problem. DW or my server machine. But anyways i have no problems now :-)

                                  • 14. Re: A sharing violation occurred...
                                    GrantHorizons Level 1
                                    Ok, it gets weirder - sorta.

                                    I was away on vacation, came back, both my machine (WinXP) and the server (Win2k) had Windows updates to install, so I did, then got to work - and Dreamweaver is fine. So maybe it's a Microsoft problem that DW got caught up in.

                                    NOTES:

                                    NO other program had any difficulty saving files to the server - all our work is on the server, shared by two computers / workers. NO trouble at all except with DW 8.

                                    REinstalling DW as suggested above seems to be a waste of time - fortunately I didn't go through all that hassle.

                                    If it comes back I'll post it here.


                                    • 15. Re: A sharing violation occurred...
                                      Outofnowhere
                                      We solved this error for Dreamweaver 8 by clearing the site cache.

                                      From the top menu, select "Site".
                                      Select "Advanced".
                                      Select "Recreate Site Cache".

                                      Maybe it was a fluke but it worked for me.
                                      • 16. Re: A sharing violation occurred...
                                        keydongle Level 1

                                        I too encountered this problem with DW CS4. To get rid of it, I clicked on Site->ManageSites->Edit (for the site of interest) and then on the Advanced tab using Local Info as the category, I unclicked "enable cache" and then clicked OK, then Done. Then I previewed the site using two browser types (IE7 and FF 3) and everything appeared correctly with no more "A sharing violation occurred..." error. Not only that, but the previous problem of not having FireFox render the file's background image correctly suddenly started working again. This was actually my original problem since it would render fine in IE, but didn't render OK in FireFox.

                                         

                                        Then I went back into Site->ManageSites->Edit and turned the enable cache setting back on. Problem seems to have disappeared. weird

                                         

                                        stevebo

                                        • 17. Re: A sharing violation occurred...
                                          slider6902 Level 1

                                          Same issue.  Running CS4 and Windows 7 Ult.  Happens at work and home office.

                                          Error: "A sharing violation occured while accessing N:\....[path-location]...\MFC72F1.tmp."

                                           

                                          When this happens i cannot save, instead i get the above error.  i then have to click on explorer window, wait 3 seconds, then my file will dissappear/delete itself.  i then go back to DW-CS4 and 'save as' to continue.  Once i complete this monotonous process, it will not happen again unless i close file and re-open said file(s).

                                           

                                          There are rare occassion that this doesn't happen, but i would say it happens about 90% of the time.

                                          • 18. Re: A sharing violation occurred...
                                            ComboAlex

                                            I had exactly the same problem. I was editing a CSS file in DW 8. I found out that JRun was somehow sharing the file. JRun is used by my local ColdFusion server, so I simply went to the Coldfusion Administrator and cleared the Template cache. After that I was able to modify my file again. Now I will see if the problem will appear again.

                                             

                                            How did I found out which process is using the same file I was editing? Well, I saved the file under another name and tried to delete the original file. By doing that, Dreamweaver denied the action (which was actually the problem) and said something like this: "The file cannot be deleted because it is being used by JRun". This is where I got the clue!!! Finally I was able to see which freakin process is sharing my file, making it impossible to modify it!

                                             

                                            Since JRun is used my my Coldfusion server I went to the task manager of my WIN7 and ended the ColdFusion Server processes (You cannot just end the JRun process if another running process is dependant on it). After that I FINALLY was able to modify the original file I couldn't modify before. So I restarted my CF server process and, like already written, cleared the Template cache.

                                             

                                            Hopefully this helps. So Try to make a copy of your original file that you are having problems to modify and delete the original IN DREAMWEAVER! Hopefully Dreamweaver will tell you why it cannot delete it and most important, which process is also sharing the file, resulting in a sharing violation we want to avoid.

                                            • 19. Re: A sharing violation occurred...
                                              ComboAlex Level 1

                                              OMG! As it seems the problem persists! However at least now I know that if I clear the Cache in the CF Administrator I can modify the original file. Which is so annoying! It is impossible to work like that! does anyone have a better idea?

                                              • 20. Re: A sharing violation occurred...
                                                ComboAlex Level 1

                                                Very interesting. I went to the CF Server administration panel and in Server Settings -> Request tuning changed "Maximum number of running JRun threads" into 1. I am not sure if this is the proper solution to the problem, however for now this worked! Will see what happens next.

                                                • 21. Re: A sharing violation occurred...
                                                  milesian

                                                  Yes, you're probably right. I've closed all the browsers and even dreamweaver and attacked files via the folders (I get so fed up I create a new file, delete the file that won't save and then rename the file as the original. Quite often, with no program at all running, it tells me that the file/webpage cannot be deleted because some program is already using it, this suggests a caching issue somewhere. Adobe really need to sort this out.

                                                   

                                                  This is one of the most annoying bugs but it drives me mad how bug riddled nearly all Adobe products are when they are first released (i.e. you update from a stable level (i.e Studio 8) and find your productivity goes down due to all sorts of glitches in the new software.

                                                   

                                                  T.Dolan

                                                  Windows XP, Adobe CS4 Web, Chrome, IE8, Firefox

                                                   

                                                  PS: I'll give you a  DW bug thats about ten years old. You click on an navigation bar in DW and then edit it in Fireworks (doesn't matter what the edit is), when you click DONE, the page is updated etc, however your drop down menus have meanwhile been lost.

                                                  • 22. Re: A sharing violation occurred...
                                                    SMCTD

                                                    If the sharing violation occurs from a network file, make sure the file is opened via a mapped drive -- not via a UNC path.

                                                     

                                                    GOOD:

                                                    N:\share\share\file.html

                                                     

                                                    BAD:

                                                    \\servername\share\share\file.html

                                                    • 23. Re: A sharing violation occurred...
                                                      milesian Level 1

                                                      Many thanks for the response. The problem appears to have evaporated or at least I have noticed it in  a while. I'm not sure how this happens as I don't think Adobe do automatic updates like Microsoft, or do they?

                                                       

                                                      The files will all typically be coldfusion files so there will always be a testing server specified http://localhost:8500/myWebsite/rmyIndex.cfm I'm not sure if that's what you're referring to. These are all specified when a project is first setup.

                                                      • 24. Re: A sharing violation occurred...
                                                        Thomas Andrew King

                                                        Okay I joined adobe forums just for this error message.

                                                         

                                                        The solution is to turn OFF windows preview pane in explorer.  I believe this is holding some type of lock on the file which causes Dreamweaver to throw the error, this occurs because because people often double click or "right click - open with" on the file they want to edit and thus leave the preview window still on that file.  Worse yet is that if you fail to save as the file and simply close the window it will DELETE the file.  That's right not just not save the file, delete the whole thing. Scary.

                                                         

                                                        I have replicated this error on two machines. Please note this was on a mapped drive.

                                                         

                                                        I hope this helps someone and Adobe/Microsoft figure this out.  Data loss is not cool.

                                                         

                                                        Thomas King

                                                         

                                                        Message was edited by: Thomas Andrew King

                                                        • 25. Re: A sharing violation occurred...
                                                          Royal Silk

                                                          What worked for me for this annoying error was to simply exit the program, return to the dwt file then "save all".  This worked.

                                                          • 26. Re: A sharing violation occurred...
                                                            Phil.Bart

                                                            I had a problem like that.  This worked for me!

                                                             

                                                            http://www.longPathTool.com

                                                             

                                                            Path too long.

                                                             

                                                            Error cannot delete file: cannot read from source file or disk

                                                             

                                                            Cannot delete file: Access is denied

                                                             

                                                            There has been a sharing violation.

                                                             

                                                            Cannot delete file or folder The file name you specified

                                                            is not valid or too long. Specify a different file name.

                                                             

                                                            The source or destination file may be in use.

                                                             

                                                            The file is in use by another program or user.

                                                             

                                                            Error Deleting File or Folder

                                                             

                                                            Make sure the disk is not full or write-protected and that the file is not currently in use.

                                                             

                                                            Path too deep.