2 Replies Latest reply on Jun 13, 2011 6:19 PM by ALiborio

    Images and swf aren't loading on iOS

    ALiborio

      I've been developing a game using FlashBuilder 4.5. It's been working on Android but when I exported to iOS I only get some of the images to show while others are not.

       

      The images that are showing are static images that are loaded using [Embed(source='')]. The ones that aren't are the ones loaded using the Loader class.  This is the only relation I see between those that have shown and those that haven't. I may be able to use the Embed way for some static images but I don't think I can use that for .swf files which I need to load.

       

      As I've said before they have been working on Android. They also show up in the emulator but once deployed to the iOS not all the images load.

        • 1. Re: Images and swf aren't loading on iOS
          ALiborio Level 1

          Okay just an update. I have been able to use the Embed method to load up both images and swf files. However the swf files are not showing up on the iPod still. The images that weren't showing when using the Loader class are now showing. Any insight into remedying this problem is greatly appreciated.

          • 2. Re: Images and swf aren't loading on iOS
            ALiborio Level 1

            OK just an update that maybe people can help me with.

            We figured out why they aren't showing. Even though my artist friend who made them didn't include any actionscript code when he made them, flash attached an actionscript file that only contained an empty class when he exported it to .swf.  I found this out by decompiling the .swf. Apparently iOS doesn't like .swfs with code attached and that's why they won't load up.  I've talked to him about it and he's not sure how to remedy the situation. There seems to be only one way to export to swf and that is somehow attaching a .as to it.

             

            So basically what I'm asking is now to ensure that the .swf won't contain any actionscript at all. Is there some settings in flash or some specific way in creating the movie that makes sure this doesn't happen?