4 Replies Latest reply on Jun 9, 2011 2:51 AM by ReaderTorture

    What Version of Reader Is Compatible?

    ReaderTorture Level 1

      The Adobe website won't tell me which version for Reader is compatible with a G5 (Intel) iMac and Mac OS 10.4.11 and where to download it.

      I call that AdobeTorture