21 Replies Latest reply on Mar 19, 2012 3:10 AM by Rahul S.

    Flash Builder 4.5 fails to update after a clean install

    david_light
      1. Install 4.5 on my Mac
      2. Configure nothing/do nothing
      3. Run Update
      4. Get the following:

      Screen shot 2011-06-09 at 4.43.20 PM.png

      I am getting conflicts even though alll I have done is a fresh install.

        • 1. Re: Flash Builder 4.5 fails to update after a clean install
          Miggl Level 1

          I'm having the same issue. Have you been able to find a solution?

          • 2. Re: Flash Builder 4.5 fails to update after a clean install
            david_light Level 1

            Nothing yet. I will post if I do.

            • 3. Re: Flash Builder 4.5 fails to update after a clean install
              C. Agruss (Adobe) Level 3

              I'm working on a different team these days, but will forward this message to the installer devs for FB, in hopes they will respond soon.

               

              -Chris

              • 4. Re: Flash Builder 4.5 fails to update after a clean install
                Sidhe

                I too am getting similar error when attempting a software update. Mac OS X 10.6.7, I do use SourceMate so not sure if that has anything to do with it. I tried changing my java preferences to use 32 bit as I read in another forum post but that didn't help.

                 

                Cannot complete the install because of a conflicting dependency.
                  Software being installed: Adobe Data Modeling Core Components 4.5.310758.v20110503 (com.adobe.model.feature.core.feature.group 4.5.310758.v20110503)
                  Software currently installed: Shared profile 1.0.0.1301933628200 (SharedProfile_epp.package.java 1.0.0.1301933628200)
                  Only one of the following can be installed at once: 
                    Adobe Data Modeling Core Components 4.5.310758.v20110503 (com.adobe.model.feature.core.feature.jar 4.5.310758.v20110503)
                    Adobe Data Modeling Core Components 4.5.304901.v20110217 (com.adobe.model.feature.core.feature.jar 4.5.304901.v20110217)
                  Cannot satisfy dependency:
                    From: Shared profile 1.0.0.1301933628200 (SharedProfile_epp.package.java 1.0.0.1301933628200)
                    To: com.adobe.model.feature.core.feature.jar [4.5.304901.v20110217]
                  Cannot satisfy dependency:
                    From: Adobe Data Modeling Core Components 4.5.310758.v20110503 (com.adobe.model.feature.core.feature.group 4.5.310758.v20110503)
                    To: com.adobe.model.feature.core.feature.jar [4.5.310758.v20110503]
                
                
                
                
                • 5. Re: Flash Builder 4.5 fails to update after a clean install
                  Unni Gopinathan S Adobe Employee

                  Hi,

                   

                  In /Applications/Adobe Flash Builder 4.5/eclipse/configuration/config.ini comment the following three lines then launch the FB and try to update.

                   

                  eclipse.p2.data.area=@config.dir/../p2/
                  osgi.configuration.area=@user.home/Documents/Adobe Flash Builder 4.5/cascaded/308971/configuration

                  osgi.configuration.cascaded=true

                   

                  Please backup the config.ini file and replace once you updated the plugins(with the all the three lines uncommented).

                   

                  Please let me know if this works.

                   

                  Regards

                   

                  Unni G S

                  • 6. Re: Flash Builder 4.5 fails to update after a clean install
                    Sidhe Level 1

                    That fixed it for me, thanks.

                    • 7. Re: Flash Builder 4.5 fails to update after a clean install
                      Miggl Level 1

                      Hi,

                       

                      Thanks for your advice. That seemed to fix it for 2 of the 3 updates. I have Flash Builder 4.5 for PHP installed, and it wants to perform the following update, but can't due to conflicting dependancies:

                       

                      Eclipse IDE for Java Developers     1.3.2.20110301-1807

                      • 9. Re: Flash Builder 4.5 fails to update after a clean install
                        spankmaster79

                        Didn't work for me... here's my edited config.ini

                         

                        Bildschirmfoto 2011-06-20 um 17.31.57.png

                        • 10. Re: Flash Builder 4.5 fails to update after a clean install
                          KidTroopa

                          Thx Unni.... your fix worked for me.

                          • 11. Re: Flash Builder 4.5 fails to update after a clean install
                            Miggl Level 1

                            I still get the following:

                            Cannot complete the install because of a conflicting dependency.

                              Software being installed: Eclipse IDE for Java Developers 1.3.2.20110301-1807 (epp.package.java 1.3.2.20110301-1807)

                              Software currently installed: Zend Studio for Flash Builder 4.5.0.v20110330-0922-8J8yCdFQvEteMB1ipqJu8S1Kg6GD (com.zend.php.flashbuilder.all.feature.group 4.5.0.v20110330-0922-8J8yCdFQvEteMB1ipqJu8S1Kg6GD)

                              Only one of the following can be installed at once:

                                ECF Core API 3.1.0.v20100529-0735 (org.eclipse.ecf 3.1.0.v20100529-0735)

                                ECF Core API 3.1.0.v20100906-1425 (org.eclipse.ecf 3.1.0.v20100906-1425)

                              Only one of the following can be installed at once:

                                Team Support UI 3.5.100.I20100527-0800 (org.eclipse.team.ui 3.5.100.I20100527-0800)

                                Team Support UI 3.5.101.R36x_v20100825-0800 (org.eclipse.team.ui 3.5.101.R36x_v20100825-0800)

                                Team Support UI 3.5.102.R36x_v20110203-1036 (org.eclipse.team.ui 3.5.102.R36x_v20110203-1036)

                              Only one of the following can be installed at once:

                                Universal Welcome 3.2.402.r36_v20100702 (org.eclipse.ui.intro.universal 3.2.402.r36_v20100702)

                                Universal Welcome 3.2.400.v20100517 (org.eclipse.ui.intro.universal 3.2.400.v20100517)

                              Cannot satisfy dependency:

                                From: Zend Studio Feature 8.0.1.v20101203-1424-Bb7Z97Fh1z-WD1aeVEsRvwW (com.zend.php.feature.group 8.0.1.v20101203-1424-Bb7Z97Fh1z-WD1aeVEsRvwW)

                                To: org.eclipse.ecf [3.1.0.v20100529-0735]

                              Cannot satisfy dependency:

                                From: Zend Studio for Flash Builder 4.5.0.v20110330-0922-8J8yCdFQvEteMB1ipqJu8S1Kg6GD (com.zend.php.flashbuilder.all.feature.group 4.5.0.v20110330-0922-8J8yCdFQvEteMB1ipqJu8S1Kg6GD)

                                To: com.zend.php.feature.group [8.0.1.v20101203-1424-Bb7Z97Fh1z-WD1aeVEsRvwW]

                              Cannot satisfy dependency:

                                From: Eclipse IDE for Java Developers 1.3.2.20110301-1807 (epp.package.java 1.3.2.20110301-1807)

                                To: org.eclipse.epp.package.java.feature.feature.group [1.3.2.20110301-1807]

                              Cannot satisfy dependency:

                                From: Eclipse IDE for Java Developers 1.3.2.20110301-1807 (epp.package.java 1.3.2.20110301-1807)

                                To: org.eclipse.platform.ide 0.0.0

                              Cannot satisfy dependency:

                                From: EPP Java Package 1.3.2.20110301-1807 (org.eclipse.epp.package.java.feature.feature.group 1.3.2.20110301-1807)

                                To: org.eclipse.platform.feature.group [3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi]

                              Cannot satisfy dependency:

                                From: Equinox p2 Provisioning 2.0.1.r361_v20100903-897HFa-FX0z-z-ntoaavz0JPX628 (org.eclipse.equinox.p2.user.ui.feature.group 2.0.1.r361_v20100903-897HFa-FX0z-z-ntoaavz0JPX628)

                                To: org.eclipse.ecf [3.1.0.v20100906-1425]

                              Cannot satisfy dependency:

                                From: Eclipse Platform 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY (org.eclipse.platform.feature.group 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)

                                To: org.eclipse.ui.intro.universal [3.2.400.v20100517]

                              Cannot satisfy dependency:

                                From: Eclipse Platform 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)

                                To: org.eclipse.team.ui [3.5.101.R36x_v20100825-0800]

                              Cannot satisfy dependency:

                                From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)

                                To: org.eclipse.team.ui [3.5.102.R36x_v20110203-1036]

                              Cannot satisfy dependency:

                                From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)

                                To: org.eclipse.ui.intro.universal [3.2.402.r36_v20100702]

                              Cannot satisfy dependency:

                                From: Eclipse Platform 3.6.0.I20100608-0911 (org.eclipse.platform.ide 3.6.0.I20100608-0911)

                                To: org.eclipse.platform.feature.group [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]

                              Cannot satisfy dependency:

                                From: Eclipse Platform 3.6.1.M20100909-0800 (org.eclipse.platform.ide 3.6.1.M20100909-0800)

                                To: org.eclipse.platform.feature.group [3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L]

                              Cannot satisfy dependency:

                                From: Eclipse Platform 3.6.2.M20110210-1200 (org.eclipse.platform.ide 3.6.2.M20110210-1200)

                                To: org.eclipse.equinox.p2.user.ui.feature.group [2.0.1.r361_v20100903-897HFa-FX0z-z-ntoaavz0JPX628]

                            • 12. Re: Flash Builder 4.5 fails to update after a clean install
                              jeff_penano

                              I recently reinstalled Flash Builder and I am getting this exact issue. Commenting out the 3 lines in the config.ini file don't do anything to help.

                              • 13. Re: Flash Builder 4.5 fails to update after a clean install
                                JayeshViradiya Adobe Employee

                                This response is not meant for this thread. Ignore it.

                                 

                                Hello All,

                                 

                                Eclipse update can not be used to updater FB4.5 to FB4.5.1.

                                Right way to update would be to use "Help --> Search for Flash Builder Updates" menu item. This action will launch "Adobe Application Manager" which will present you with the available and applicable FB related updates. Make sure that in "AdobeApplicationManager->Preferences" you have FB checked.

                                 

                                Try it and let us know.

                                 

                                -Jayesh Viradiya

                                FB Team

                                • 14. Re: Flash Builder 4.5 fails to update after a clean install
                                  John R Nyquist Level 1

                                  I had the exact same error as David from a clean install on my Mac. Unni's solution worked for me (thanks!).

                                   

                                  My question is, what were those three lines that we commented out, why did it work, and why did we have to do that on a clean install?

                                   

                                  Regards,

                                  John

                                  • 15. Re: Flash Builder 4.5 fails to update after a clean install
                                    david_light Level 1

                                    I ended up eliminating some of the update sites and picking specific updates based on fellow developer's settings. Definitely not something I would expect to have to do out of the box.

                                    • 16. Re: Flash Builder 4.5 fails to update after a clean install
                                      m r erickson

                                      I just ran into the same problem on a new installation of Flash Builder Pro 4.5, note that the Adobe Application Manager did perform an update before I first launched FB myself. Definately not something I would expect either.

                                       

                                      Can you say what settings yoiu did use, might be helpful to share (and it sounds like you turned off the updates to avoid the conflicting update error).

                                      • 17. Re: Flash Builder 4.5 fails to update after a clean install
                                        m r erickson Level 1

                                        I now have the installation working, but did not comment exactly the same lines as Unni's solution. I found the following article in Adobe's knowledge base:

                                         

                                        http://kb2.adobe.com/cps/895/cpsid_89514.html

                                         

                                        This article refers to the problem where third party plug-in are installed in the user directory rather than the Flash Builder application directory. You can force installation into the application directory by commenting out these lines:

                                         

                                         

                                        osgi.configuration.area=@user.home/Documents/Adobe Flash Builder 4.5/cascaded/<build number>/configuration  osgi.shared.configuration.area=file\:configuration  osgi.configuration.cascaded=true

                                         

                                        I commented out these lines, and the update worked. It looks like the problem is competing dependencies between FB4.5 user and application directories. By removing the reference to your user directory, everything can be updated, everything in your Flash Builder 4.5 application directory. I am still curious why Unni commented the "eclipse.p2.data.area=@config.dir/../p2/" line.

                                         

                                        Adobe should really comment on a solution or fix this issue. I suspect I'm going to run into problems later, now that I have updated the application directory, but Adobe *did* recommend this approach for other plug-ins in their knowledge base.

                                        • 18. Re: Flash Builder 4.5 fails to update after a clean install
                                          Ravi Sharma Level 1

                                          Thanks a ton Unni, for helping out !!!!!

                                           

                                          It works perfectly fine for me......

                                          • 19. Re: Flash Builder 4.5 fails to update after a clean install
                                            Namobhagavan

                                            same here

                                             

                                            Eclipse IDE for Java Developers     1.3.2.20110301-1807

                                            cannot be updated

                                            • 20. Re: Flash Builder 4.5 fails to update after a clean install
                                              O Red

                                              i'm using Flash Builder 4.6 for PHP and tried uncommenting the config lines and still get these errors.

                                              In addition, i want to install the ADT Plugin to do native android development and get the same error.  This is really frustrating since i just want to use 1 IDE for all my dev.  Please HELP!!

                                               

                                              Cannot complete the install because of a conflicting dependency.

                                                Software being installed: Eclipse IDE for Java Developers 1.3.2.20110301-1807 (epp.package.java 1.3.2.20110301-1807)

                                                Software currently installed: BlackBerry Tablet OS Plugin for Adobe Flash Builder 1.2.0.201110311231 (com.qnx.tools.flashbuilder45.feature.group 1.2.0.201110311231)

                                                Software currently installed: Zend Studio for Flash Builder 4.5.1.v20110609-1000-8J8yCeFQvEteMB6jnqJy3X1Kg6GL (com.zend.php.flashbuilder.all.feature.group 4.5.1.v20110609-1000-8J8yCeFQvEteMB6jnqJy3X1Kg6GL)

                                                Only one of the following can be installed at once:

                                                  Core File Systems 1.3.0.v20100526-0737 (org.eclipse.core.filesystem 1.3.0.v20100526-0737)

                                                  Core File Systems 1.3.1.R36x_v20100727-0745 (org.eclipse.core.filesystem 1.3.1.R36x_v20100727-0745)

                                                Only one of the following can be installed at once:

                                                  ECF Core API 3.1.0.v20100529-0735 (org.eclipse.ecf 3.1.0.v20100529-0735)

                                                  ECF Core API 3.1.0.v20100906-1425 (org.eclipse.ecf 3.1.0.v20100906-1425)

                                                Only one of the following can be installed at once:

                                                  Views 3.5.0.I20100527-0800 (org.eclipse.ui.views 3.5.0.I20100527-0800)

                                                  Views 3.5.1.M20110202-0800 (org.eclipse.ui.views 3.5.1.M20110202-0800)

                                                Cannot satisfy dependency:

                                                  From: BlackBerry Tablet OS Core Shared 1.1.0.201110311231 (com.qnx.tools.bbt.core 1.1.0.201110311231)

                                                  To: bundle org.eclipse.core.filesystem [1.3.1,2.0.0)

                                                Cannot satisfy dependency:

                                                  From: BlackBerry Tablet OS Plugin for Adobe Flash Builder 1.2.0.201110311231 (com.qnx.tools.flashbuilder45.feature.group 1.2.0.201110311231)

                                                  To: com.qnx.tools.bbt.core [1.1.0.201110311231]

                                                Cannot satisfy dependency:

                                                  From: Zend Studio Feature 8.0.1.v20101203-1424-Bb7Z98Fh1z-WD1aqSLsR8mU (com.zend.php.feature.group 8.0.1.v20101203-1424-Bb7Z98Fh1z-WD1aqSLsR8mU)

                                                  To: org.eclipse.ecf [3.1.0.v20100529-0735]

                                                Cannot satisfy dependency:

                                                  From: Zend Studio for Flash Builder 4.5.1.v20110609-1000-8J8yCeFQvEteMB6jnqJy3X1Kg6GL (com.zend.php.flashbuilder.all.feature.group 4.5.1.v20110609-1000-8J8yCeFQvEteMB6jnqJy3X1Kg6GL)

                                                  To: com.zend.php.feature.group [8.0.1.v20101203-1424-Bb7Z98Fh1z-WD1aqSLsR8mU]

                                                Cannot satisfy dependency:

                                                  From: Eclipse IDE for Java Developers 1.3.2.20110301-1807 (epp.package.java 1.3.2.20110301-1807)

                                                  To: org.eclipse.epp.package.java.feature.feature.group [1.3.2.20110301-1807]

                                                Cannot satisfy dependency:

                                                  From: Eclipse IDE for Java Developers 1.3.2.20110301-1807 (epp.package.java 1.3.2.20110301-1807)

                                                  To: org.eclipse.platform.ide 0.0.0

                                                Cannot satisfy dependency:

                                                  From: EPP Java Package 1.3.2.20110301-1807 (org.eclipse.epp.package.java.feature.feature.group 1.3.2.20110301-1807)

                                                  To: org.eclipse.platform.feature.group [3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi]

                                                Cannot satisfy dependency:

                                                  From: Equinox p2 Provisioning 2.0.1.r361_v20100903-897HFa-FX0z-z-ntoaavz0JPX628 (org.eclipse.equinox.p2.user.ui.feature.group 2.0.1.r361_v20100903-897HFa-FX0z-z-ntoaavz0JPX628)

                                                  To: org.eclipse.ecf [3.1.0.v20100906-1425]

                                                Cannot satisfy dependency:

                                                  From: Eclipse Platform 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY (org.eclipse.platform.feature.group 3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY)

                                                  To: org.eclipse.core.filesystem [1.3.0.v20100526-0737]

                                                Cannot satisfy dependency:

                                                  From: Eclipse Platform 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L (org.eclipse.platform.feature.group 3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L)

                                                  To: org.eclipse.ui.views [3.5.0.I20100527-0800]

                                                Cannot satisfy dependency:

                                                  From: Eclipse Platform 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi (org.eclipse.platform.feature.group 3.6.2.r362_v20110210-9gF78Gs1FrIGnHDHWkEcopoN8AmxeZflGDGKQi)

                                                  To: org.eclipse.ui.views [3.5.1.M20110202-0800]

                                                Cannot satisfy dependency:

                                                  From: Eclipse Platform 3.6.0.I20100608-0911 (org.eclipse.platform.ide 3.6.0.I20100608-0911)

                                                  To: org.eclipse.platform.feature.group [3.6.0.v20100602-9gF78GpqFt6trOGhL60z0oEx3fz-JKNwxPY]

                                                Cannot satisfy dependency:

                                                  From: Eclipse Platform 3.6.1.M20100909-0800 (org.eclipse.platform.ide 3.6.1.M20100909-0800)

                                                  To: org.eclipse.platform.feature.group [3.6.1.r361_v20100909-9gF78GrkFqw7GrsZnvz0JWNTeb6fue6896L]

                                                Cannot satisfy dependency:

                                                  From: Eclipse Platform 3.6.2.M20110210-1200 (org.eclipse.platform.ide 3.6.2.M20110210-1200)

                                                  To: org.eclipse.equinox.p2.user.ui.feature.group [2.0.1.r361_v20100903-897HFa-FX0z-z-ntoaavz0JPX628]

                                              • 21. Re: Flash Builder 4.5 fails to update after a clean install
                                                Rahul S. Level 1

                                                Which plugin are you trying to install before the ADT ones ? Are you sure the plug-ins are compatible with Eclipse 3.6 ? FB PHP 4.6 is based on Eclipse 3.6. This looks like a plugin related error. If you could tell me the steps you followed i would gladly help you out.

                                                 

                                                Regards,

                                                Rahul