7 Replies Latest reply on Mar 26, 2009 7:38 AM by BosDog

    FLEX and CF Debugger setup - PLEASE HELP

    BosDog Level 1
      I can't get the line debugger for CF in eclipse to work for the life of me. I've been trying this for over 8 hours now. I follow the directions on all the tutorials out there on the web and still no luck. All my CF admin settings are correct. I think it has to do w/ the debug mappings but not sure. I have a remote CF server and am running Flex Builder 3 off of my local laptop (so wouldn't that mean that the server and Eclipse are not on the same machine?) My web root is a mapped network drive to the remote CF machine (z:\websites). I can connect to the CF RDS fine... I can use the wizards fine... I can set the breakpoints on the CFC page fine... but the debugger just will not show me any variables. Please help me to understand what I am doing wrong.
        • 1. Re: FLEX and CF Debugger setup - PLEASE HELP
          John Hall Level 4
          I would be willing to help if you had CF installed on your own machine and you're using IIS on your own machine. That's how I've successfully used it before. I can't turn on debugging on our production machine so I'm afraid I might lead you down the wrong path trying to extrapolate a local installation to a remote installation. A couple of things to check. When you do a test of the RDS configuration under your preferences, I assume the test connection works fine. What happens if you go to CF Administrator and turn on the debugging server under the debugging settings then come back to Eclipse and click on the Test Debugger in the same dialog box where you tested your Test Connection?
          • 2. Re: FLEX and CF Debugger setup - PLEASE HELP
            BosDog Level 1
            hi john thanks for this. i hope you can help me. when i click on test debugger under RDS settings it reads "test debugger was successful". on my home computer i am using Apache and CF8 both installed locally and i still cannot get the CF debugger to work. in fact on my breakpoint when i select the arrow next to the debug (bug icon) --> other -->Coldfusion i set the debug home page URL to http://localhost:8500/, select the RDS server as localhost and click debug. i notice the little breakpoint on my CFC becomes a question mark and a tooltip says "this breakpoint may not be hit". I open a browser, launch the app and click around (so that the CFC will be called). no variables ever show in my debugger window. what could i be doing wrong? (i also tried localhost without the :8500 and that wont work either)
            • 3. FLEX and CF Debugger setup - PLEASE HELP
              John Hall Level 4
              I'm quite familiar with the trials you're going through. I'm glad mine is working relatively reliably now. I've never had to set a home page, to tell you the truth.

              OK, it's good that the debugger tests OK; that implies it's communicating. When you're ready to debug, you click on the dropdown arrow next to the debug icon and choose to open the dialog. You created a new CF debugger session. I didn't change anything else from the default (oh, I gave it a name so I would recognize it). Click Debug.

              Now I've had a lot more luck using the Debug perspective (as opposed to Flex Debug perspective). So if you haven't tried that, click on the open perspective icon at the upper right and choose Other and choose Debug.

              Do you now see a coldfusion localhost debugging session running in the debug panel?

              If so, you should be getting close. Now setting breakpoints can be a little tricky. Some things aren't caught. I use a lot of cftry's in my apps and it seems to be a good valid breakpoint all the time. Even the function name declaration seems to be pretty good. You can also try adding a few things that CAN be debugged by going to preferences > ColdFusion > Debug Settings.

              If you get a breakpoint without a question mark, press F11 to actually debug your Flex session in a different Flex debug session (assuming you're doing a flex app - other instructions if you're just using this to debug CF by itself).

              Any luck with any of this?
              • 4. Re: FLEX and CF Debugger setup - PLEASE HELP
                BosDog Level 1
                In the debug window I see some things running... but under the Coldfusion Template line there is no templates ever showing up. if only i could attach a screen shot to show you
                • 5. Re: FLEX and CF Debugger setup - PLEASE HELP
                  John Hall Level 4
                  Wrote you a private message. Hopefully you get it. Which raises a question OFF TOPIC. How does one enable the ability to receive private messages in the forum. I've been told I have mine turned off?

                  Thanks.
                  • 6. Re: FLEX and CF Debugger setup - PLEASE HELP
                    BosDog Level 1
                    i did get your message but you're right i cant reply. i looked under the account settings and tried all the options but i didnt see private message options either.

                    my email is bazzbos@yahoo.com
                    send me an email from your email account and i can reply with some screenshots.

                    thanks
                    • 7. Re: FLEX and CF Debugger setup - PLEASE HELP
                      BosDog Level 1
                      For anyone having difficulty setting up the debugger please follow these steps (btw all the tutorials out there are awful and leave out important steps so I thought I'd document this to help others out). Being a software application developer and not a network admin these remote paths can be rather difficult to understand.

                      1. uninstall any Flash player or plugins you have

                      2. run and install the Flash player and debugger that comes with Flex Builder (its located in the Flex installation folder, mine was under C:\Program Files\Adobe\Flex Builder 3\Player\win). You'll see 3 files, but only need to install Flash Player Active X and Plugin

                      3. Ensure you'r debugger and tester are working (CF line debugging is enabled). In Windows Preferences under Adobe --> RDS click the 2 test buttons.

                      4. Install CFEclipse (to be able to get code hints and have Eclipse color code cfm and cfc's like DreamWeaver does)

                      5. Make sure you have 2 breakpoints in the section you want the debugger to stop. I was using 1 and on an empty space and that wasn't stopping on the breakpoints. Also make sure the breakpoints are on a coldfusion command line.

                      6. If you are using localhost don't add anything to the mappings section other than http://localhost:(your port number, if you run CF admin you will see the port number in your URL). If you have a CF server remotely though this is the TOUGH part. It took me days to figure out my mappings. I'll just give you my setup and work with that to figure out you're own.

                      I mapped my remote server drive to Z:\ and my WWWroot is z:\websites so the correct Eclipse path = z:\websites.
                      The correct Coldfusion path is /websites (don't ask me why or how, but anything other than this was not working)

                      7. Run the debugger by clicking the right arrow next to the debug icon, select Other and select CF(launch a new config is you dont have one already). When you set it up and press "Debug"... press F11 to run a browsing session. Navigate to the page you set breakpoints for and the debugger should work!

                      I hope this helps and saves others the agony of playing around with mappings.