15 Replies Latest reply on Jun 5, 2012 12:27 AM by moszapy1

    Can anyone help me silent installation of Adobe Robohelp 9?

    alexander447

      I want to deploy Adobe Robohelp 9 across my organization. So, i want to deploy it silently. Please can anyone help me with the silent switches or the procedure to install Adobe Robohelp 9 silently. In adobe site Adobe Robohelp 8 silent install document is available, but it is not working for Adobe Robohelp 9. 

        • 1. Re: Can anyone help me silent installation of Adobe Robohelp 9?
          moszapy1 Level 1

          Hi Alexander,

           

          Please follow the steps below to silently install RoboHelp 9:

           

          I) Copy the set up from installation media to your local drive.

           

          II) Create the application.xml.override file.This file(application.xml.ov) is required for serialization during installation, registration suppression, End User LicenseAgreement   (EULA) suppression, and update suppression.To create this override file follow steps mention below

           
          1. Open Notepad.
          2. Copy the following text into the application:
            <?xml version="1.0" encoding="utf-8"?> <Configuration><Payload adobeCode="{Product_Code}"> <Data key="Serial" protected="0">12341234123412341234</Data> <Data key="Registration">Suppress</Data><Data key="Updates">Suppress</Data><Data key="EULADelay">-1</Data> </Payload> </Configuration>
          3. Replace Product_Code with your product's code:

                    a) Navigate to <Installation source folder>\payloads.

                    b) Open setup.xml in Notepad.

                    c) Locate the <mediaSignature> tag.

                    d) Copy the alphanumeric product code between <mediaSignature> and </mediaSignature>.

                    e) Paste the copied code into the {Product_Code} value in the application.xml.override file.
                       Example: <Configuration><Payload adobeCode="{DE60F0DE-469A-42DC-A678-978313210057}">.

             4) Replace 123412341234123412341234 with your serial number.
                     Important: Omit hyphens. Delete <Data key="Registration">Suppress</Data> to have the registration prompt appear. Delete <Datakey="Updates">Suppress</Data> to have the Adobe Application Manager check for updates.

           

             5) Save the file as application.xml.override in the deployment folder.
                  Important: Make sure that application.xml.override does not have any additional extensions, such as .txt.

           

           

          III) Open command promt in Admin mode. Type the following command to silently install the product.

              Set-up.exe --mode=silent --deploymentFile=<path to Deployment.install.xml> --acton=install --overrideFile="<Deployment files source path>\application.xml.override" .

           

          Note:- 1) Depolyment file can be found in the deploy folder of the set up. There will be locale specific deployment file. Use one which pertains to your need.

                    2) You may get error code 6 after completing the set up. However, product may work fine.

          • 2. Re: Can anyone help me silent installation of Adobe Robohelp 9?
            alexander447 Level 1

            Thanks for the help..... I'll work on this and I'll let u know....... hope this works.....

            • 3. Re: Can anyone help me silent installation of Adobe Robohelp 9?
              alexander447 Level 1

              Thankzzzz A looootttt..... Its Workin ..... I got exit code 0.......

              Thankxxxxxx

              • 4. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                moszapy1 Level 1

                Great....nice to hear...just to mention...one can find the information related to silent install of TSC 3/RH 9/FM 10 at following link:

                http://kb2.adobe.com/cps/906/cpsid_90658.html

                • 5. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                  Captiv8r Adobe Community Professional & MVP

                  Hello

                   

                  Years ago I worked in a large call center. I used RoboHelp to develop what was used by the Call Center staff. The folks that ran the call center were about to add ten new call center employees. They were ordering new workstatiions and software to accommodate the new employees. At one point someone approached me to ask if I could negotiate a discount on RoboHelp for mass purchases. When I questioned why, they advised that they were about to order ten new copies of RoboHelp because they misunderstood and thought each user of what I created needed their own copy of RoboHelp in order to use it.

                   

                  I mention this because you said:

                   

                  I want to deploy Adobe Robohelp 9 across my organization.

                   

                  So either you have gobs of folks using RoboHelp to create content in your organization, or you may be misunderstanding things and thinking that all users of RoboHelp created content actually need RoboHelp in order to view and use the content created. And if that's what you are thinking, you are mistaken and there is no need to install RoboHelp all over your organization.

                   

                  Cheers... Rick

                   

                  Helpful and Handy Links

                  RoboHelp Wish Form/Bug Reporting Form

                  Begin learning RoboHelp HTML 7, 8 or 9 within the day!

                  Adobe Certified RoboHelp HTML Training

                  SorcerStone Blog

                  RoboHelp eBooks

                  • 6. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                    Kadiem4100

                    This does not work for me, as I expected. I am on Windows 7 enterprise 64 bit.

                     

                    I get :

                     

                    UI mode : Silent.
                    Some error occurred during installation. Installation cannot continue.
                    Exiting Installer with Code: 19

                     

                    This is the log from PDApp.txt in %appdata%\local\temp:

                     

                    5/31/2012 17:23:28 [INFO] Setup - Build Version - 2.2.41.0
                    5/31/2012 17:23:28 [INFO] Setup - Logging Level verbosity Set  to 4
                    5/31/2012 17:23:28 [INFO] Setup - Start Adobe Setup
                    5/31/2012 17:23:28 [INFO] Setup - TimeLog: Bootstrapper Start
                    5/31/2012 17:23:28 [INFO] Setup - TimeLog: Start initial checks
                    5/31/2012 17:23:28 [ERROR] Setup - Error parsing command line arguments at - "--acton=install".
                    Expected arguments are -
                    --mode=silent
                    --overrideFile="<FilePath>"
                    5/31/2012 17:23:29 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\resources\setup.xml
                    5/31/2012 17:23:29 [INFO] PIM - XML is valid
                    5/31/2012 17:23:29 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:29 [INFO] Setup - Found 3 packages in setup manifest
                    5/31/2012 17:23:29 [INFO] Utilities - Semaphore is not locked
                    5/31/2012 17:23:29 [INFO] PIM - Build Version - 2.2.41.0
                    5/31/2012 17:23:29 [INFO] PIM - Logging Level verbosity Set  to 4
                    5/31/2012 17:23:29 [INFO] Utilities - File does not exist

                    5/31/2012 17:23:29 [INFO] PIM - Build Version - 2.2.41.0
                    5/31/2012 17:23:29 [INFO] PIM - Logging Level verbosity Set  to 4
                    5/31/2012 17:23:29 [INFO] PIM - CREATE PIM Instance ...
                    5/31/2012 17:23:29 [INFO] Utilities - File does not exist

                    5/31/2012 17:23:29 [INFO] PIM - trying to createOrUpdatePIMDbSchema.
                    5/31/2012 17:23:29 [INFO] PIM - Current db schema version on machine 1.
                    5/31/2012 17:23:29 [INFO] PIM - Current db schema version to install 1.
                    5/31/2012 17:23:29 [INFO] PIM - PIM DB Schema is up to date. Current schema version is 1.
                    5/31/2012 17:23:29 [INFO] PIM - PIM Database is Up To Date.
                    5/31/2012 17:23:29 [INFO] PIM - Updater Inventory location:C:\RoboHelp9\resources\updaterinventory.dll
                    5/31/2012 17:23:29 [INFO] PIM - Acquired System level ACF lock ...
                    5/31/2012 17:23:29 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\packages\core\PDApp.pimx
                    5/31/2012 17:23:29 [INFO] PIM - XML is valid
                    5/31/2012 17:23:29 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:29 [INFO] PIM - Package id 46DB720D-70A9-49B8-8904-875CF6D9827A is already installed
                    5/31/2012 17:23:29 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\packages\UWA\UWA.pimx
                    5/31/2012 17:23:29 [INFO] PIM - XML is valid
                    5/31/2012 17:23:29 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:29 [INFO] PIM - Package id 4B1B5F88-7767-4A42-AE69-10945059D31C is already installed
                    5/31/2012 17:23:29 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\packages\DWA\DWA.pimx
                    5/31/2012 17:23:29 [INFO] PIM - XML is valid
                    5/31/2012 17:23:29 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:29 [INFO] PIM - Package id F3809CA1-F2E8-4E68-819A-AF1079AA9735 is already installed
                    5/31/2012 17:23:29 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\packages\LWA\LWA.pimx
                    5/31/2012 17:23:29 [INFO] PIM - XML is valid
                    5/31/2012 17:23:29 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:29 [INFO] PIM - Package id 288AEB6F-C67B-4244-8B68-392A279BC618 is already installed
                    5/31/2012 17:23:29 [INFO] PIM - pim_haveEnoughDiskSpaceToInstallPackages reqSize ... 21989306
                    5/31/2012 17:23:29 [INFO] Setup - TimeLog: End initial checks
                    5/31/2012 17:23:29 [INFO] Setup - TimeLog: Begin Installing
                    5/31/2012 17:23:29 [INFO] Setup - Start Installing core package - C:\RoboHelp9\packages\core\PDApp.pimx
                    5/31/2012 17:23:29 [INFO] PIM - START installPackage at file C:\RoboHelp9\packages\core\PDApp.pimx
                    5/31/2012 17:23:29 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\packages\core\PDApp.pimx
                    5/31/2012 17:23:29 [INFO] PIM - XML is valid
                    5/31/2012 17:23:29 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:29 [INFO] PIM - Package id 46DB720D-70A9-49B8-8904-875CF6D9827A is already installed
                    5/31/2012 17:23:29 [INFO] PIM - SUCCESS deleteAppletRegInfoRecords.
                    5/31/2012 17:23:29 [INFO] PIM - SUCCESS deletePackageUpgradeInfoRecords.
                    5/31/2012 17:23:29 [INFO] PIM - SUCCESS deletePackageInstallationInfoRecords.
                    5/31/2012 17:23:29 [INFO] PIM - SUCCESS insertPackageUpdateList.
                    5/31/2012 17:23:29 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:29 [INFO] PIM - SUCCESS insertAppletRegInfoList.
                    5/31/2012 17:23:29 [INFO] PIM - Backup Folder Created
                    5/31/2012 17:23:34 [INFO] Utilities - File does not exist

                    5/31/2012 17:23:35 [INFO] PIM - SUCCESS installPackage at file C:\RoboHelp9\packages\core\PDApp.pimx.
                    5/31/2012 17:23:35 [INFO] Setup - Finished Installing core package - C:\RoboHelp9\packages\core\PDApp.pimx, Return status: 0
                    5/31/2012 17:23:35 [INFO] Setup - Start Installing package - C:\RoboHelp9\packages\UWA\UWA.pimx
                    5/31/2012 17:23:35 [INFO] PIM - START installPackage at file C:\RoboHelp9\packages\UWA\UWA.pimx
                    5/31/2012 17:23:35 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\packages\UWA\UWA.pimx
                    5/31/2012 17:23:35 [INFO] PIM - XML is valid
                    5/31/2012 17:23:35 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:35 [INFO] PIM - Package id 4B1B5F88-7767-4A42-AE69-10945059D31C is already installed
                    5/31/2012 17:23:35 [INFO] PIM - SUCCESS deleteAppletRegInfoRecords.
                    5/31/2012 17:23:35 [INFO] PIM - SUCCESS deletePackageUpgradeInfoRecords.
                    5/31/2012 17:23:35 [INFO] PIM - SUCCESS deletePackageInstallationInfoRecords.
                    5/31/2012 17:23:35 [INFO] PIM - SUCCESS insertPackageUpdateList.
                    5/31/2012 17:23:35 [INFO] PIM - SUCCESS insertAppletRegInfoList.
                    5/31/2012 17:23:35 [INFO] PIM - Backup Folder Created
                    5/31/2012 17:23:39 [INFO] Utilities - File does not exist

                    5/31/2012 17:23:40 [INFO] PIM - SUCCESS installPackage at file C:\RoboHelp9\packages\UWA\UWA.pimx.
                    5/31/2012 17:23:40 [INFO] Setup - Finished Installing package - C:\RoboHelp9\packages\UWA\UWA.pimx
                    5/31/2012 17:23:40 [INFO] Setup - Start Installing package - C:\RoboHelp9\packages\DWA\DWA.pimx
                    5/31/2012 17:23:40 [INFO] PIM - START installPackage at file C:\RoboHelp9\packages\DWA\DWA.pimx
                    5/31/2012 17:23:40 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\packages\DWA\DWA.pimx
                    5/31/2012 17:23:40 [INFO] PIM - XML is valid
                    5/31/2012 17:23:40 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:40 [INFO] PIM - Package id F3809CA1-F2E8-4E68-819A-AF1079AA9735 is already installed
                    5/31/2012 17:23:40 [INFO] PIM - SUCCESS deleteAppletRegInfoRecords.
                    5/31/2012 17:23:40 [INFO] PIM - SUCCESS deletePackageUpgradeInfoRecords.
                    5/31/2012 17:23:40 [INFO] PIM - SUCCESS deletePackageInstallationInfoRecords.
                    5/31/2012 17:23:40 [INFO] PIM - SUCCESS insertPackageUpdateList.
                    5/31/2012 17:23:40 [INFO] PIM - SUCCESS insertAppletRegInfoList.
                    5/31/2012 17:23:40 [INFO] PIM - Backup Folder Created
                    5/31/2012 17:23:44 [INFO] Utilities - File does not exist

                    5/31/2012 17:23:45 [INFO] PIM - SUCCESS installPackage at file C:\RoboHelp9\packages\DWA\DWA.pimx.
                    5/31/2012 17:23:45 [INFO] Setup - Finished Installing package - C:\RoboHelp9\packages\DWA\DWA.pimx
                    5/31/2012 17:23:45 [INFO] Setup - Start Installing package - C:\RoboHelp9\packages\LWA\LWA.pimx
                    5/31/2012 17:23:45 [INFO] PIM - START installPackage at file C:\RoboHelp9\packages\LWA\LWA.pimx
                    5/31/2012 17:23:45 [INFO] PIM - Trying to access xml at path:C:\RoboHelp9\packages\LWA\LWA.pimx
                    5/31/2012 17:23:45 [INFO] PIM - XML is valid
                    5/31/2012 17:23:45 [WARN] PIM - Failed to find Node
                    5/31/2012 17:23:45 [INFO] PIM - Package id 288AEB6F-C67B-4244-8B68-392A279BC618 is already installed
                    5/31/2012 17:23:45 [INFO] PIM - SUCCESS deleteAppletRegInfoRecords.
                    5/31/2012 17:23:45 [INFO] PIM - SUCCESS deletePackageUpgradeInfoRecords.
                    5/31/2012 17:23:45 [INFO] PIM - SUCCESS deletePackageInstallationInfoRecords.
                    5/31/2012 17:23:45 [INFO] PIM - SUCCESS insertPackageUpdateList.
                    5/31/2012 17:23:45 [INFO] PIM - SUCCESS insertAppletRegInfoList.
                    5/31/2012 17:23:45 [INFO] PIM - Backup Folder Created
                    5/31/2012 17:23:58 [INFO] Utilities - File does not exist

                    5/31/2012 17:23:59 [INFO] PIM - SUCCESS installPackage at file C:\RoboHelp9\packages\LWA\LWA.pimx.
                    5/31/2012 17:23:59 [INFO] Setup - Finished Installing package - C:\RoboHelp9\packages\LWA\LWA.pimx
                    5/31/2012 17:23:59 [INFO] PIM - Processing ... _pimCreateOrUpdateAAMInventory
                    5/31/2012 17:23:59 [INFO] PIM - Inventory Already present on the machine...
                    5/31/2012 17:23:59 [INFO] Setup - TimeLog: End Installing. Now launching PDApp
                    5/31/2012 17:24:00 [WARN] Setup - Install Source Path not specified. Searching for payloads at the launch path.
                    5/31/2012 17:24:00 [INFO] Setup - Deployment Engine launched with command : "C:\Program Files (x86)\Common Files\Adobe\OOBE\PDApp\DWA\Setup.exe" --deploymentFile="C:\RoboHelp9\deploy\AdobeRobohelp9.0.1en_US.install.xml" --overrideFile="C:\RoboHelp9\application.xml.override" --installSourcePath="C:\RoboHelp9"
                    5/31/2012 17:24:04 [FATAL] Setup - End Adobe Setup. Exit code: 19
                    5/31/2012 17:24:04 [INFO] PIM - PIMSqlite closeDB status 0
                    5/31/2012 17:24:04 [INFO] PIM - FREE PIM Instance ...

                    • 7. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                      Kadiem4100 Level 1

                      Also if I just run the command instead:

                      Set-up.exe --mode=silent --overrideFile="C:\RoboHelp9\application.xml.override"

                      then I get:

                      C:\RoboHelp9>Starting installer...
                      UI mode : Silent.
                      Installation successful.
                      Exiting Installer with Code: 0

                       

                      But there is no sign that Robohelp is installed anywhere on my computer.

                       

                      I did that because in the log file it said:

                      5/31/2012 17:23:28 [ERROR] Setup - Error parsing command line arguments at - "--acton=install".
                      Expected arguments are -
                      --mode=silent
                      --overrideFile="<FilePath>"

                      • 8. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                        Jeff_Coatsworth Adobe Community Professional & MVP

                        Give Adobe Support a call - installation calls are usually free.

                        • 9. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                          Kadiem4100 Level 1

                          Ok I'll give a call tomorow at 800-833-6687 in case I get any solutions posted here.

                          • 10. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                            Peter Grainge Adobe Community Professional

                            Not sure if you have seen this page. It is for RoboHelp 8 but I don't think the process changed in 9.

                             

                            http://helpx.adobe.com/robohelp/kb/silent-installation-robohelp-8.html

                             


                            See www.grainge.org for RoboHelp and Authoring tips

                             

                            @petergrainge

                            • 11. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                              Kadiem4100 Level 1

                              Peter, thanks for reply, but the 8 silent install instructions don't appear to work for 9. It just launches the full GUI installer.

                               

                              I wonder why there was such a drastic, complicated change from version 8 to 9 for silent/auto deployment? That seems to be the case with every vendor now days. It really is a shame.

                              • 12. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                                moszapy1 Level 1

                                Exit code 19 means you have a conflicting process running on your system. That's why RoboHelp installer is giving fatal error. Please close all conflicting process and try installing again. If you are not sure which process to stop just restart your system and install RoboHelp.

                                • 13. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                                  Kadiem4100 Level 1

                                  I did read that regarding exit code 19 but the description of that was for another Adobe product.

                                   

                                  I'm curious as to why there'd be a conflicting process when attempting to install silently, but I have no issue installing via the GUI.

                                   

                                  And I have already rebooted and tried in another PC (vm) that has nothing but Windows on it.

                                   

                                  I'm also curious if the gentlemen in this thread who installed it with an error code 0 actually got the application installed to the hard drive. I can change up the command and get an exit code 0 after 5 mins, but it's never installed to the disk.

                                  • 14. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                                    Peter Grainge Adobe Community Professional

                                    Maybe this link that I have been sent will help.

                                     

                                    http://kb2.adobe.com/cps/906/cpsid_90658.html

                                     


                                    See www.grainge.org for RoboHelp and Authoring tips

                                     

                                    @petergrainge

                                    • 15. Re: Can anyone help me silent installation of Adobe Robohelp 9?
                                      moszapy1 Level 1

                                      Hi Kadiem4100,

                                       

                                      Can you please share the log of RoboHelp 9 present at "C:\Program Files (x86)\Common Files\Adobe\Installers". Please send it to mdsameer87@gmail.com.