0 Replies Latest reply on Jun 14, 2011 8:26 PM by septicman_NZ

    Flash CS4 on MacOS 10.6.7 crashing when 'test movie' used

    septicman_NZ

      Hi all,

       

      I have a MacBook Pro running Mac OS 10.6.7.  I am using Flash CS4 10.0.2.

       

      I recently upgraded computers from another MacBook Pro, and installed the same version of CS4 on this new one.

       

      However, given this new computer has lots more RAM and more grunt and is by far less 'clogged up' than my old one (which was about three years old) it crashes all the time when I press CMD-ENTER to test my movies in Flash.

       

      These are FLA's I've worked on for months on my other computer.  When I open the SWFs in Flash Player (i.e. outside the authoring environment) I do not get any crashes.

       

      I have noticed the CPU rockets upwards to 100% just before the crash (and hovers around 80% even when nothing is moving on the screen etc).  It doesn't do this in the Flash Player.

       

      I have scoured the web and can't seem to find what the problem might be.  They're known good FLAs (i.e. they worked on my other computer in the same version of Flash) and this computer should definitely be able to cope with them, given the old one did.  What might be the cause?

       

      Here's an example of the error report that Mac OS throws up after the crash:

       

      Process:         Adobe Flash CS4 [43416]
      Path:            /Applications/Adobe Flash CS4/Adobe Flash CS4.app/Contents/MacOS/Adobe Flash CS4
      Identifier:      com.adobe.flash-10.0
      Version:         10.0.2.566 (10.0.2)
      Code Type:       X86 (Native)
      Parent Process:  launchd [146]

       

      Date/Time:       2011-06-15 15:14:43.937 +1200
      OS Version:      Mac OS X 10.6.7 (10J4138)
      Report Version:  6
      Sleep/Wake UUID: 85F82BE0-C1EA-43C7-9A7C-77DA38363765

       

      Interval Since Last Report:          177155 sec
      Crashes Since Last Report:           10
      Per-App Interval Since Last Report:  89418 sec
      Per-App Crashes Since Last Report:   10
      Anonymous UUID:                      C8B710B0-DB36-428D-834D-975007911DCD

       

      Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
      Exception Codes: KERN_INVALID_ADDRESS at 0x00000000ff1c9680
      Crashed Thread:  41

       

      There's more info in the report but I imagine this is the significant bit.

       

      If anyone at all can suggest an answer to this problem that fixes it or contributes directly to a fix, I'll send you a thank-you gift of some description regardless of wherever in the world you might be.  I'm losing hours and hours of productivity on this.

       

      Many thanks!

       

      G