10 Replies Latest reply on Jun 15, 2011 9:49 AM by Karen@Work

    Text flow stops midway

    Karen@Work

      I work for a map company and am doing a layout with maps and the street indexes that go with them. When I get a really lengthy text file like Vancouver which has 6500 paragraphs of text (eg. George St. C-15 is an example of what each paragraph is like) the text doesn't flow properly. It will stop right in the middle of a text frame and sometimes even continue in later with a big gap in between. For most of our map layouts the indexes aren't a problem but for cities like Vancouver I have to resort to laying out the index in Quark (yuk!) and importing that image into the indesign layout.

       

      Here are the steps: I import a text file into Indesign text frames that have multiple columns and when the index, which is alphabetical, gets to about the letter J, it just stops...no more text. As I said above, sometimes it will even start back midway through a column. There is nothing wrong with the structure (eg. no text wraps, paragraph spacing, etc) and we've had numerous people here checking to look for some error we've made. Sometimes it will work if I take a text box that was 6 columns and break it into two - 3 column text boxes. There definitely seems to be an issue with the number of lines of text. This only happens with the very large indexes. Is there a limitation on line count in Indesign? Is this where Framemaker is needed? Is there any way around this? I really, really don't want to use Quark.

       

      Karen

        • 1. Re: Text flow stops midway
          Peter Spier Most Valuable Participant (Moderator)

          I suspect it is not related to the number of lines, but the widths of the columns, and your hyphenation settings. If a line is too long to fit into the width of the column, and you've told ID not to break the line in some fashion, typically by applying No Break or using a combination of non-breaking spaces and not allowing hyphenation, ID has no choice but to stop the flow in the frame at that point and go into overset.

          • 2. Re: Text flow stops midway
            Karen@Work Level 1

            Hyphenation is allowed. No non-breaking spaces. The text frame also doesn't show as overset text (the little red + sign doesn't appear). The text will often reflow later in that same text frame or will skip the remaining of that text frame and go into the next one. Also, if I were to break down the text file that is being imported and only import say from A-L the text would flow properly but as soon as I add in the extra lines it will now break at J and doesn't even make it to L.

            • 3. Re: Text flow stops midway
              Peter Spier Most Valuable Participant (Moderator)

              Can you post a screen grab of one of these frames where you see the problem? Turn on non-printing characters, first.

               

              You can embed the image in a post by using the camera icon on the web page:

               

              CameraIcon.png

              • 4. Re: Text flow stops midway
                Karen@Work Level 1

                Entire-Index.jpg

                Top-Text-Box.jpg

                I have vertical justification turned on in the columns but even when it's turned off it still stops midway.

                • 5. Re: Text flow stops midway
                  Peter Spier Most Valuable Participant (Moderator)

                  What does it show in Story editor? Highlight the last line that shows,  then press Cmd (Ctrl on Windows) + Y to view in Story editor.

                   

                  And the overset indicator is there, in the last frame in the chain...

                  • 6. Re: Text flow stops midway
                    Karen@Work Level 1

                    Last-Line-Story-Editor.jpg

                    The last line that shows is highlighted as Innes Rd.

                    • 7. Re: Text flow stops midway
                      Peter Spier Most Valuable Participant (Moderator)

                      That long string of numbers separated by commas and no spaces is the problem. It can't break because ID thinks it's a single number and it's too wide for the column.

                       

                      Since there are presumably no real numbers in the story with actual comma separators that you need to keep from breaking, it would probably be safe to just add a discretionary line break to any place where you have a digit followed by a comma and a digit.

                       

                      Do a GREP find change. Search for (\d,)(\d) and change to $1~k$2

                       

                      This translates to find (any digit and a comma)(any digit) [the parentheses are there to group the found text into chunks] and replace with first chunk of found text - discretionary line break - second chunk of found text.

                      1 person found this helpful
                      • 8. Re: Text flow stops midway
                        Karen@Work Level 1

                        Ok. I'll give it a shot. For shorter indexes this isn't a problem though. The line will wrap onto the next line and then we go in and manually break the line where fits and looks best. Thanks.

                        • 9. Re: Text flow stops midway
                          Peter Spier Most Valuable Participant (Moderator)

                          My guess would be that your shorter indexes use wider columns or you just haven't encountered a string of numbers long enough to go into overset. You could insert a soft line break manually in story editor, too, if you want to control absolutely where the line breaks. The GREP just put in a break between every comma and a following digit so the line can break between any two numbers, not necessarily the one you want to use.

                          • 10. Re: Text flow stops midway
                            Karen@Work Level 1

                            I didn't do the GREP, I just entered a soft return in 2 spots and the rest of the index flowed through, even the lines that were long! Thanks so much. I tried entering the soft returns before and it didn't work, but for whatever reason when I do it in the story editor it works. FYI, the other indexes where I didn't have a problem, also have long paragraphs(that don't fit the width of the column) and often even narrower columns than the one you saw today, but not as many paragraphs. Indesign handles those situations perfectly and just rolls the remaining text beneath the paragraph but once we get into the 1000's of paragraphs we have problems. Doing the soft returns in story editor solved the problem though. Thanks again!