6 Replies Latest reply on Jun 17, 2011 1:08 PM by dixon10

    Proxy Error in CS5.5

    dixon10

      Hey

      Not sure if anyone else has come across this. When I set a proxy for a comp, I get an error which says, "After Effects error: zero denominator in ratio multiply. ( 17 :: 17 )". I've looked up the error code in Mylenium's database, but to no avail.

       

      The error only occurs when the proxy-enabled comp is being viewed in the comp window. If I'm viewing a parent comp (one that uses the proxy-enabled comp as a layer), everything works fine. This behavior only started when I switched to CS5.5.

       

      Also, I use tif sequences for the proxies, and the error occurs whether I use a still or a sequence.

       

      Any ideas?

       

      (I'm on Windows 7 64-bit, if that's relevant.)

        • 1. Re: Proxy Error in CS5.5
          Mylenium Most Valuable Participant

          Should be a similar cause as in the other 17 :: xx numbers (http://aeerrors.myleniumstuff.de/?p=138). From your description I would suspect that there could be an issue with continuous rasterization or that the proxy does not go down well with a distortion effect. Anything along those lines going on there? Also, does it still occur when you switch the project bit depth? If there are 32bpc effects involved that work differently between modes, this might also throw off other effects further down the chain who cannot deal with this scenario. Specific to CS5.5 I could imagine the new caching mechanism not invalidating cahed frames properly, so I would try a manual purge after assigning teh proxy to enforce new caching...

           

          Mylenium

          • 2. Re: Proxy Error in CS5.5
            dixon10 Level 1

            Thanks for the reply. I tried your suggestions and the problem still occurs. It doesn't matter what the bit depth is, and clearing the cache doesn't help. If I enable the proxy with caps lock on to prevent rendering it still happens.

             

            I've also tried messing with the frame rates: the comp should be set to 29.97df and the proxy is the same, but I've tried every combination of 30fps, 29.97df and ndf. None of it makes a difference.

             

            I'm not using any distortion effects or continuous rasterization. Again, the problem only occurs when viewing the comp with the proxy, not any of the parent comps.

             

            Thanks again. Let me know if I can provide any other information.

            • 3. Re: Proxy Error in CS5.5
              Mylenium Most Valuable Participant

              Mmh, if it's not too much trouble, you could send a project to my personal mail and I'll have a look. These things have a way of often hinging on some minor switch or setting somewhere and it might just be easier to see it hands on rather than trying to describe on a forum...

               

              Mylenium

              • 4. Re: Proxy Error in CS5.5
                dixon10 Level 1

                @Mylenium: sent you a pm.

                 

                In general: I've done some more testing. The problem occurs even in a brand new project. Also tried using a quicktime .mov instead of an image sequence, but no change. Tried different resolutions: nothing. So far every proxy (or old project with a proxy in it) I've used since upgrading to CS5.5 has thrown this error.

                 

                Also interesting, the error does not occur just after rendering is finished, while I'm still in the render queue panel and the proxy is visible in the comp window. It only occurs once I click over to the newly proxy-enabled comp in the timeline panel.

                 

                I'd like to know if anyone else can repeat this. If you haven't tried setting a proxy for a comp in CS5.5, could someone try a quick test (new comp, new solid, add turbulent noise with animated evolution, then right click on the comp in the project panel and select Create Proxy>Movie and render) and post your results here? As mentioned above, I get the error as soon as I go back to the comp in the timeline panel.

                 

                Thanks again.

                Dixon

                 

                UPDATE: Mylenium confirms the same issue on his system and filed a bug report. Hope it gets fixed soon!

                • 5. Re: Proxy Error in CS5.5
                  ky_ae Adobe Employee

                  Do you set "Show Layer Cache Indicator" ON?

                  If so, please try to turn it OFF.

                   

                  To make it off,

                  1) Composition > New Composition

                  2) In Timeline, click flyout menu (right-top corner of Timeline panel)

                  3) Uncheck "Show Layer Cache Indicator"

                   

                  Hope this helps.

                   

                  Thanks.

                   

                  -keiko

                  • 6. Re: Proxy Error in CS5.5
                    dixon10 Level 1

                    Fascinating! That took care of it, Keiko. Thanks for the suggestion.

                     

                    I don't suppose it's crucial to have the layer cache indicators enabled, although I like being able to keep track of what's going on behind the scenes. It would be nice to be able to use proxies and see the layer cache at the same time.

                     

                    Dixon