5 Replies Latest reply on Sep 6, 2011 3:20 AM by Saqib.lodhi

    Coldfusion Builder 2 Debugger Error

    Saqib.lodhi

      Hi everyone,

       

      I am using CF9 as remote server for development. We have decided to move on CFBuilder to use its debugger feature.

       

      I am getting an error while testing Coldfusion Builder 2 Debugger.

       

      I have googled for this error but didn't find any related post.

       

      Below is the snapshot with error.

       

      cfusion_builder_error.png

        • 1. Re: Coldfusion Builder 2 Debugger Error
          Saqib.lodhi Level 1

          is someone there????

          • 2. Re: Coldfusion Builder 2 Debugger Error
            Big Mad Kev Level 1

            When you say remote, do you mean shared hosting?

             

            The erro is due to the CF Line Debugger not enabled in the CF Admin.

             

            If your using shared hosting, I'd suggest you'd need to setup CF9 locally and connect that way.

            • 3. Re: Coldfusion Builder 2 Debugger Error
              Saqib.lodhi Level 1

              CF Line Debugger is enabled. every thing is configured perfectly. This is a error which I've never seen before.

               

              Actually, I am a IT Manager in a Software company and we need to setup a remote CF9 Server for development and testing with debugging. This is a centralize server for my team to work and test. Currently we are working using dreamviewer and every thing is going fine with this tool but as you know there is no good debugger tool in DW so we have decided to work in CFBuilder 2. Below you will find the jvm config in my CF Server.

               

              ========================================================================================== =======================

              -Xdebug -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005 -server -Dsun.io.useCanonCaches=false -XX:MaxPermSize=192m -XX:+UseParallelGC -Xbatch -Dcoldfusion.rootDir={application.home}/../ -Dcoldfusion.libPath={application.home}/../lib -Duser.language=en -Duser.country=US -Dfile.encoding=UTF-8 -DDEBUGGER_SERVER_PORT=5005 -DDEBUGGER_TRACE=true

              ========================================================================================== =======================

              • 4. Re: Coldfusion Builder 2 Debugger Error
                Big Mad Kev Level 1

                One thing to look at I guess is the neo*.xml files on the server, some one spotted before a similar sort of error and it was down to one of these files being courrpt or empty.

                 

                On CF Server installed as a Server Instance these files are

                 

                C:\JRun4\servers\cfusion\cfusion-ear\cfusion-war\WEB-INF\cfusion\lib

                 

                can't remember where they are for standard, but would be very similiar location.

                 

                I guess with the issue pointing at logs start with neo-logging.xml then neo-debug.xml then the rest. That's the best I can suggest.

                • 5. Re: Coldfusion Builder 2 Debugger Error
                  Saqib.lodhi Level 1

                  This issue has been resolved. Port Number must be your HTTP port like "80".

                   

                   

                  Thanks for Help.