8 Replies Latest reply on Sep 30, 2011 2:53 PM by kremisoski

    org.osmf.media::MediaPlayer could not be found


      Hi all,

      I'm using Win 7, Flash Builder 4 with Flex 4.5 SDK (manually upgraded).

      I'm creating a video viewer, which streams from a Flash Media Server. Sometimes, when you reload the app, the video is not showed: audio is fine, duration, seek, everything. It's random, no error... MediaPlayerState is normal, Buffering + Playing.

      I'm using the default VideoDisplay component.


      So my conclusion was to upgrade the OSMF library to the latest one.


      I downloaded the 1.6 (tried also with the 1.5) from the website, put the OSMF.swc in my project/libs and removed the default osmf.swc from the build path. No compile error. Moreover, I have forced to use Flash Player 10.2 in the Compiler section of the project.

      When I run, I have this exception, and the application doesn't work.

      Error #1014: Class org.osmf.media::MediaPlayer could not be found.


      But the OSMF.swc is there and also looking in org.osmf.media I can see the MediaPlayer class.

      I guess it is because VideoDisplay is using something removed in the new library, could be this the problem?


      I would like to resolve this problem, that sometimes the video is not showed, using the VideoDisplay component.

      Any idea? Something wrong in my steps?


      Thank you