4 Replies Latest reply on Jun 20, 2011 10:19 PM by Sukhi12

    Flash CS4 file won't open in CS5

    tomhofann2

      I have tried Adobe support with this but their response was as helpful as a hole in the head. I am hoping someone here might be able to help or seen this problem before.

       

      I have a fla file which opens, save and compiles perfectly in Flash CS4 but when I open it in CS5 it crashes Flash with the below error report. I have tried this on multiple machines all resulting in the same error message.

       

      I have also tried saving the file in CS4 under a new name, did a compact and save and a magic spell. Neither of which had any effect.

       

      Any help or pointers would be appreciated.

       

      Tom

       

      PS: If anyone from Adobe is reading this... given you are charging a premium for Master Collection here in Australia I would have expected a little bit of help when your software doesn't work as expected. I am sorry, but that's just not good customer service.

       

       

      Here the first part of the error report if it helps:

       

      Process:         Adobe Flash CS5 [89706]

      Path:            /Applications/Adobe Flash CS5/Adobe Flash CS5.app/Contents/MacOS/Adobe Flash CS5

      Identifier:      com.adobe.flash

      Version:         11.0.2.489 (11.0.2)

      Code Type:       X86 (Native)

      Parent Process:  launchd [176]


      Date/Time:       2011-06-19 12:22:47.453 +1000

      OS Version:      Mac OS X 10.6.7 (10J869)

      Report Version:  6


      Interval Since Last Report:          232933 sec

      Crashes Since Last Report:           1

      Per-App Interval Since Last Report:  23 sec

      Per-App Crashes Since Last Report:   1

      Anonymous UUID:                     


      Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

      Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bf800fe4

      Crashed Thread:  0  Dispatch queue: com.apple.main-thread


      Application Specific Information:


      Java information:

      Exception type: Bus Error (0xa) at pc=00000000008c87c0

       

      Java VM: Java HotSpot(TM) Client VM (19.1-b02-334 mixed mode macosx-x86)

       

      Current thread (000000003a801000):  JavaThread "main" [_thread_in_native, id=-1598790336, stack(00000000bf800000,00000000c0000000)]

      Stack: [00000000bf800000,00000000c0000000]

       

      Java Threads: ( => current thread )

        000000003107c000 JavaThread "Code Model Worker" daemon [_thread_blocked, id=-1310355456, stack(00000000b1d59000,00000000b1e59000)]

        000000003107b800 JavaThread "Code Model Worker" daemon [_thread_blocked, id=-1311412224, stack(00000000b1c57000,00000000b1d57000)]

        000000003a8c1c00 JavaThread "FelixPackageAdmin" daemon [_thread_blocked, id=-1313034240, stack(00000000b1acb000,00000000b1bcb000)]

        00000000698c8800 JavaThread "FelixStartLevel" daemon [_thread_blocked, id=-1314091008, stack(00000000b19c9000,00000000b1ac9000)]

        0000000031072000 JavaThread "FelixDispatchQueue" [_thread_blocked, id=-1318744064, stack(00000000b1559000,00000000b1659000)]

        0000000031009000 JavaThread "Low Memory Detector" daemon [_thread_blocked, id=-1320857600, stack(00000000b1355000,00000000b1455000)]

        0000000031008000 JavaThread "CompilerThread0" daemon [_thread_blocked, id=-1321914368, stack(00000000b1253000,00000000b1353000)]

        0000000031007400 JavaThread "Signal Dispatcher" daemon [_thread_blocked, id=-1322971136, stack(00000000b1151000,00000000b1251000)]

        0000000031006400 JavaThread "Surrogate Locker Thread (CMS)" daemon [_thread_blocked, id=-1324027904, stack(00000000b104f000,00000000b114f000)]

        000000003a843000 JavaThread "Finalizer" daemon [_thread_blocked, id=-1325084672, stack(00000000b0f4d000,00000000b104d000)]

        000000003a842400 JavaThread "Reference Handler" daemon [_thread_blocked, id=-1326141440, stack(00000000b0e4b000,00000000b0f4b000)]

      =>000000003a801000 JavaThread "main" [_thread_in_native, id=-1598790336, stack(00000000bf800000,00000000c0000000)]

      Other Threads:

        000000003a83f800 VMThread [stack: 00000000b0c49000,00000000b0d49000] [id=-1328246784]

        000000003100a800 WatcherThread [stack: 00000000b1457000,00000000b1557000] [id=-1319800832]

      VM state:not at safepoint (normal execution)
      VM Mutex/Monitor currently owned by a thread: None
      Heap
      par new generation   total 14784K, used 5986K [000000005d6e0000, 000000005e6e0000, 000000005e6e0000)
        eden space 13184K,  40% used [000000005d6e0000, 000000005dc097a0, 000000005e3c0000)
        from space 1600K,  43% used [000000005e550000, 000000005e5ff208, 000000005e6e0000)
        to   space 1600K,   0% used [000000005e3c0000, 000000005e3c0000, 000000005e550000)
      concurrent mark-sweep generation total 49152K, used 0K [000000005e6e0000, 00000000616e0000, 00000000656e0000)
      concurrent-mark-sweep perm gen total 12288K, used 6656K [00000000656e0000, 00000000662e0000, 00000000696e0000)
      Virtual Machine Arguments:
      JVM Args: -Djava.awt.headless=true -Xmx128m
      Java Command: <unknown>
      Launcher Type: generic
      Physical Memory: Page Size = 4k, Total = 8192M, Free = 209M

      Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
      0   com.adobe.flash               0x008c87c0 std::map<unsigned long long, CLibraryItem*, std::less<unsigned long long>, std::allocator<std::pair<unsigned long long const, CLibraryItem*> > >::operator[](unsigned long long const&) + 18
      1   com.adobe.flash               0x008c5c9f non-virtual thunk to drover::PIPanel::GetContextMenu() + 17531
      2   com.adobe.flash               0x008c5d02 non-virtual thunk to drover::PIPanel::GetContextMenu() + 17630
      3   com.adobe.flash               0x008c5d02 non-virtual thunk to drover::PIPanel::GetContextMenu() + 17630