18 Replies Latest reply on Mar 4, 2012 11:04 AM by mpaca

    Update fails, uninstalls Adobe with an Error 1303

    Joshua1F

      I had a employee report that he couldn't open PDF files.

       

      I go to his machine, and thought thats strange Adobe Reader X isn't installed.  I re-installed and didn't think much about it.

       

      About 10 minutes later he called again and it was missing again.

       

      I delved into the issue and found that when the Updater is running, and executing because I have it set to automatically install updates, that it fails with an error:

       

      error 1303 the installer has insufficient priviledges to access this directory: c:\program files(x86)\Common Files\Adobe\ARM\1.0.  The installation cannot continue.  Log on as an administrator or contact your system administrator.

       

      I've tried taking ownership of the Adobe folder under c:\programdata\, and the one located in c:\program files(x86)\Common Files and inherited the correct permissions.

       

      I've restarted the machine and the update always uninstalls Adobe, and then fails to install the update.

       

      I was thinking it was Kaspersky that was interfering but as best I can tell I disabled the policy and each component from Kaspersky and it still fails to apply the update.

       

      Any ideas?

       

      Also the user is an Administrator Account, I double checked.

       

      Message was edited by: Joshua1F

        • 1. Re: Update fails, uninstalls Adobe with an Error 1303
          Joshua1F Level 1

          I just checked and the update works correctly on my machine, and I have Kaspersky running though the corporate policy is slightly different on my machine.

          • 2. Re: Update fails, uninstalls Adobe with an Error 1303
            LeoAdobeX Adobe Employee

            10.1 Reader will always uninstall older Reader by default.

            The issue is that new Reader cannot be installed by Windows Installer service.

             

            Try to

            1. manually uninstall existing Reader

            2. download  MSI version of 10.1 Reader from Adobe FTP (the links are posted on this forum all the time)

            3. install it

             

            If you run into the same issue again, you will need to fix permissions on this User system.

            1 person found this helpful
            • 3. Re: Update fails, uninstalls Adobe with an Error 1303
              Joshua1F Level 1

              Leo thanks for the response.

               

              1) I have uninstalled Adobe Reader manually, and the update process also uninstalls Reader when it fails.  I have noticed when re-installing that it appears to keep the registry keys regarding the automatic update so it might be worth deleting some of thoese keys in the registry.

               

              2) I actually registered for Corporate Deployment so I'm already installing using the MSI, with a customized mst I've been using.

              • 4. Re: Update fails, uninstalls Adobe with an Error 1303
                LeoAdobeX Adobe Employee

                Updater preferences are irrelevant here.

                Also, it should not matter that you customized 10.1, unless you've done something very unusual.

                 

                Windows Installer Service installs Files and Registries under System privileges.

                If it cannot access something like in your case, it means that your folders have abnormal permissions.

                Example - "allow access for User A and nobody else including System"

                • 5. Re: Update fails, uninstalls Adobe with an Error 1303
                  Joshua1F Level 1

                  I agree the preferences are irrelevant here, and the same MST configuration is working fine on most if not all other machines.

                   

                  On the employee's machine that is having the problem, I've double checked permissions on the file system.

                   

                  I even deleted the folders c:\programdata\Adobe and c:\program files (x86)\Adobe\ARM and the re-install recreated these folders.  I then set the user as an owner and deleted the old permissions and gave the user rights to those two folders.

                   

                  I'm still thinking it's Kaspersky somehow interfereing, but it bothers me that I disabled the policy for Kaspersky and it's still happening.

                  • 6. Re: Update fails, uninstalls Adobe with an Error 1303
                    LeoAdobeX Adobe Employee

                    Maybe you should not re-create those folders and set any permissions - Windows Installer will take care of it.

                    • 7. Re: Update fails, uninstalls Adobe with an Error 1303
                      Joshua1F Level 1

                      I only deleted and recreated the folders with permissions when the Windows Installer (MSIEXEC) was failing to do so.  It obviously didn't matter.

                      • 8. Re: Update fails, uninstalls Adobe with an Error 1303
                        Joshua1F Level 1

                        Any other ideas?

                         

                        Since the last post I have tried the following things:

                         

                        1) Tried to grant full admin rights to c:\program files (x86)\Adobe\ARM\1.0 folder with no luck.  I even tried the command line icacls to set permissions.

                         

                        2) After step one failed I uninstalled Adobe Reader

                         

                        3) Deleted File system locations in program files, and program data

                         

                        4) Deleted Registry Keys under HKCU, HKLM > Software > Adobe

                         

                        5) Reinstalled Adobe Reader

                         

                        6) Ran Adobe Reader and clicked Check for Updates

                         

                        7) Opened the c:\programdata\Adobe\ARM\ folder and saw the updated files download correctly.

                        ProgramData Folder Contents.png

                         

                        8) Received same error, shown below.

                        UpdaterError.png

                         

                        It seems to me that it's a problem with the Adobe Reader/ARM updater because it's recreating the ARM\1.0 folder with the incorrect permissions, which I can't fix even though I have full admit rights.

                         

                        My next step will be to see if I can get an updated MSI package and see if there is a problem somehow with the one I have

                        • 9. Re: Update fails, uninstalls Adobe with an Error 1303
                          Joshua1F Level 1

                          One last thing.  It's not just one machine now. I've noticed it on 3 of our newer machines.

                           

                          All 3 running Windows 7 64 bit.

                          • 10. Re: Update fails, uninstalls Adobe with an Error 1303
                            Joshua1F Level 1

                            Still looking for an answer.

                            • 11. Re: Update fails, uninstalls Adobe with an Error 1303
                              LeoAdobeX Adobe Employee

                              Updater does not set or reset permissions on files or folders.

                              All those permissions are inherited when Updater copies files.

                              In your sample picture there is a folder 499

                              Can you please do the following:

                              1.     Save all 4 files from this folder somewhere (if you start from the very beginning, the folder may have different name)

                              2.     Check that they all have normal permissions, valid Adobe digital signature and all are version 1.5.5.0

                              3.     Exit Updater if running and delete c:\programdata\Adobe\ARM folder

                              4.     Replace existing files in c:\program files (x86)\Adobe\ARM\1.0 folder with those new files

                              5.     Start Update again.

                              • 12. Re: Update fails, uninstalls Adobe with an Error 1303
                                Joshua1F Level 1

                                Leo thanks again for the reply.

                                 

                                I haven't gotten a chance to test your suggestion yet but wanted to follow up.

                                 

                                The laptop I had used yesterday to recreate the problem is not having the same issue today.  I just reapplied our base corporate image to it, and before I ran any updates from Windows Updates Adobe Reader asked for an update. I ran the update and it ran normally.

                                 

                                This is the same image and same laptop I used the other day but the other day I ran the Adobe Reader update after I had updated everything else on the machine.

                                 

                                I wonder what the chances are that a Windows update has broken the updater somehow?

                                 

                                The other user who had the problem was a lawyer who is out of the office today, but when I get some time I will try some further testing.

                                • 13. Re: Update fails, uninstalls Adobe with an Error 1303
                                  Preston H

                                  Had exact same problem on Win 7 x64 system.  After making many changes to permissions and ownerships, restored back to a point before these changes, turned off windows firewall, installed  windows hotfix KB947821, and then updated/installed Adobe X (10.1) and it worked. Not sure if it was the hotfix or turning off the firewall, since i did both at the same time.  Note: When installing the hotfix, it stalls at about 70%.  Actually, it is scanning your system, so let it run its course.  Good luck, and let me know if this works for you.

                                  • 14. Re: Update fails, uninstalls Adobe with an Error 1303
                                    ICSIG

                                    nvidia drivers ?!

                                     

                                    got the same problem, update from 10.0.1 to 10.1.0 with integrated updater fails, after that acrobat is gone from the computer. but i could track it down:

                                    we use images to install corporate pcs. we use dell hardware. we had e6410 laptops until dell recently changed to e6420, and we have some dell optiplex pc. we use windows 7 ultimate/pro 64 bit. the first 2 new 6420 laptops all have the adobe problem, but acrobat 10.1.0 can be installed from the complete package without errors. it does not matter if we 1) use the dell installation out of the box or b) install w7 with SP1 from DVD and add drivers manually. No changes have been made to the laptop software for this test (no domain member, no additional software) Also, the older e6410 (factory default w/o SP1) work even with SP1 installed later.

                                    Also, all brand new optiplex PC dont have the problem (out of the box with sp1).

                                    on all e6420, the adobe update starts, and stops right before the 'service is been installed' shows on other pc's, and rolls back the installation. i think the 'service' is c:\Program Files (x86)\Common Files\Adobe\ARM\1.0\armsvc.exe which is new since 10.1.0.

                                     

                                    So, maybe in the future updates from 10.1.0 to higher versions will work, but since we wanted to create an image for the new 6420 i installed windows 7 with sp1 (nothing else), and adobe COULD update !!

                                    After this, i added all drivers for the laptop, and testet after each. the strange thing is: if i install the nvidia graphics driver for the integrated nvs 4200m (downloaded package from dell R306240, 8.1712.6883 A02, which installs Nvidia version 268.68), after that the update fails. if i uninstall the driver package, re-install adobe 10.0.1, the update works again ! i tried also the newest driver from nvidia (275.33), it's the same. if the nvidia driver is installed after a plain w7 SP1 64bit installation to the dell e6420 (no windows updates), update fails. if it is removed, it works.

                                     

                                    don't know if this helps anyone, and i dont even have an idea why nvidia drivers will cause the problem, but it has been reproduced on two laptops.

                                     

                                    i will wait for the next adobe update and see if it will work. if i will encounter other problems with the new laptops, i probably will uninstall the drivers and try the integrated intel hd graphics.

                                    1 person found this helpful
                                    • 15. Re: Update fails, uninstalls Adobe with an Error 1303
                                      Joshua1F Level 1

                                      You may be on to something.

                                       

                                      We have the same corporate environment with Dell Latitude (E6x00, E6x10, E6x20, D620, D630) and Dell Optiplex 960's.  We have a mixture of Windows 7 and Windows Vista.

                                       

                                      These new 6420's and 6520's have the dual Nvidia/Intel video card setup and the Sandy Bridge.  This is where I have had the problem.

                                       

                                      The older laptops haven't exhibited this same behavior.

                                       

                                      I got sick of dealing with the issue and just installed the 10.1 version instead of trying to run an update.

                                       

                                      Heres to hoping that this latest version of Reader, won't have the same issue updating.

                                       

                                      Thanks for the heads up regarding the Nvidia Driver, I'll give that a try if it comes up again.

                                      • 17. Re: Update fails, uninstalls Adobe with an Error 1303
                                        brian-gm

                                        Just chiming in to say that I'm seeing the same Adobe Reader update issue with a 64-bit Windows 7 machine (a ThinkPad T410s - also with the Nvidia+Intel switchable graphics setup).  I had tried uninstalling and re-installing, and the install then failed complaining about insufficient rights to the Adobe directory under c:\ProgramData...

                                         

                                        The KB947821 Windows patch mentioned earlier in this thread is the "System Update Readiness Tool for Windows 7 for x64-based Systems (KB947821) [May 2011]". Here's the description:

                                         

                                        This tool is being offered because an inconsistency was found in the Windows servicing store which may prevent the successful installation of future updates, service packs, and software.

                                         

                                        Installing it as I type...  OK... The Microsoft update complete successfully, but the Adobe Reader install failed again with the same error about c:\ProgramData\Adobe. I then re-applied the inheritable permissions from c:\programdata to the Adobe subdirectory and below...

                                         

                                        The Adobe Reader then Installed successfully, and I'm fairly optimisitic that future updates will go smoothly as well.

                                         

                                        Speaking of which, Adobe updates are too frequent and too visible. I get annoyed with how often Flash or Reader is getting some update or other... Ironically, I'm eager for another Reader Update now, to test this :-).

                                        • 18. Re: Update fails, uninstalls Adobe with an Error 1303
                                          mpaca

                                          Installed the windows patch KB947821, applied the permissions. nothing worked. i even tried to install ver 10.1.1, 10.1.0, 9.5, but i got the same error message about the "\Adobe\ARM\1.0" folder no matter what I tried.

                                          Then I started windows in Safe mode. I created Common Files\Adobe\ARM\1.0 myself. I gave full control to myself under properties->security tab. IT WORKED.