2 Replies Latest reply on Jun 22, 2011 2:07 AM by EruAinur

    Extension not appearing in Photoshop CS5

    EruAinur

      Hi,

       

      I'm not being able to get my simple extension to show up on the window\extensions menu in photoshop CS5.
      I'm using Flash Builder 4 CS5, with the CS SDK 1.5, without Extension Builder.
      I've tried everything.
      The extension runs ok inside Flash Builder when I try to debug with AIR debugger without photoshop.
      In the main xml file, I only included a simple function, and have managed to get all the importing right (auto-complete works on the document objects)

      I have gone through everything that needed to be done to coextension.jpgmpile the extension, and it is being loaded ok in the extension manager.

      I am using a certificate I created with ADT, according to the documentation:

      java -jar ucf.jar -package -storetype PKCS12 -keystore newcert.p12 -storepass 39#wnetx3tl com.example.helloworld.zxp -C "tt" .

      (having all files from the output folder copied to a local folder named "tt")

      I did all the builer-plate manifest file definition, by the book.

      I used the Flex 3.4 SDK libraries, as described in the tutorial.

      All can be seen in the attachement.

       

      Here is my main xml file:

      --

      <?xml version="1.0" encoding="utf-8"?>

      <mx:WindowedApplication xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute"

      historyManagementEnabled="false">

      <mx:Script>

      <![CDATA[

      import com.adobe.csawlib.photoshop.Photoshop;

      import com.adobe.photoshop.*;

       

      public function run():void

      {

      var app:com.adobe.photoshop.Application = Photoshop.app;

      var doc:Document = app.documents.add();

      doc.selection.selectAll();

       

      var color:RGBColor = new RGBColor();

      color.red = 0;

      color.green = 0;

      color.blue = 255;

       

      doc.selection.fill(color);

       

      }

      ]]>

      </mx:Script>

      <mx:VBox height="100%" width="100%" verticalAlign="middle" horizontalAlign="center">

      <mx:Button label="Say Hello" click="run()"/>

      </mx:VBox>

      </mx:WindowedApplication>

      --

       

       

      Here is the manifest file:

      --

      <?xml version="1.0" encoding="UTF-8"?>

      <ExtensionManifest Version="2.0" ExtensionBundleId="com.example.helloworld" ExtensionBundleVersion="1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

      <ExtensionList>

      <Extension Id="com.example.helloworld.extension1" Version="1.0" />

      </ExtensionList>

      <ExecutionEnvironment>

      <HostList>

      <Host Name="PHSP" Version="12" />

      </HostList>

      <LocaleList>

      <Locale Code="All" />

      </LocaleList>

      <RequiredRuntimeList>

      <RequiredRuntime Name="CSXS" Version="2.0" />

      </RequiredRuntimeList>

      </ExecutionEnvironment>

      <DispatchInfoList>

      <Extension Id="com.example.helloworld.extension1">

      <DispatchInfo >

      <Resources>

      <SwfPath>HelloWorld.swf</SwfPath>

      </Resources>

      <Lifecycle>

      <AutoVisible>true</AutoVisible>

      </Lifecycle>

      <UI>

      <Type>Panel</Type>

      <Menu>Hello World</Menu>

      <Geometry>

      <Size>

      <Height>200</Height>

      <Width>200</Width>

      </Size>

      </Geometry>

      </UI>

      </DispatchInfo>

      </Extension>

      </DispatchInfoList>

      </ExtensionManifest>

      --

       

       

      Debug mode didn't work for me for some reason:

       

      I added the registry debug flag (windows 7 64bit) in both the user-key:

       

      HKEY_CURRENT_USER\Software\Adobe\CSXSPreferences\PlayerDebugMode     REG_SZ     1

      And the local-machine key:

       

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Adobe\CSXSPreferences\PlayerDebugMode     REG_SZ     1

       

      I tried puting the output files both in the common files folder:

      C:\Program Files (x86)\Common Files\Adobe\CS5ServiceManager\extensions\

       

      And the user folder:

      C:\Users\arnon\AppData\Roaming\Adobe\CS5ServiceManager\extensions\

       

      Tried debugging both using the AIR debugger and the Web one...
      Nothing...

       

      I tried updating the AIR2.0 SDK, as described by overriding the files, both in the Flash CS subfolder, and the CS SDK subfolder, as described.

      I tried updating both flash CS and Flash Builder 4 CS5 to their latest patch.

       

      I'm all out of ideas...

      Please HELP!

        • 1. Re: Extension not appearing in Photoshop CS5
          david_a_clark Adobe Employee

          Check your manifest.xml. If you are running Photoshop Extended, you must also add the Photoshop Extended code to the manifest file:

           

          <Host Name="PHXS" Version="12.0" />

           

          Also, your SwfPath should be

           

          <SwfPath>./HelloWorld.swf</SwfPath>

           

          Let me know if that doesn't solve the problem.

          • 2. Re: Extension not appearing in Photoshop CS5
            EruAinur Level 1

            10x,
            You saved my ***!
            It actually has to include both the PHSP "AND" the
            PHXS host names for it to work - this is stupid!
            If I only use
            PHXS the extension manager is not able to install the extension, saying it cannot find a host that matches the manifest (even though my photoshop IS the extended variation, so in a sense it's more acurate manifest-wise), and if I only use the PHSP, it IS loaded but doesn't appear in the application!
            AND THERE IS NO DOCUMENTATION ON THIS PHENOMENON ANYWHERE!
            THIS IS BEYOND IRRESPONSIBLE!

             

            Thank you very much david, but please, as you are an adobe employee, get this message to the right people, if you can.
            I know the corporate agenda would probabely be the incentivise people to register to the 1500$ program to get the extension-builder, by keeping the alternative inconvenient, but this issue is beyond inconvenient, it's border-line cruelty!