7 Replies Latest reply on Jul 11, 2011 12:18 PM by Loren Amelang

    update of reader causes issue with web based content

    crash13031958

      I have just downloaded the latest update for Adobe Reader x and I am now experiencing a problem when opening a pdf document from the internet.  I am now getting a message "before proceeding you must first launch adobe acrobat and accept the end user license agreement" which does not make sense.  When I click on the ok button nothing happens.  If I open the reader and then select the document it opens correctly.

       

      Can anyone provide some clue as to what the configuration setting is to turn off this "feature" please?

        • 1. Re: update of reader causes issue with web based content
          Loren Amelang

          Afraid I don't have an answer, but it isn't just web content. And it isn't just Reader X or 10.1. Search the web and you'lI see forums discussing the same exact message over two years ago with Reader 9. Most people seem to be having problems only with web or server hosted files.

           

          My problem is that if I double-click any pdf in a certain local Windows folder I get that message. Move the single pdf file to a different folder and it opens right up. But move the pdf file _and_ the rest of the contents of its original folder to a new folder, and the problem moves with it! The message seems quite inappropriate since I don't have the paid version of Acrobat installed, and never have.

           

          I do have the PrimoPDF print driver installed...  I wonder if that could be related. I noticed Reader X refuses to print to the PrimoPDF driver... 

           

          I see sysadmin types discussing the new Reader "Enhanced Security" and "sandboxing", and file permissions issues as possible causes, but nobody has conclusively solved this. None of their suggestions helped me. I haven't seen a single word from Adobe, over the years this seems to have been happening.

           

          While I'm complaining, (and perhaps this might even be a clue), ever since I got this new Win7 computer a year and a half ago _every_ update of Adobe Reader installs showing a generic taskbar icon. I have to open up my Start menu, find the shortcut to Adobe Reader, delete it, open Program Files and find Reader.exe, and manually create a new Start Menu shortcut. Even if the existing shortcut was obviously created during the install and named "Adobe Reader X"! Then the proper icon shows in my taskbar.

           

          Reader seems to have become more complex than humans can cope with.

          • 2. Re: update of reader causes issue with web based content
            370H55V Level 4

            I've never seen this problem on my own system(s) but it did happen on a work system a few years back. Here's what I did, and this is ONLY recommended if you don't have any Adobe professional products (Acrobat, Photoshop, Dreamweaver, etc.)

             

            Remove Adobe Air, Adobe Download Manager, Adobe Reader, Flash Player, and Shockwave using the Control Panel

             

            Click Start and Run. Type regedit and open the registry editor.

            Under HKEY_LOCAL_MACHINE\Software click the Adobe folder and press Delete. Click Yes and delete the folder,

            Do the same under HKEY_CURRENT_USER\Software.

            Reboot.

            Redownload Reader, Air, Flash Player, and Shockwave and install them.

            Your system should not mistakenly acknowledge an Acrobat installation afterward.

             

            The reason for deleting the other applications is that once you delete the entire Adobe folder from the registry, they will not run and it will be more difficult to uninstall or re-install them with a "broken installation" on the system.

            • 3. Re: update of reader causes issue with web based content
              Loren Amelang Level 1

              I'm definitely not willing to re-install Photoshop, so I'm not going to try that whole procedure. But it is interesting to see some Acrobat entries in the registry alongside the Reader entries:

               

              -----

              [HKEY_CURRENT_USER\Software\Adobe\Adobe Acrobat\10.0\AVGeneral]

              "bLastExitNormal"=dword:00000001

              "bAppInitialized"=dword:00000001

               

              [HKEY_CURRENT_USER\Software\Adobe\Adobe Acrobat\10.0\AVGeneral\cTaskPanes]

               

              [HKEY_CURRENT_USER\Software\Adobe\Adobe Acrobat\10.0\AVGeneral\cTaskPanes\cBasicCommentPane]

              "bAllowMultipleExpandedPanels"=dword:00000001

              -----

               

              No Acrobat entries in HKEY_LOCAL_MACHINE\Software, so it is curious to see "AppInitialized" under my user account.

               

              -----
              To Disable Registration, I used this registry

              [HKEY_CURRENT_USER\Software\Adobe\Adobe Acrobat\10.0\AVGeneral]
              "bSerialized"=dword:00000001
              "bAppInitialized"=dword:00000001
              There is also a "bActivated" key whose DWORD value is x00000000

              -----

               

              Maybe I need the Activated key? On the other hand, at

              http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/4713fea0-043f-4cf0-8edd- aa6d737aaad2/

              there is a complete dump of a Win7 registry that doesn't have any of those Acrobat keys - but it is from Reader 9.0...

              • 4. Re: update of reader causes issue with web based content
                GNiessen

                I was getting the same message when I clicked on a file in explorer or tried to launch AcroRd32 with a file as a parameter from CMD.  Once I went into AcroRd32 directly and went to Edit/Preferences/General and set "Enable Protected Mode at startup", I was able to run fine.

                 

                The registry change seems to be

                [HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\10.0\Privileged]

                "bProtectedMode"=dword:00000001

                 

                It now starts without the  "before proceeding you must first launch adobe acrobat and accept the end user license agreement" message.

                • 5. Re: re-enabling Protected Mode
                  Loren Amelang Level 1

                  Interesting! I just discovered the same thing - but as I said in http://community.spiceworks.com/topic/144910-weird-adobe-reader-x-issue?page=1#entry-80715 4

                  "I just re-enabled Protected Mode, and suddenly can double-click the local file I was testing with, and it opens right up! There must be more to this, because it wasn't working for me before I found this thread and the suggestion to "uncheck Enable Protected Mode at Startup". Maybe the trip through turning off Protected Mode and Enhanced Security, restarting the program, and turning them back on resets some other condition?"

                   

                  Still seems odd that Protected Mode "sandboxing" should make any difference to opening local files.

                  • 6. Re: update of reader causes issue with web based content
                    PatrickHoban1 Level 1

                    I ran into this problem as well. I wrote a post on my blog about how I fixed it. Hopefully it works in your case

                    also.

                     

                    http://patrickhoban.wordpress.com/2011/07/09/124/

                     

                    Regards,

                     

                    Patrick

                    • 7. Re: update of reader causes issue with web based content
                      Loren Amelang Level 1

                      As I noted in my comment on Patrick's blog, I think maybe the "CR" clue he found applies to the full path to the file - I was unable to open any pdf in any subfolder of a folder named "CRR Doc". I moved all of the contents to a temporary folder and could open pdf files. When I renamed the temporary folder back to "CRR Doc", I could no longer open the pdf files.