1 Reply Latest reply on Jun 30, 2011 2:48 PM by Ansury

    JVM Crash During Flash Builder 4 plug-in Install

    Ansury Level 3

      While installing the FB 4 plugin (selected an existing Eclipse install, Ganymede), I received a JVM crash dialog while files were being copied.  After closing the dialog, the installer kept going, and seemed to complete successfully.  However files were not copied into the Eclipse directory I specified.

       

      I did end up copying from the plugin's /eclipse directory (which did get created) to the version I wanted to install within, and things seem fine (so far).  Has anyone seen this happen before?  One thing to note is that this system (in the crash report) is using a "jvm.dll" Java VM.  Installing FB 4 standalone works fine, but when running it, I get a similar error (permgen space I believe).  I was able to resolve that by using some startup parameters and I think the parameter that worked for getting it running was "-vm javaw.exe".  In light of the plugin-installer's crash I found that interesting.

       

      It would be good if the FB installers could be simpfied a little so they're a little less fragile, or at least, allow us to specify jvm parameters during the install so this type of issue can possibly be worked around.

        • 1. Re: JVM Crash During Flash Builder 4 plug-in Install
          Ansury Level 3

          Anyone from Adobe here willing to address or comment on this?  Preferably I'd rather have a workaround to get the installer to run correctly without throwing up errors, and without manual copies into /plugins which may or may not result in a reliable install.  If there's no fix to get around this, I hope at least the installer can be simplifed a bit in future versions so it's not so fragile.