21 Replies Latest reply on Jun 30, 2011 1:37 AM by Peter Spier

    CS 5 exports two pages at a time instead of one.

    The Primate Level 1

      I copied the following script from the Internet into notepad, saved it, and renamed it "spreads.jsx". I put it into my scripts file. It didn't do anything. app.interactivePDFExportPreferences.exportReaderSpreads = !app.interactivePDFExportPreferences.exportReaderSpreads

       

      I removed the facing pages check. My pages still exported two pages to a page. I then created a new document without the facing pages checked. I copied the 21 of my original file into the new file. It still exported two pages on one.

       

      >The only way to get non-facing pages to stick together is to disable page shuffling and drag them together in the Pages Panel, and that 
      won't happen accidentally.

      I turned off shuffling, and that didn't help either. It was unclear what to drag in the Pages Panel.

      I'm now past my deadline for the newsletter and can use anybody's help so that I get an output in .pdf for single pages, so people can print out the file and have a single page on a single sheet.

      Lou

       

       

      First, here is my screen shot of the resulting .pdf file from exporting my 21 page document

      screen1.jpg

      Second, here is the screen shot of my pages panel.

      Screen2.jpg

      Next, the export dialogue:

      screen3.jpg

      Here is the scripts dialogue box.

        • 1. Re: CS 5 exports two pages at a time instead of one.
          Stix Hart Level 5

          If you have created a new docuiment without facing pages ticked your pages panel should look something like this:

           

          1.png

           

          Anyhoo I'm sure you should be able to fix your original document with a script.  Try downloading this one here.  That is a zipped folder.  Save it somewhere, extract it and copy the .jsx file to your scripts panel folder.  Once you have it there and your document open double click on it.  You should get a dialog box like this:

           

          2.png

           

          If you don't get exactly that, with it telling you they are OFF, click on it again and you will that time.  Export away and let us know what happens.  If it then doesn't work export the document to idml, open again in Indesign and repeat, along with making sure the script is telling you that spreads are OFF before you export.

           

          Also, that screenshot is telling us that you have missing fonts, go to Type > Find Font to fix them up.

          • 2. Re: CS 5 exports two pages at a time instead of one.
            The Primate Level 1

            It worked! Um, kind of. The three videos in the file won't play now. Do you have any advice?

             

            >that screenshot is telling us that you have missing fonts,

             

            The reason why the fonts are not there is because I am on a different computer trying to fix the problem.I am going to the other one to see if I can get different results.

            • 3. Re: CS 5 exports two pages at a time instead of one.
              Stix Hart Level 5

              If you're on a different computer my first suspicion is that that computer doesn't have the latest Adobe Reader, try your other one where (I'm assuming) the videos worked before.

              • 4. Re: CS 5 exports two pages at a time instead of one.
                The Primate Level 1

                Here is what I've done. I took my original file and renamed it. Then I 

                inserted the given script, ran it, and got the message I was told I would. 

                When I exported my file, Video 1 and 3 disappeared altogether; there's white 

                space in their position instead. Video 2 has moved up the page and is 

                covering other photos, and left a blank space where it had been. Video 2 plays  in

                Reader. This is the same thing that happened on the other computer where I 

                was testing the solution.

                 

                I'm excited that my newsletter, for the first time in 27 years, is  going

                to have animation, kind of like that Harry Potter newspaper. What can I do 

                to make this happen?

                 

                Lou

                 

                If  you're on a different computer my first suspicion is that that computer

                doesn't have the latest Adobe Reader, try your other one where (I'm

                assuming)  the videos worked before.

                • 5. Re: CS 5 exports two pages at a time instead of one.
                  Stix Hart Level 5

                  OK I think you can mark this question as answered and start another thread for the video problem.  Unless when you exported as spreads it all worked OK?

                   

                  First thing to do with the video problem is look at this post here and make sure that you are following those guidelines.

                  • 6. Re: CS 5 exports two pages at a time instead of one.
                    The Primate Level 1

                    >Unless when you exported as spreads it all worked

                    Yes, when CS 5 exported and I had the two page spread problem, the videos were right where I put them and worked beautifully. The only thing that is different now is that I have the script that was sent to me. Get this. When I deleted the script, the file exported with single pages as I wanted. The video positions are where they should be, they just don't play still. It is an improvement and I seem to be extremely close now. What can be done to make them play?

                     

                    I am very appreciative that you are helping me.

                     

                    Lou

                    • 7. Re: CS 5 exports two pages at a time instead of one.
                      Peter Spier Most Valuable Participant (Moderator)

                      The script changes from spreads to single pages the first time it runs, and the settings stay that way until the script is run again.

                       

                      As stix pointed out, you did NOT have a non-facing document. I think it would be helpful to run this script again to reset the export to it's default condition (in case there is some connection), then make a new single page file and uncheck facing pages in the setup dialog for that file. Add your videos to the new test file and export.

                       

                      If they work there, make a copy of the newsletter, then in the copy go to File > Document Setup... and uncheck the facing pages box. Note that all pages will now be using the right-hand side of the two-page master spread that was assigned, so if you had asymmetrical master elements this is going to disturb them, but for testing purposes that should not be an issue. Export without running the script to see if the videos work and if you get single pages.

                       

                      The other thing to try is make another copy of the file, then run the script from  http://www.printisrael.com/indesign/scripts/freeware/SeparatePages.jsx which will break apart all the facing page spreads into single pages without changing their "facing" attributes. This also should export as single pages.

                      • 8. Re: CS 5 exports two pages at a time instead of one.
                        The Primate Level 1

                        I did what you said: 1) Created a new two page file 2) Facing pages was not

                        checked 3) I put two videos in the bottom right corner of page 1   4)  I

                        put a third video near the right middle of page two. 5) I deleted the  script

                         

                        Here is what happened.

                         

                        1) I have always gotten this error message on export: "One or more 

                        interactive files are clipped in ways that PDF files cannot reproduce. Those 

                        elements will be adjusted in the exported PDF." I've been just saying okay to 

                        that. Is that important to the issue here?

                        2) The two videos moved to the upper left and partially off the page in 

                        Reader. They both play.

                        3) There is a red outline of the third video almost in the middle of page 1

                        (It should be on page 2.) There is nothing there to click on.

                        4) Page 2 is blank.

                         

                        Why are the position of the videos moving? All three are f4v files that I 

                        converted from mpg in the Adobe Media program.

                         

                        What do you suggest? Also, how is it you came by all this knowledge of how 

                        InDesign works? I have taken over 80 of those small lessons on Lynda, and

                        there  is nothing even close to this.

                         

                        Lou

                         

                         

                        In a message dated 6/27/2011 6:08:17 A.M. US Mountain Standard Time, 

                        forums@adobe.com writes:

                         

                        The  script changes from spreads to single pages the first time it runs,

                        and the  settings stay that way until the script is run again.

                         

                        As stix  pointed out, you did NOT have a non-facing document. I think it

                        would be  helpful to run this script again to reset the export to it's default

                        condition  (in case there is some connection), then make a new single page

                        file and  uncheck facing pages in the setup dialog for that file. Add your

                        videos to the  new test file and export.

                         

                        If they work there, make a copy of the  newsletter, then in the copy go to

                        File > Document Setup... and uncheck the  facing pages box. Note that all

                        pages will now be using the right-hand side of  the two-page master spread

                        that was assigned, so if you had asymmetrical  master elements this is going to

                        disturb them, but for testing purposes that  should not be an issue. Export

                        without running the script to see if the videos  work and if you get single

                        pages.

                         

                        The other thing to try is make  another copy of the file, then run the

                        script from  

                        http://www.printisrael.com/indesign/scripts/freeware/SeparatePages.jsx which  will break apart all the facing page spreads into single pages

                        without  changing their "facing" attributes. This also should export as

                        single  pages.

                        • 9. Re: CS 5 exports two pages at a time instead of one.
                          The Primate Level 1

                          One more thing. I just ran the script that you sent me. All three videos 

                          now play, two on page one and one on page two. However, all have been

                          displaced  from their original positions, which would ruin the document design.

                           

                          I went back and exported my original file. Video 1 is just a red outline of

                          blank space in the correct position. Video 2 has been displaced and 

                          covers two photos, and plays. Video 3 is just blank space, not even a red 

                          outline.

                           

                          Lou

                           

                           

                          In a message dated 6/27/2011 6:08:17 A.M. US Mountain Standard Time, 

                          forums@adobe.com writes:

                           

                          The  script changes from spreads to single pages the first time it runs,

                          and the  settings stay that way until the script is run again.

                           

                          As stix  pointed out, you did NOT have a non-facing document. I think it

                          would be  helpful to run this script again to reset the export to it's default

                          condition  (in case there is some connection), then make a new single page

                          file and  uncheck facing pages in the setup dialog for that file. Add your

                          videos to the  new test file and export.

                           

                          If they work there, make a copy of the  newsletter, then in the copy go to

                          File > Document Setup... and uncheck the  facing pages box. Note that all

                          pages will now be using the right-hand side of  the two-page master spread

                          that was assigned, so if you had asymmetrical  master elements this is going to

                          disturb them, but for testing purposes that  should not be an issue. Export

                          without running the script to see if the videos  work and if you get single

                          pages.

                           

                          The other thing to try is make  another copy of the file, then run the

                          script from  

                          http://www.printisrael.com/indesign/scripts/freeware/SeparatePages.jsx which  will break apart all the facing page spreads into single pages

                          without  changing their "facing" attributes. This also should export as

                          single  pages.

                          • 10. Re: CS 5 exports two pages at a time instead of one.
                            Peter Spier Most Valuable Participant (Moderator)

                            Lou,

                             

                            In order to properly diagnose your problem it is ESSENTIAL that ID is

                            behaving in a known and predictable way. This means that if you ran the

                            first script, the one that Stix recommended, and ran it only once and then

                            deleted it, you MUST reinstall the script, and run it again to reset the

                            export behavior to spreads so we know what's going on. You should see a new

                            dialog telling you that exporting spreads is active when the script runs.

                             

                            Until you do that, we really can't tell where the problems with things

                            moving might be coming from.

                             

                            I design for print, and I've been working with InDesign since it was first

                            released, switching my production work from Quark Xpress to InDesign when ID

                            2.0 was released about 10 years ago. Before going freelance as a designer I

                            worked a few years in print shops learning from other people's mistakes (and

                            learning how to fix most of them), and did some newspaper and magazine

                            production. Quite a bit of what I know about InDesign I've actually learned

                            here. For the first few years I read every post, and if I didn't already

                            know the answer I tried to figure it out. Even now, though, I usually learn

                            something new at least once a week.

                             

                            As I just mentioned, I design for print, so the interactive stuff is a bit

                            murky for me, too, but if we can get you to a known state and see if things

                            are where they belong, someone who does interactives all the time may be

                            able to help more. I don't know about the warning you get, but I suspect it

                            is significant.

                            • 11. Re: CS 5 exports two pages at a time instead of one.
                              The Primate Level 1

                              Someone, maybe you, suggested I start a new thread about the video. I 

                              posted it to the forum under:

                               

                              "I solved the export single page issue and now my videos won't work." Here 

                              is the text:

                               

                               

                              I have  windows 7 for 64 bit. 

                              I ran  a script on my InDesign CS 5 document to solve the problem with two

                              pages  appearing on one .pdf file.  When I  clicked on it, here is what I

                              get “Spreads are now ON in Interactive PDF  Preferences.”

                              I get  two pages stuck together in my interactive .pdf file. I don’t want

                              that because  it prints to pages on a single sheet and I want each page to

                              print separately.  However, my three .f4v videos appear the way I want and run

                              perfectly, even  though I got the error message, “One or more interactive

                              elements are clipped in  ways that PDF files cannot reproduce. Those elements

                              will be adjusted in the  exported PDF. “ 

                              When I  click on the script again, it says, “Spreads are now OFF in

                              Interactive PDF  Preferences.”

                              The  pages are the way I want. Now my videos don’t behave. Video 1 vanished

                              into a  red border with blank inside. Video 2 has moved half way up the

                              page, covering  two photos, but it plays. Video 3 has just white space in its

                              position. 

                              Next,  I tried another script. When I ran it I got the message, “Shuffling

                              pages will  remove some page transitions. To avoid this message in the

                              future, uncheck allow  Document Pages to Shuffle in the Pages panel. Select OK to

                              continue.” I hit okay  several times and the message kept appearing again

                              and again. I finally clicked  “Don’t show again” and it went away. I got the

                              same error message as before. The  videos are all screwed up, like before.

                              I  toggled that script and exported again, and got the same error message.

                              This  time, as before, the videos were messed up, but this time one of the

                              videos was  off the page, but played. 

                              Is  there any way I can keep one page to one in the .pdf AND have my videos

                              work?

                              Lou

                               

                               

                              In a message dated 6/27/2011 7:39:51 A.M. US Mountain Standard Time, 

                              forums@adobe.com writes:

                               

                              Lou,

                               

                              In order to properly diagnose your problem it is  ESSENTIAL that ID is

                              behaving in a known and predictable way. This means  that if you ran the

                              first script, the one that Stix recommended, and ran  it only once and then

                              deleted it, you MUST reinstall the script, and run  it again to reset the

                              export behavior to spreads so we know what's going  on. You should see a

                              new

                              dialog telling you that exporting spreads is  active when the script runs.

                               

                              Until you do that, we really can't  tell where the problems with things

                              moving might be coming  from.

                               

                              I design for print, and I've been working with InDesign  since it was first

                              released, switching my production work from Quark  Xpress to InDesign when

                              ID

                              2.0 was released about 10 years ago. Before  going freelance as a designer

                              I

                              worked a few years in print shops learning  from other people's mistakes

                              (and

                              learning how to fix most of them), and  did some newspaper and magazine

                              production. Quite a bit of what I know  about InDesign I've actually

                              learned

                              here. For the first few years I read  every post, and if I didn't already

                              know the answer I tried to figure it  out. Even now, though, I usually

                              learn

                              something new at least once a  week.

                               

                              As I just mentioned, I design for print, so the interactive  stuff is a bit

                              murky for me, too, but if we can get you to a known state  and see if

                              things

                              are where they belong, someone who does interactives all  the time may be

                              able to help more. I don't know about the warning you get,  but I suspect

                              it

                              is  significant.

                              • 12. Re: CS 5 exports two pages at a time instead of one.
                                Peter Spier Most Valuable Participant (Moderator)

                                Did you run the first script again to put the export options back to two-page spreads BEFORE running the scond script? That's important since evidently it's the first script changing the preferences that is initially causing the problem with the video. The scond script does not toggle anything, only the first one, which is why I suggested running on a copy. We're trying to establish if breaking the spreads apart inside ID will export the videos correctly, but we can't do that unless the preference is toggled to the "on" postion for exporting spreads.

                                 

                                Do you actually have page transitions to worry about? You didn't mention them before...

                                 

                                Have you ever actually tried a new document that didn't have facing pages? The last time you said you did the screen shot showed you still had facing pages.

                                • 13. Re: CS 5 exports two pages at a time instead of one.
                                  The Primate Level 1

                                  >Did you run the first script again to put the export options back to two-page

                                  spreads BEFORE running the scond script?

                                  I tried all the combinations of both scripts. At present all graphics print black.

                                   

                                   

                                  >which is why I suggested running on a copy.

                                  I am experimenting on a copy.

                                   

                                   

                                  We're trying to establish if breaking the spreads apart inside ID will export the videos correctly, but we can't do that unless the preference is toggled to the "on" postion for exporting spreads.

                                   

                                  I have done everything with spreads on and off. If I have the spreads on, the video works. But then I can't publish my newsletter because there are two pages that print on one sheet.

                                   

                                   

                                  >Do you actually have page transitions to worry about?

                                  I don't know what that is. I never heard of it before. Can you explain?

                                   

                                   

                                  >Have you ever actually tried a new document that didn't have facing pages? The

                                  last time you said you did the screen shot showed you still had facing pages.

                                   

                                  I unchecked the box with facing pages on all tries I have done.

                                   

                                  Lou

                                   

                                   

                                   

                                   

                                   

                                   

                                   

                                  >Do you actually have page transitions to worry about?

                                  I don't know what that is. I never heard of it before. Can you explain?

                                   

                                   

                                  >Have you ever actually tried a new document that didn't have facing pages? The

                                  last time you said you did the screen shot showed you still had facing pages.

                                   

                                  I unchecked the box with facing pages on all tries I have done.

                                   

                                  Lou

                                  • 14. Re: CS 5 exports two pages at a time instead of one.
                                    Stix Hart Level 5

                                    The Primate wrote:

                                     

                                    I unchecked the box with facing pages on all tries I have done.

                                     

                                    Lou

                                    OK let's focus on this.  You say you've done this but it hasn't worked, as I've said before your screenshot above shows facing pages.  Show us the Setup dialog box and the pages panel after you've unticked facing pages.

                                    • 15. Re: CS 5 exports two pages at a time instead of one.
                                      Peter Spier Most Valuable Participant (Moderator)

                                      I would like you to try a brand new file if you don't mind. There's really no way to tell waht sort of damage is done to what you have.

                                       

                                      First, File > New... and set up the correct page count and dimensions, then uncheck the Pacing Pages box. Verify by looking in the Pages Panel that there are no two-page spreads showing in the panel.

                                       

                                      Open the original file, switch to the Black Arrow (Selection tool) and page by page, Edit > Select All, then Edit > Copy. Paste onto the corresponding page in the new document and adjust the position if necessary.

                                       

                                      Export the new file to Interactive PDF without running any scripts.

                                      • 16. Re: CS 5 exports two pages at a time instead of one.
                                        The Primate Level 1

                                        Hi,

                                         

                                        As far as those scripts, there were two of them, should BOTH be in my 

                                        documents scripts folder? It just occurred to me that I have been only putting 

                                        in one at a time, deleting it, then running the other one to see if I could

                                        fix  things.

                                         

                                        Lou

                                         

                                         

                                        In a message dated 6/26/2011 6:13:58 P.M. US Mountain Standard Time, 

                                        forums@adobe.com writes:

                                         

                                        If you  have created a new docuiment without facing pages ticked your pages

                                        panel  should look something like  this:

                                         

                                        http://forums.adobe.com/servlet/JiveServlet/showImage/73669/1.png

                                         

                                        Anyhoo  I'm sure you should be able to fix your original document with a

                                        script.   Try downloading this one 

                                        http://indesignsecrets.com/downloads/togglespreads.zip.  That is a zipped  folder.  Save it somewhere, extract it and

                                        copy the .jsx file to your  scripts panel folder.  Once you have it there

                                        and your document open  double click on it.  You should get a dialog box like 

                                        this:

                                         

                                        http://forums.adobe.com/servlet/JiveServlet/showImage/73682/2.png

                                         

                                        If  you don't get exactly that, with it telling you they are OFF click on

                                        it again  and you will that time.  Export away and let us know what happens. 

                                        If it then doens't work export the document to idml, open again in

                                        Indesign  and repeat, along with making sure the script is telling you that spreads

                                        are  OFF before you export.

                                         

                                        Also, that screenshot is telling us that  you have missing fonts, go to

                                        Type > Find Font to fix them  up.

                                        • 17. Re: CS 5 exports two pages at a time instead of one.
                                          Stix Hart Level 5

                                          The Primate wrote:

                                           

                                          Hi,

                                           

                                          As far as those scripts, there were two of them, should BOTH be in my 

                                          documents scripts folder? It just occurred to me that I have been only putting 

                                          in one at a time, deleting it, then running the other one to see if I could

                                          fix  things.

                                           

                                          Lou

                                           

                                          Makes no difference at all if both, one or neither are in the folder, it's only when you run them that they do something.

                                           

                                          Take a look at and respond to posts 14 & 15, separately.

                                          • 18. Re: CS 5 exports two pages at a time instead of one.
                                            The Primate Level 1

                                            >Makes no difference at all if both, one or neither are in the folder, 

                                            it's only when you run them that they do something.

                                             

                                            Okay. I guess what I meant is do I run them both. I have tried that  after

                                            your last letter and a two page spread keeps appearing in my pages panel. 

                                            Despite my success in doing that previously in my gyrations at the keyboard,

                                            I  can't get the spread off. I keep unchecking the facing pages box, running

                                            the  scripts...I'm in a really frustrating loop here.

                                             

                                            Lou

                                            • 19. Re: CS 5 exports two pages at a time instead of one.
                                              The Primate Level 1

                                              I started a brand new 21 page file. I copied five pages using the pages 

                                              panel. I then exported the interactive pdf file and the videos were messed up.

                                              When I went to print in Reader, the print preview had my graphics as all

                                              black.  I deleted that file.

                                               

                                              I again made a 21 page file, but this time I copied five of the pages 

                                              directly from the InDesign pages, not using the pages panel. I pasted them in 

                                              the new file. Same result.

                                               

                                              I didn't load or run scripts in these two procedures. They both had single 

                                              pages showing in the pages panel, although the file from which I  was

                                              copying had two page spreads showing in the pages panel.

                                               

                                              Is there something else I can try?

                                               

                                              Lou

                                               

                                               

                                              In a message dated 6/29/2011 4:04:40 A.M. US Mountain Standard Time, 

                                              forums@adobe.com writes:

                                               

                                              I would  like you to try a brand new file if you don't mind. There's really

                                              no way to  tell waht sort of damage is done to what you have.

                                               

                                              First, File  > New... and set up the correct page count and dimensions,

                                              then uncheck the  Pacing Pages box. Verify by looking in the Pages Panel that

                                              there are no  two-page spreads showing in the panel.

                                               

                                              Open the original file,  switch to the Black Arrow (Selection tool) and

                                              page by page, Edit > Select  All, then Edit > Copy. Paste onto the

                                              corresponding page in the new  document and adjust the position if necessary.

                                               

                                              Export the new  file to Interactive PDF without running any  scripts.

                                              • 20. Re: CS 5 exports two pages at a time instead of one.
                                                The Primate Level 1

                                                >Take a look at and respond to posts 14 & 15,  separately.

                                                 

                                                I also exported the new file as an InDesign markup file (IDML). Then 

                                                reloaded it. That didn't help either.

                                                 

                                                Lou

                                                • 21. Re: CS 5 exports two pages at a time instead of one.
                                                  Peter Spier Most Valuable Participant (Moderator)

                                                  The Primate wrote:

                                                   

                                                  I started a brand new 21 page file. I copied five pages using the pages 

                                                  panel. I then exported the interactive pdf file and the videos were messed up.

                                                  When I went to print in Reader, the print preview had my graphics as all

                                                  black.  I deleted that file.

                                                   

                                                  I again made a 21 page file, but this time I copied five of the pages 

                                                  directly from the InDesign pages, not using the pages panel. I pasted them in 

                                                  the new file. Same result.

                                                   

                                                  I didn't load or run scripts in these two procedures. They both had single 

                                                  pages showing in the pages panel, although the file from which I  was

                                                  copying had two page spreads showing in the pages panel.

                                                   

                                                  Is there something else I can try?

                                                   

                                                  Lou

                                                  I'm still not sure what state the export of spreads setting is in. You should stop running those scripts for the moment while we figure out where things are.

                                                   

                                                  Make a facing pages file of at least three pages, or open one that you have already. DO NOT RUN ANY SCRIPT. Export to interactive PDF. Are you getting single pages, or a two-page spread in the PDF? If you are getting a two page spread, do nothing more. If you are getting all single pages, run the script that toggles single pages/spreads ( the first script you got, the one that puts up the dialog) ONE TIME ONLY. Close InDesign.

                                                   

                                                  Read the directions in this link and replace your preferences: Replace Your Preferences

                                                   

                                                  Try the second file you made above with the copied elements. If it still does not work, re-link the videos to fresh copies and try again.

                                                   

                                                  If it still does not work, I think someone will need to see your files to diagnose what's going on. Normally I would volunteer to do this myself, but I don't do this kind of file in my regular workflow, and I have a major project in production this week and no time to experiment. Perhaps someone else can step in.