7 Replies Latest reply on Jun 29, 2011 3:55 AM by Peter Spier

    Don't include 'out-of-frame' objects in PDF export

    Riquez JP Level 1

      Here's my issue - I need to create a screen friendly PDF instruction manual.

      I have been provided with the PDF print version of the manual, which is 660mm x 90mm (it folds up, 11 pages, to 60x90)

       

      I want to present the manual 2 pages at a time, so the resulting PDF will display nicely on screen & user can scroll down.

       

      I create a document 120x90 with a frame containing the PDF - only showing 2 of the pages (the rest of the manual is out of frame)

      If I export this to a new PDF it will include the entire manual out-of-frame, thus giving a 2MB file for what should be only 200K

      If I repeat this for all pages I'll end up with a 10MB PDF.

       

      How can I crop /  exclude out-of-frame artwork from the export?

        • 1. Re: Don't include 'out-of-frame' objects in PDF export
          Stix Hart Level 5

          Have you tried using Acrobat?  If you go File > Properties and go to the Initial View tab you should be able to change what view a reader sees there without going through InDesign at all.  What you want sounds like you need to set it to Two-Up Continous, and then choose Facing or COver Page depending on whether you have a cover page or not.  I always like to set Magnification to Fit Page as well.

           

          If you have to use Indesign to re export it take a look at this post here as to why your files might be too big.

           

          I know neither is answering your original question but I think they might help!

          • 2. Re: Don't include 'out-of-frame' objects in PDF export
            Riquez JP Level 1

            I never really use Acrobat, so im not sure if it has the tools i need.

             

            The artwork I have is one large single page document 660mm x 90mm, this folds concertina style to create an 11 page manual. So the artwork does not have any separately defined 'pages' as such - just one large sheet.

             

            I opened in Acrobat & cropped the page down to only show 2 of the 'pages'. then saved the new PDF - it was exactly the same filesize as the original PDF even though it was 1/5th the physical dimension - so it seems acrobat has the same issues.

             

            The solution for me is to open the PDF in illustrator & drag over the 'pages' into indesign.

            However, the point of this question was to see if there is an option in indesign to crop out extraneous artwork so I dont have to do that.

             

            Your post is helpful though, the article about overhead is exactly what i am experiencing. Dragging from Illustrator is my quickest solution it seems.

            • 3. Re: Don't include 'out-of-frame' objects in PDF export
              Stix Hart Level 5

              When yuo crop in Acrobat you are only telling Acrobat or Reader to view only that part of the PDF, all the rest of it is still there and can be uncropped.  If you crop it and export to PS it gets rid of the rest of the info and will reduce your file size.

              1 person found this helpful
              • 4. Re: Don't include 'out-of-frame' objects in PDF export
                Riquez JP Level 1

                That sounds like a decent workaround, thanks. I will bear that in mind for the future.

                 

                PDF can be difficult to edit in Illustrator sometimes & in this case, it was one of those times.

                 

                I have now managed to get hold of the original indesign file from the designer, but it took them a few hours to get back to me with it.

                Your solution will save me time if this situation happens again.

                • 5. Re: Don't include 'out-of-frame' objects in PDF export
                  John Hawkinson Level 5
                  I want to present the manual 2 pages at a time, so the resulting PDF will display nicely on screen & user can scroll down.

                  Most people consider this user-unfriendly.

                   

                  A page should be a page. I should be able to jump to any arbitrary page by page number. And my monitor size and shape may be very different from yours, such that I want to display pages my own way.

                   

                  Since Acrobat has a preference that lets you display two pages side-by-side, you should use it. That way users can just turn it off if they don't like it, rather than cursing at the manual designer who didn't let them escape from the two-up-spreads of Doom! (ok, mild exaggeration).

                  • 6. Re: Don't include 'out-of-frame' objects in PDF export
                    Riquez JP Level 1

                    I would agree normally but in this particular case its not a standard page-by-page document.

                    As mentioned, it is a long foldout with all content running left to right. The document is folded in such a way so it fits in the product box.

                    Text on one page refers to a diagram across the fold, so the onscreen version is more useful when people can also see the diagram by default.

                    • 7. Re: Don't include 'out-of-frame' objects in PDF export
                      Peter Spier Most Valuable Participant (Moderator)

                      I would suggest you set up a new InDesign document of 11 60 x 90 NON-facing pages. In the Pages panel flyout menu UNCHECK "allow document pages to shuffle" and drag the last 10 pages into a single horizontal row (ten is the maximum ID will put into a single spread), or break them 5 & 6 or whatever is convenient. You'll see a sort of black "brakect" line when the pages are going to lock together. Place the file you have now twice across the entire layout, arranging it so it fits the pages correctly, then export a new PDF which will give you single pages.