7 Replies Latest reply on Jun 29, 2011 1:21 PM by Rick Gerard

    Attach point position.....

    AudoWarp Level 1

      Okay, now my "Attach Point" (that liitle "x" in the tracker) is changing its postiotion relative to the search region/feature region boxes over time.

      Why wouldn't it maintain the same relative position to those boxes over time.

      As I'm attaching a clone stamp to that little "x", I kind of need it to be in a predictable position--like where I put it to begin with--rather than have it wondering.....

        • 1. Re: Attach point position.....
          Mylenium Most Valuable Participant

          You have chosen to adapt the search area per frame and that behavior is expected - the actual search pattern takes precedence over tha absolute search window and the tracker attempts to stick the point in the same place. Turn off the adaptive feature if you need a fixed placment. I can see no reason why this shoudl be a problem, though. Any offsets can easily be compensated with some very simple expressions, if needed.

           

          Mylenium

          • 2. Re: Attach point position.....
            AudoWarp Level 1

            Okay, "Adaptive Feature on Every Frame" is turned off...

            Could it be the "Subpixel Positioning"?

            • 3. Re: Attach point position.....
              Mylenium Most Valuable Participant

              Sub-pixel positioning should only do minor corrections. They may eventually drift considerably, but by that time, normally the track needs to be restarted, anyway, as it is drifted off too much as a whole. Are you sure you're not seeing some weird jumps from wrong field settings or excessive compression artifacts?

               

              Mylenium

              • 4. Re: Attach point position.....
                AudoWarp Level 1

                I am tracking a hot pixel from a camcorder.

                I believe it is moving because of digital image stabilization.

                It jumps around, but it stays within a small area.

                I have to zoom in to the area so that I can see the hot pixel behind the tracker points that AE overlays over the video...

                3200%

                "Subpixel positioning" may be shifting the 'x' ("Attach Point") at that scale?

                • 5. Re: Attach point position.....
                  AudoWarp Level 1

                  It IS interlaced footage--I believe....

                  • 6. Re: Attach point position.....
                    AudoWarp Level 1

                    "Sub-pixel positioning should only do minor corrections"

                    I am zoomed in to 3200%That's what it was.

                    I turned it off......

                    • 7. Re: Attach point position.....
                      Rick Gerard Adobe Community Professional & MVP

                      AudoWarp wrote:

                       

                      I am tracking a hot pixel from a camcorder.

                      I believe it is moving because of digital image stabilization.

                      It jumps around, but it stays within a small area.

                      You need to be tracking an area of about 100 pixels or more. The larger the area and the more different pixels (detail) in the track area, the better the track.

                       

                      If you are just trying to clone a single pixel you're going have a bit of trouble because of the sub-pixel adjustments the track makes. Try working with larger areas. You'll probably be more successful.

                       

                      If the footage is interlaced you'll also want to make sure that you separate fields, then double the frame rate of the comp or make sure that track fields is selected.