1 Reply Latest reply on Jul 23, 2011 2:13 PM by Shongrunden

    link element in TextArea disappear on scrolling

    dkelly60

      I am not sure if this is a known bug but when I have links in a TextFlow for a TextArea or RichEditableText and I scroll the links vanish. Sample code below can someone tell me if it is something I am doing wrong? And if not how can I fix the problem?

      <?xml version="1.0" encoding="utf-8"?>
      <s:WindowedApplication xmlns:fx="http://ns.adobe.com/mxml/2009"
          xmlns:s="library://ns.adobe.com/flex/spark"
          xmlns:mx="library://ns.adobe.com/flex/mx" height="170" width="450">
          <fx:Declarations>
              <!-- Place non-visual elements (e.g., services, value objects) here -->
          </fx:Declarations>
         
          <s:TextArea id="richTxt1" textAlign="justify" percentWidth="100" height="133" width="413">
              <s:textFlow>
                  <s:TextFlow>
                      <s:p fontSize="24">TextFlow Child Tag</s:p>
                      <s:p>1) Lorem ipsum dolor sit amet, consectetur adipiscing elit.</s:p>
                      <s:p>2) Cras posuere posuere sem, eu congue orci mattis quis.</s:p>
                      <s:a href="link1:">link 1</s:a>
                      <s:p>3) Curabitur pulvinar tellus venenatis ipsum tempus lobortis.</s:p>
                      <s:a href="link2:">link 2</s:a>
                      <s:p fontSize="24">TextFlow Child Tag</s:p>
                      <s:p><s:a href="http://www.adobe.com">Adobe.com</s:a></s:p>
                      <s:p>4) Lorem ipsum dolor sit amet, consectetur adipiscing elit.</s:p>
                      <s:p>5) Cras posuere posuere sem, eu congue orci mattis quis.</s:p>
                  </s:TextFlow>
              </s:textFlow>
          </s:TextArea>
         
      </s:WindowedApplication>