12 Replies Latest reply on Jul 17, 2011 8:40 PM by Amebr

    RH9 Snippets not saving, RH not closing>have to force close

    LaconicVerbosity

       

       

       

      I'm a new RH user so please forgive me if this is answered somewhere else (I did search for awhile first).

       

       

       

      Windows XP Pro 2002 Service Pack 3

       

      RoboHelp 9 HTML 9.0.1.232 (recent upgrade from RH7) Project has about a thousand topics

      Using Visual SourceSafe (VSS) for version control

       

       

      There were snippets in the project before I started and before this upgrade - those all are usable and stay where you put them through saving and closing RH. Other edits to topics seem to be surviving the save process also. Snippets I create (have not created any before this) are not surviving when I save the project, but they are creating .hts files on the hard drive (but not showing up in VSS).  Also, when I create multipe new snippets, the first one and only the first one I create shows up in the snippet pod (before closing RH), and when I save/close/reopen RH, none show in the pod.

       

      Note: had the same as problem/related to this forum question.

       

      Also, now when I try to close RH it just closes the active tabs but does not close the project and I have to force close RH in the Windows Task Manager.

       

      Summary:

      • Edits to topics that do not      involve snippets are being saved
      • Edits that involve snippets      created before yesterday are saved
      • Snippets created by me:
        • All are creating files       on my hard drive
        • None are going into       Visual SourceSafe
        • Only the first shows       up in the Snippet pod before RH closes
        • None show up in the       Snippet pod when RH is reopened later

       

      So there we are.  Any ideas or suggestions?

        • 1. Re: RH9 Snippets not saving, RH not closing>have to force close
          Captiv8r Adobe Community Professional & MVP

          Welcome to our community

           

          Unfortunately we have version control in the mix. That always complicates things more than it should because now you must ponder is the issue related to RoboHelp or is it related to Source Control?

           

          Are you using VSS in the integrated mode where RoboHelp attempts to "help you out" by automagickally checking things in and out for you as you work? Or are you using it separately, where you perform your check in and check out as if VSS was a separate application?

           

          My thought is that certain files that are needed in order to update the snippet management aren't becoming writable. This could be a bug with RoboHelp (if using in an integrated fashion) and it could be an error on your behalf (if using as a separate app).

           

          If integrated, I'd suggest filing a Bug Report (link is in my sig).

          If separate, make sure you check out ALL the files before working with RoboHelp and see if things improve.

           

          Also, as a workaround for the integrated aspect, I'd try checking out ALL the files as well.

           

          Cheers... Rick

           

          Helpful and Handy Links

          RoboHelp Wish Form/Bug Reporting Form

          Begin learning RoboHelp HTML 7, 8 or 9 within the day!

          Adobe Certified RoboHelp HTML Training

          SorcerStone Blog

          RoboHelp eBooks

          • 2. Re: RH9 Snippets not saving, RH not closing>have to force close
            LaconicVerbosity Level 1

            Thank you for your reply.  We use VSS separately, I think because more than one of us is working with the same project at a time, but we always check out the files we need, then open RH, and after working close RH, then check the files back in to VSS.  Today when I did all my testing to see what worked and what didn't it did include checking out all the project files, from the root recursively through the rest.  I think there may be a bug in the snippet functionality somewhere especially given the problem previously mentioned in this forum topic.

            • 3. Re: RH9 Snippets not saving, RH not closing>have to force close
              Amebr Level 4

              If you are using Source Control separately, you will need to manually add the snippet files into source control. If RH isn't integrated with VSS then they won't be added automatically.

               

              Can you confirm that the .cpd file is not in source control? There are several files that shouldn't be checked in (.ldb, .pss from memory), but as I'm using an older version, I'm unsure if they are still relevant in RH9. Rick or someone might be able to confirm.

               

              Also, if multiple people are working on the same project at the same time, I recommend you set RH to automatically delete the cpd. This 'cache' seems to cause problems with not 'seeing' changes made by others. For example, I delete several files, then my colleague opens the project, but because the files are still "in" her cpd file, they are recreated on her PC. Or if I add files, they can be deleted on her pc.

              • 4. Re: RH9 Snippets not saving, RH not closing>have to force close
                LaconicVerbosity Level 1

                We do manually enter new files into VSS because it becomes a pain to deal with it through RH.

                 

                I'm noticing that the .cpd file is indeed in VSS and being checked in/out when we (two of us) check out the entire folder.  I've just set RH to "Clear project cache(.cpd file) before opening any project," and I deleted the .cpd from VSS. This is the first time we've had 2 people working on this so we didn't know about this issue.

                 

                The result was that one of my new snippets reappeared, but not others, and RH is still not recognizing when I create new ones.

                 

                I know there is a magic order of doing things (adding to VSS, getting latest version or something, opening RH, etc.) that will work I just don't know what that order is.

                • 5. Re: RH9 Snippets not saving, RH not closing>have to force close
                  johndaigle Level 4

                  I'm not a practitioner of Source Control, but adding to the files Amber mentioned, I see this post from Leon (MergeThis):

                   

                  >Be sure that these machine- and language-specific files are not controlled by RSC (or VSS):

                  • .cpd
                  • .hhp
                  • .ldb
                  • .pss

                  http://forums.adobe.com/message/2501858#2501858

                  Sorry I don't have specific info on the Snippet issue.

                  1 person found this helpful
                  • 6. Re: RH9 Snippets not saving, RH not closing>have to force close
                    LaconicVerbosity Level 1

                    OK, so we've removed all the files that shouldn't be in VSS from VSS (the ones previously mentioned as not belonging there), and we have looked at the rhsnippet.apj file to make sure it's being properly updated for each of us, but we are not yet sure where the hiccup is occurring regarding both of us using the same project files and something not syncing properly between both of our hard drive copies of everything - or something like that.

                     

                    My colleague tells me there is something wrong with my computer vs. hers, that I am missing some files in my project that are present in hers, and that somehow when I make changes something gets corrupted.

                     

                    I know that's not helpful information but my point is that we are in the process of further diagnosis and I wanted to let you all know that the information you shared was indeed helpful in at least furthering our understanding of how RH works.  This is the first time in our office that more than one person is using RH for the same project and I think it's just a matter of figuring out what we need to do as a team to make it work smoothly.

                     

                    If anyone knows of any red flags or standard issues regarding multiple users of the same project feel free to let me know.  My colleague is a super RH genius but we are both new to the multiple users situation.

                    • 7. Re: RH9 Snippets not saving, RH not closing>have to force close
                      Amebr Level 4

                      First I would recommend ensuring the project is fixed on one PC.

                       

                      1. Everyone checkin all work and close the project. A manual recursive checkin using VSS wouldn't hurt.

                      2. One person does a Get on the project and ensures the .cpd file is deleted from the C: drive.

                      3. Open the project and fix any errors. Probably have everyone around the one PC to make sure everyone can see the content they expect.

                      4. Checkin and close the project.   A manual recursive checkin using VSS wouldn't hurt.

                      5. Everyone delete (or zip and backup) everything from the project folder on C:. (delete should be fine as everything is in source control, but if you're extra paranoid, then creating a zip file means you have a copy of the content in case of emergencies.)

                      6. Do a fresh Get on one PC and verify the project looks fine. Repeat on other PCs.

                       

                      Ongoing:

                      1. Ensure the cpd is deleted at the end of every work day. (I think you said you'd already done this, but restating for completeness).

                      2. Do a Get before work every day to ensure the latest files are available locally. Note that in some source control progams Get latest won't always get the latest files; Get Specific (latest) might be needed. (I don't think VSS is affected by this, so you should be okay just to Get.)

                      3. It might be best if someone is changing administrative files such as the .apj files, that the person creating/deleting them ask everyone else to checkin and close RH while they create/delete them, then everyone Get, delete cpd and re-open the project. It's possible that this will not be practical for you (some projects take too long to open, for example).

                       

                      Ensuring points 1. and 2. are done every day should minimise any problems however. This has mostly removed our problem of me adding files and my co-worker not being able to see them (and RH "helpfully" deleting them from source control in the process.) Snippets however may require step 3 to ensure they don't go missing - we don't have a robohelp version supporting them at the moment, so haven't encountered this issue ourselves.

                       

                      HTH,

                      Amber

                      • 8. Re: RH9 Snippets not saving, RH not closing>have to force close
                        LaconicVerbosity Level 1

                        OK, my colleague (who is a RH certified expert) figure out what was going on.  Basically, in addition to our two hard drive copies of the project being out of sync (which we fixed by deleting some, taking some out of VSS that didn't belong, and recopying everything onto my hard drive) there is an underlying snippet problem which my colleague diagnosed as follows (her description):

                         

                         

                         

                        1. The project was worked on in RH7 for a couple of years. In early June 2011, RH9 was installed. The project was opened in RH9, and the appropriate ‘do you want to convert the project’ message displayed. I proceeded to do the conversion.
                        2. Everything seemed to convert rather well except for one thing – the snippets. If you opened the Properties window for a snippet, you could see the description; however, the description would not display in the Pod in the designated “Description” column.
                        3. As a test, I created a new snippet in RH9, which generated the following code:

                         

                        <?xml version="1.0" encoding="utf-8"?>

                        <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

                        <html xmlns="http://www.w3.org/1999/xhtml">

                        <head>

                        <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

                        <meta name="topic-comment" content="here's the description" />

                        <title>New Snippet</title>

                        <meta name="generator" content="Adobe RoboHelp 9" />

                        </head>

                        <body>

                        <p>This is placeholder text for your snippet. To add content to the body,

                        replace this text. </p>

                        <p>&#160;</p>

                        <p>For information about applying snippets to topics, press <b>F1</b>.</p>

                        </body>

                        </html>

                        However, the code for a converted snippet looks like this:

                        <!doctype HTML public "-//W3C//DTD HTML 4.0 Frameset//EN">

                        <html><head>

                        <meta http-equiv=content-type content="text/html; charset=utf-8">

                        <meta name=generator content="Adobe RoboHelp - www.adobe.com">

                        <meta name=generator-major-version content=0.1>

                        <meta name=generator-minor-version content=1>

                        <meta name=filetype content=RoboHelp>

                        <meta name=filetype-version content=1>

                        <meta name=page-count content=1>

                        <meta name=layout-height content=487>

                        <meta name=layout-width content=424>

                        <title>Use this snippet as the explanation for the Credit Type field on a form.</title>

                         

                         

                        </head>

                        <body>

                        <p>Unit of credit for the course. Together with the Credit Value, it defines

                        the possible credit hours earned for the course.</p>

                        </body>

                        </html>

                        Notice how the text that is in the title tag is actually the DESCRIPTION for the snippet. Also, there is no meta tag for the real description in the converted code. The real title for this snippet is Credit Type, but for some reason, that does not display in the converted snippet code. The name only displays correctly in the Properties window, like this:

                        Screenshot 1.jpg

                         

                         

                        Strange how the name (or “Title” as the code seems to indicate it should be) correctly displays in the Properties window, but that name is nowhere in the actual code in the HTS file.

                         

                         

                         

                        So it seems to me that there is a disconnect between what’s in the code, and what’s displaying in RH, and I’m not sure how or why that happened. I simply allowed RH9 to convert my RH7 project, and this Snippet problem was the only resulting problem that I’ve found.

                         

                         

                         

                        Is there any way to get this properly fixed by Adobe? Even when we enter the appropriate descriptions ourselves, they STILL don’t display properly in the Snippets pod. Sometimes some of them display, sometimes all of them don’t display, and sometimes if you perform an action (like creating a new snippet), then that action will cause some or all of the descriptions to display.

                         

                         

                         

                        Here’s an example --

                         

                        1st screenshot below – the Snippets pod as it typically displays for us in RH9. Absolutely no descriptions displaying.

                        2nd screenshot below – I created a new snippet. The description for the new snippet displays PLUS the two descriptions for recently created snippets display! You can only see one of them in the screenshot (“Curriculum Considered Complete Situations”), but further down the list, the description for a snippet named “Requiring Search Criteria” also displays after creating the new snippet (Note: Both of these snippets were created in RH9, which raises the questions: Why didn’t the descriptions already display *before* I created a new snippet? Why did the action of creating a new snippet *cause* the two snippet descriptions to suddenly display?)

                         

                        Screenshot 2.jpg

                         

                        Screenshot 3.jpg

                         

                        Another Note: After my co-worker had manually gone through all of the snippets and manually added descriptions (and updated the “Title” tags to reflect the actual title of each snippet), this caused some issues – erratic Snippet pod behavior, and he had to keep using the Task Manager to close RH (normal close methods wouldn’t work). So since RH9 started acting funny and wouldn’t close for him, we reverted back to using the HTS files and the rhsnippet.apj snippet file that RH9 originally converted for us, and those original files are what we are continuing to use, but we would like to have a solution for the problem. Why didn’t RH9 properly convert the HTS files? Or at least, to us, based on the code that’s actually in the files, they don’t appear to be properly converted.

                        • 9. Re: RH9 Snippets not saving, RH not closing>have to force close
                          Peter Grainge Adobe Community Professional

                          Given that this is not a common problem and all the behind the scenes stuff that you have understandably had to try, I doubt Adobe would investigate this as a bug. Even if they did, who knows when a solution would be made available. There is no consultancy service offered by them so I think you are stuck with a home brewed fix.

                           

                          Try this to see if it helps. Create a new project and don't put it anywhere near source control. Import some topics from the rogue project that include good and bad snippets. The import process will not bring in the snippet but the topics will still have the placeholders. Next import all the snippets referenced in those topics.

                           

                          First see if the process of importing them fixed the missing description problem. I doubt it will. What I am hoping though is that you can now add descriptions that will stick.

                           


                          See www.grainge.org for RoboHelp and Authoring tips

                           

                          @petergrainge

                          • 10. Re: RH9 Snippets not saving, RH not closing>have to force close
                            Peter Grainge Adobe Community Professional

                            LaconicVerbosity

                             

                            Just wondered how you were getting on with this problem.

                             


                            See www.grainge.org for RoboHelp and Authoring tips

                             

                            @petergrainge

                            • 11. Re: RH9 Snippets not saving, RH not closing>have to force close
                              LaconicVerbosity Level 1

                              Thank you for your concern.  We ended up deleting my entire project folder and then copying my colleague's project folder manually onto my hard drive (instead of a get-latest from VSS). That was to make sure we both had the same version of files.

                               

                              We also had realized that we did in fact have some .ldb, .pss and .cpd files in Visual SourceSafe that I think weren't supposed to be there, so my colleague removed them from VSS before copying the project folder to my computer.

                               

                              Also, I wasn't always checking out the entire project folder so files that get updated as I work (such as rhsnippet.apj) would also be checked out and thus saved in VSS. I simply didn't know I needed to do that.

                               

                              For part of the problem I think the copies that she had checked out but that I hadn't were the only one's with changes being saved, so I think they were overwriting my files when I would check out or do a "Get Latest" for the entire project folder (and accept VSS's version, not the one on my hard drive, which had my changes) on occasion.

                               

                              In the end it seemed to fix the issue of snippets being properly created, saved and showing up for both of us.

                               

                              The snippet description problem is still an issue, however, but we have both decided that this is not a critical issue right now since everything else seems to be working.

                               

                              With the exception of the snippet description issue described with the screenshots above by my colleague, which I will let her decide how to handle, I consider the issue closed and I thank you all again for your suggestions and support.

                              • 12. Re: RH9 Snippets not saving, RH not closing>have to force close
                                Amebr Level 4

                                If you were working on files that your colleague had checked out, then that is indeed the reason you were losing work - your changes were not added to the source control database and thus "didn't exist" according to VSS. It's possible to have VSS set up to allow multiple people to work on the same file and merge in their changes, but I always found it too much work and prefer to wait until the other user has finished with the file. Also, I'm not sure RH deals well with this either, especially if you both make changes that affect admin files like snippets.

                                 

                                Also see the Snippets page on Peter's site for a comprehensive article on multi-authoring.

                                 

                                # 139 Multiple authors - when to use source control.

                                http://www.grainge.org/pages/snippets/snippets.htm

                                 

                                You should read the whole article, but I'd like to specifically point out this quote from the Gravenstein section "Set it up to restrict file checkouts to one author only. Allowing two authors to work on a single topic simultaneously is bad."

                                 

                                (Also note that if you check out the entire project, you are restricting the project to a single person until the files are checked back in.)

                                 

                                Amebr