11 Replies Latest reply on Aug 9, 2011 9:04 AM by lelandrangel

    Re: Flex automation and license

    John Hall Level 4

      I just realized this is probably a Flash Builder issue, rather than a Flex issue. Maybe that’s why there are no responses in the Flex forum.

      I have a volume license for CS5.5 Master Collection from my university that I just installed. 

       

      Everything works fine except when I go to use FlexMonkey to do automation tests, which I’ve been doing for a long time in Flex 4.  After about 20 actions in the automation framework, I get the message “License not present. With the trial verison only limited records are allowed.” That’s not a typo on the word version on my part. Might want to change that ;-)

       

      Anyway, I have done everything suggested in this thread: http://forums.adobe.com/thread/834214.

       

      I definitely have Premium installed – as per Deepa’s suggestion I have network monitor and the other Premium features totally fine. To make sure no leftover files are around, I’ve totally uninstalled CS5.5, deleted all Adobe folders under Program Files, deleted the licenses.properties file in C:\ ProgramData\Adobe\Flex, emptied the trash, bought my computer lunch and still no luck. I start doing functional testing and after 20 items I get the same message: License not present. With the trial verison only limited records are allowed. Is it possible that volume licensed Premium versions don’t correctly activate the automation API?

       

      I spent about 2 frustrating hours with four people on technical support. Very frustrating. Finally have been told that technical support doesn’t support Flash Builder, only “consumer products” and that I’ll  have to pay for support from Level 2 support. That just sounds odd that I can’t get the product to activate properly and I have to pay for tech support.  But three out of the 4 told me this after they hit dead-ends on the issue and the fourth one transferred me to volume licensing sales, who said, oh, you can probably guess what the said. What? The fourth person did at least tell me before transferring that volume licensing doesn’t require the same type of activation so he thinks it doesn’t properly activate the automation tools. Just his humble opinion.

       

      Anyone know better?

        • 1. Re: Flex automation and license
          Deeptika Gottipati Adobe Employee

          Hi John,

           

          May I know with which SDK you are facing this issue? Please let us know whether you are seeing same error even when you automate projects built with SDK 4.5 and later?

           

          Thanks,

          Deeptika

          • 2. Re: Flex automation and license
            John Hall Level 4

            I'm using CS5.5 (volume license at my educational institution), so it installed 4.5 Premium. I then upgraded with the recent patch for 4.5.1. I don't have the problem at home where I purchased an individual copy as a faculty person. Not really sure if that figures into the equation but I've done everything else I can find on the forums, including your previous posts, and simply have had no luck so far. I'm glad I can still use the automation API at home but it's a little frustrating at work where I really need it.

            The only thing I can think of, having totally uninstalled CS5.5 and deleted the licenses.properties file and every other trace of Adobe products of which I'm aware, and then reinstalled without luck ... could there be some difference between volume licensing activation and the copy I bought on faculty/staff discount, where I don't have an issue, such that activation of the automation api is not the same?

            I appreciate your time very much. Kind of frustrating but I know it's not Adobe's intention to create such problems.

            • 3. Re: Flex automation and license
              fruto da terra

              pagamento de boletos e dechmento de fatura de combio numeros de cartois de creditos visa master cad

              • 4. Re: Flex automation and license
                Deeptika Gottipati Adobe Employee

                Hi John,

                 

                Can you please let us know whether you are facing the issue with projects built with 4.5 SDK or with those built with earlier SDKs?

                 

                FlashBuilder 4.5 comes with 4.5 SDK but if the projects that you have are compiled with older SDKs, then probable reason could be that they are not able to understand the new license.

                 

                Also can you please send the license.properties file to deeptika (at) adobe (dot) com?

                 

                Thanks,

                Deeptika

                • 5. Re: Flex automation and license
                  John Hall Level 4

                  Compiling with 4.5.1. It is an AIR project, using 2.6. I'll send the properties file.

                   

                  Thanks

                  • 6. Re: Flex automation and license
                    John Hall Level 4

                    So it does the same thing on both the volume license edition and the teacher/student version. Is the Automation API not supported for educational versions ofFlash Builder Premium as installed from Master Collection?

                     

                    In case it's another piece of the puzzle, I have Coldfusion Builder 2 installed on both machines, both versions. CFB2 plugin inside the Flex standalone.

                    • 7. Re: Flex automation and license
                      John Hall Level 4

                      I know the forum is not an official place for tech support from Adobe but I did send all the requested info and haven't heard back if there's something wrong with the approach I was taking or if all the educational versions of Master Collection simply don't support the automation API. I uninstalled and installed with various permutations of cleaning off the machine with no luck yet. As you might guess, it's a little frustrating when I contacted tech support and they told me they don't support Flash Builder at all, that I have to pay for level 2 support to get that. If that's true, is there a per-incident way I can do that which isn't totally expensive?

                      • 8. Re: Flex automation and license
                        Deeptika Gottipati Adobe Employee

                        Hi John,

                         

                        Sorry to let you know that automation is licensed only when one uses FB Premium or FBPHP Premium licenses.

                        None of the other licenses are considered valid and this is a bug from our side.

                         

                        We are looking into this and http://bugs.adobe.com/jira/browse/SDK-30752 is logged to track this.

                         

                        Thanks,

                        Deeptika

                        • 9. Re: Flex automation and license
                          John Hall Level 4

                          Thank you much. At least I know what's going on now. I appreciate finding this out.

                          • 10. Re: Flex automation and license
                            John Hall Level 4

                            BTW, this was fixed in an updated SDK.

                            • 11. Re: Flex automation and license
                              lelandrangel

                              Hi Deeptika,

                               

                               

                              Is this still an issue today then with the Flex SDK 4.5.1.21328 revision? I saw in the comment on the bug at http://bugs.adobe.com/jira/browse/SDK-30752 that it was fixed in revision 21579 but that is not released yet as far as I can tell. I am testing the automation libraries now for a project we will be building soon. We have the volume license for the CS 5.5 package that includes FB 4.5.1 premium edition.

                               

                              If this has not been fixed yet, when might we expect the next release? I notice the above bug has been closed so I am assuming it is fixed in the release they mention in the bug comments.

                               

                              Thanks,

                               

                              Leland