4 Replies Latest reply on Jul 20, 2011 6:58 PM by Briandliz

    Mjpeg codecs not working

    Briandliz

      Hi All

      Aplogies if this thread has been dealt with before but I am brand new to the forum and couldn't see anything recent.

      I tried to load M jpeg 720p HD video from my Pentax X90 camera into Prel. without success and as prompted I downloaded trial Codecs (Morgan) these seemed to work fine  but I proceeded to trial other codecs (Mainconcept, Avid etc.). I also tried a couple of trial video converters. I decided to go with the Morgan Codecs. However the codecs had stopped working properley. Although the video is fine I was now only able to import half the audio file. (ie 10 sec clip only imports first 5 secs audio). This was happening with all M Jpeg video files. I unninstalled all codecs, reinstalled Morgan, same result. I even reinstalled Prel which was raelly unnecessary as there is only an issue with the mjpeg files. I would appreciate any help as my only recourse at the moment may be to reinstall windows 7. Intestingly the software bundled with the camera (Arcsoft Mediaimpressions 2) loads , plays and saves the video but unfortunately only in 4:3 WMV format. It must use a codec from somewhere.

      Thanks for any help

        • 1. Re: Mjpeg codecs not working
          the_wine_snob Level 9

          Welcome to the forum.

           

          I have not read of anyone having an issue with the Morgan MJPEG CODEC. That it worked for a period of time, but now only allows partitial Import of the Audio is very odd indeed.

           

          The only thing that I can think of is that you are not allowing PrE to Conform the Audio 100%. This ARTICLE goes into a bit more detail. However, considering the short Duration of the files, that you cite, Conforming, even on a slow machine, should be very quick.

           

          I do not know if Pentax has tweaked the MJPEG CODEC, as many camera mfgrs. do, but I would anticipate that they would ship their version of MJPEG with the camera. This could be a separate installer program on the disc, bundled with a driver for the camera, or installed along with that editing software - the ArcSoft.

           

          About the only thing that comes to my mind would be to get the Pentax disc, search it for a CODEC install, and there is none, reinstall any camera driver, and if that does not change things, then reinstall the ArcSoft program.

           

          Since a CODEC is installed at the system level, their performance seldom changes, but it seems that yours has.

           

          Good luck, and maybe others will have more ideas.

           

          Hunt

          • 2. Re: Mjpeg codecs not working
            Briandliz Level 1

            Thanks for the response Bill

            I have checked for codecs when MediaImpressions is installed but there

            doesn't appear to be anything new showing in the list for media players.

            Certainly there is nothing on the Disc to install them. It would appear that

            my registry is scrambled (not for the first time this has happened) Maybe

            from uninstalling too may trial codecs and media converters. I'm going on

            holidays for a couple of weeks and will have the chance to thrash this

            problem out with another kindred spirit who has PREL working

            successfully.Otherwise when I get back I will do a format

            and re-install windows 7. Thanks for your help . I will be in touch.

            • 3. Re: Mjpeg codecs not working
              the_wine_snob Level 9

              Most of all, enjoy the holiday!

               

              When installing trials of almost anything, I will manually do a System Restore Point, so that I can revert to that, if needed.

               

              Now, I do have one question, and this regards the "trial CODEC's," did you install FFDShow along the way? It has been known to really mess up some Adobe programs. Just curious.

               

              Good luck, and travel safely,

               

              Hunt

              • 4. Re: Mjpeg codecs not working
                Briandliz Level 1

                Hi Bill,

                Back from Hols with lots of videos and pics.

                I don't recall installing FFDShow but I did download a lot of codecs from some obscure sites so let that be a lesson well learned.

                Good news is that I have solved the problem of getting elements to accept my video files in MJPeg format (dragged straight from Media card)

                Install Quicktime player. (free version will do)

                My son worked this out from a clue on Wikipedia.

                Apparently Quicktime imports an MJPeg codec that Elements will look at (It can be seen loading on Elements startup)

                Works perfectly.

                With the output set to HD 720p Mpeg the resulting files are indistinguishable from the original quality.

                As more and more people start to realize the benefits of HD video recording in their still cameras this issue of compatability will only get worse. I hope this simple free fix for video from the Pentax X90 digital camera is of some help.

                A small tip for those that, like me now only show video from a media player drive, try outputting in WMV. The latest windows codecs (version9) are excellent and rated as HD standard. The video files are much smaller for media drive storage and the quality is excellent. Worth a try.

                Thanks for the help

                BriandLiz