4 Replies Latest reply on Jul 4, 2011 4:47 AM by martinjconnolly

    Debugger stopped working - FB4

    martinjconnolly Level 1

      Hi,

      this morning my debugger stopped working. FB4 stays reponsive after I hit the debug button - it shows a main thread running - but either IE8 or FF5 freeze, showing "not responding" in the title bar. Windows says Flashbuilder.exe is using a constant 10% or so of CPU and lots of disk access. I have tried installing the latest versions of the Flash debugger player (10.3.181.34) but it makes no difference. Just launching the app works perfectly. I'm running Windows 7 Pro 64 bit on a Thinkpad W510 (8gb RAM, two quad-core i7 processors). Has anyone else seen anything like this?

      Thanks

      Martin

        • 1. Re: Debugger stopped working - FB4
          martinjconnolly Level 1

          Just found this in the log: one for every time I've tried launching the debugger today. In fact one every 3 milliseconds when I've done that! No wonder the disk light is flashing constantly.... any ideas anyone? Reinstall Flash Builder?

          Thanks

           

          !ENTRY com.adobe.flexbuilder.debug 4 2 2011-07-01 13:53:04.395
          !MESSAGE Problems occurred when invoking code from plug-in: "com.adobe.flexbuilder.debug".
          !STACK 0
          java.lang.NullPointerException
              at com.adobe.flexbuilder.debug.breakpoints.FlexLineBreakpoint.findSourceFiles(FlexLineBreakp oint.java:412)
              at com.adobe.flexbuilder.debug.breakpoints.FlexLineBreakpoint.instantiate(FlexLineBreakpoint .java:465)
              at com.adobe.flexbuilder.debug.model.FlexDebugTarget.instantiateBreakpoint(FlexDebugTarget.j ava:1012)
              at com.adobe.flexbuilder.debug.model.FlexDebugTarget.access$4(FlexDebugTarget.java:1006)
              at com.adobe.flexbuilder.debug.model.FlexDebugTarget$FdbThread.installDeferredBreakpoints(Fl exDebugTarget.java:637)
              at com.adobe.flexbuilder.debug.model.FlexDebugTarget$FdbThread.advanceStateMachine(FlexDebug Target.java:668)
              at com.adobe.flexbuilder.debug.model.FlexDebugTarget$FdbThread.access$7(FlexDebugTarget.java :642)
              at com.adobe.flexbuilder.debug.model.FlexDebugTarget$FdbThread$1.run(FlexDebugTarget.java:75 2)
              at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
              at com.adobe.flexbuilder.debug.model.FlexDebugTarget$FdbThread.eventLoop(FlexDebugTarget.jav a:732)
              at com.adobe.flexbuilder.debug.model.FlexDebugTarget$FdbThread.run(FlexDebugTarget.java:793)
              at java.lang.Thread.run(Unknown Source)

          • 2. Re: Debugger stopped working - FB4
            martinjconnolly Level 1

            Aha! found this entry with some judicious googling: http://www.fingersdancing.net/2008/06/flex-debugger-crashing-eclipse-safari.html

            That related to OS X rather than Windows, but I deleted the line starting "PreloadSwf" from my mm.cfg file and the problem is solved!

            • 3. Re: Debugger stopped working - FB4
              martinjconnolly Level 1

              Aargh, it's stopped again. The rogue line had come back in the mm.cfg file but even after removing it my browser hangs when I try to debug. This needs to get sorted quickly or I'm thinking of ditching Flex for future development.

              • 4. Re: Debugger stopped working - FB4
                martinjconnolly Level 1

                Flashfirebug extension disabled and now working - forgot I had that installed