2 Replies Latest reply on Jul 17, 2011 1:00 PM by eagl0r

    New code doesnt show, project clean, now launch failed.

    eagl0r

      Last week all the sudden more and more often my newly added/modified Flex code would stop showing when I ran or debug my app, instead it kept showing me an older version. I could 'fix' this by removing some lines of coding, saving, adding them back, saving. But now that doesn't work anymore either! When I googled this I found someone saying I should hit Project - Clean. After I did this I can't run or debug anything anymore.

       

      http://img43.imageshack.us/img43/3349/initialcontent.png

      I already reinstalled Flash Builder, removing all preferences, but it didn't help.

       

      What's going on? Why is my Flash Builder completely mindf**king me right now?? I can't work like this and it's driving me crazy. I'm only just starting to learn Flex so I have no idea what to do.

        • 1. Re: New code doesnt show, project clean, now launch failed.
          embeddedsoft

          Hi,

           

          I can try and help if you'd like. I'm also new to Flash Builder/Flex 4 but FB is eclipse based and I have almost 10 years experience getting my mind blown by eclipse.

           

          First off, do you have automatic build enabled for the workspace/projects? If not, try enabling this.

           

          Now, how complex/large is your workspace? how many projects in it? Large library references?

           

          One thing I used to do in Eclipse is delete the '.metadata' folder in the workspace. This basically blows away all of FB/Eclipse configuration settings for your workspace allowing you to start from a clean slate but with the inconvenience of rebuilding all your workspace settings. Workspace/Project corruption seems to be a common "feature" of eclipse and hence I would imagine that this would also happen in Flash Builder.

           

          Another thing to do is create a new shortcut to the Flashbuilder.exe file and then modify it and put a -clean at the end forcing FB to <ahem> clean itself.

           

          Anyway, lets see if you can get to building and rebuilding your projects/workspace and then take a look at debugging.

           

          cheers.

           

          embeddedsoft

          • 2. Re: New code doesnt show, project clean, now launch failed.
            eagl0r Level 1

            Thanks embeddedsoft. I did have automatic build enabled. My workspace was very small, 5 projects with 100 lines of code each max. I've messed around with those profiles/metadata folders and done some more of those destructive cleans.

             

            Nothing helped. Then I started a new project just to see if it would run, and it did. So I started copying over line by line of my current project slowly reconstructing it and behold.. the fully copied project worked.

             

            So altho I have no idea what caused it or how to solve it, if anyone has this same problem: Start over and slowly bring in your old code to the new project. Then delete your old projects!