5 Replies Latest reply on Jul 4, 2011 10:05 PM by Lloyd Seymour

    Plain text issue

    Lloyd Seymour

      Hi

       

      Any ideas why text imported from a plain text file appears with lots of symbols and other stuff when placing in to Indesign (CS5.5?.  It's never been a problem before now, I'm at a loss as to why its happening now.

       

      Any help appreciated.

      Lloyd

        • 1. Re: Plain text issue
          Stix Hart Level 5

          Just checking here, is it a .txt file?  If it is I can't think of anything at the moment, if it is could it be in some other format and carrying across some font information?

          • 2. Re: Plain text issue
            John Hawkinson Level 5

            There are lots of reasons, generally related to character encoding. Please post a screenshot, so we know exactly what we're dealing with...

            • 3. Re: Plain text issue
              Lloyd Seymour Level 1

              Thanks guys, yes I am placing from a plain text .txt file. Two examples

               

              Plain text (text edit)  screen grab:

              Picture 18.png

              Placed into Indesign (check the apostrophe):

              Picture 19.png

               

              This one's a bit more bonkers:

               

              Plain text (text edit)  screen grab:

               

              Picture 21.png

               

              Placed in to Indesign:

              Picture 22.png

               

              Thanks for your help

               

              Lloyd

              • 4. Re: Plain text issue
                John Hawkinson Level 5

                Just because the TextEdit programs shows it as "plain text" doesn't mean that's how it is saved!

                 

                Notice how when you Save As in TextEdit you have the opportunity to specify UTF-8,UTF-16,Mac OS Roman, etc.?

                And when you open in InDesign if you check Show Import Options you have the opportunity to do the same.

                 

                If there is a mismatch, than non-ASCII characters, such a curly-quote, will show just like that.

                 

                I believe your input text file is UTF-8, which is almost undoubtedly the correct choice. So Show Import Options when you place in InDesign and ensure you have Unicode UTF-8 selected as the Character Set.

                1 person found this helpful
                • 5. Re: Plain text issue
                  Lloyd Seymour Level 1

                  Correct!  That worked perfectly, thank you so much!