3 Replies Latest reply on Aug 23, 2011 8:11 AM by Michael Orzechowski

    Path Mapping popup issue

    Jamie McDaniel Level 1

      If anyone else has an issue with the "Path Mapping" popup appearing when debugging a Flex and PHP application on your local Zend Server, here is the solution.

       

      When you first install Flash Builder 4.5 for PHP, it will remind you to download and install Zend Server CE.

       

      Once you have done that, the next time you start Flash Builder, you get this.

       

      Flash BuilderScreenSnapz001.jpg

       

      Unfortunately, Flash Builder for PHP did not configure Path Mapping for Zend Server CE correctly.  When I create a combined Flex and PHP project, and go to debug it, I got this:

       

      Flash BuilderScreenSnapz001.jpg

       

      The popup appears like 100 times for various php classes in the framework. I would select the bottom option of "Get content from the server for the following path:"  I would have to go through 5 minutes of clicking these popups before finally getting my application to launch.

       

      The problem turned out to be the Path Mapping.  If you go to Preferences --> PHP --> PHP Servers, you will see that the Local Zend Server has been added as the default.  Select it and click the Edit button. Then select the Path Mapping tab.

       

      The entry for Zend Framework will point to a wrong server path.

       

      Flash BuilderScreenSnapz002.jpg

       

      The "Path on Server" is set to /usr/local/zend/ZendServer/share/ZendFramework/library

       

      It should be set to /usr/local/zend/share/ZendFramework/library

       

      Once I changed it, the popups no longer appeared.

        • 1. Re: Path Mapping popup issue
          RoyGanor Level 1

          Hi Jamie,

           

          Thanks for providing this observation, we will log this issue and fix it.

           

          Roy

          • 3. Re: Path Mapping popup issue
            Michael Orzechowski

            Jamie

             

            I just managed to install and setup Builder 4.5 for PHP with Zend Debugger.

            It was quite a headache to enable Zend Debugger on WAMP server. I have been forced to downgrade PHP to ver 5.2.11 (and subsequently to downgrade Apache version to 2.0.63) to make it work. Anyways, not a good start but I thought, ok, finally some progress. At the moment I am faced with same issue as reported in that post however I am not sure how to setup path mapping(s) so I wont be presented with 30-50 popups when trying to debug my PHP classes.

            I tried to check the status of reported bug you have mentioned but link seems to be broken.

             

            Example of first popup I am presented with:

             

            Path Mapping - Select Local Resource

             

            Select the local resource that matches the following server path:

             

            ...Adobe Flash Builder 4.5\.metadata\.plugins\org.zend.php.framework.resource\resources\ZendFramework-1\library\ Zend\Loader.php

             

            Get content from the server to the following path:

             

            C:\Users\Michael\Adobe Flash Builder 4.5\.metadata\.plugins\org.zend.php.framework.resource\resources\ZendFramework-1\library\ Zend\Loader.php

             

             

            Once I will confirm that popup I am presented with another 30-50 of these. After all is confirmed I am finally able to debug my code.

             

            Can anyone please advise how to setup this mapping?

             

            PS. I can create a separate mapping for each php file that is mentioned but surely there should be better way than defining 30-50 separate mappings...

             

            Regards

            Michael

             

            Nevermind, I have decided to create mapping for all 30-50 files. It works fine now. Good thing its a global setting and does not have to be set for each project separately;)

             

            Message was edited by: Michael Orzechowski