5 Replies Latest reply on Jul 7, 2011 10:51 AM by Peter Grainge

    Text is shown although CBT says not to show it

    Louisa_de

      Hi, once again!

       

      I'm still using RoboHelp 9 (having upgraded from RoboHelp 7 at the beginning of the year) and it's giving me nothing but grief.

       

      The newest shenanigan it plays on me: it displays text which is conditioned not to be shown:

       

      In the topic html the text is conditioned as follows

       

      <?rh-cbt_start condition="CONDITION_1" ?><li style="list-style: none;
                                                               display: inline;"><ul>
              <li class="p-bullet1"><p class="bullet1"><a href="texttextext.htm">TEXTTEXTTEXT</a></p></li>

       

      When generating a chm or PDF, I click "Define" next to the Contional Buil Expressions Drop-down and tell it

       

      NOT CONDITION_1

       

      then generate.

       

      But still the text is shown in the chm/PDF.

       

      This was just an example, it happens with various conditions and it's a massive problem.
      Does anybody have the same problem and/or a solution for me?

       

      Thank you very much!

       

      Lousia
        • 1. Re: Text is shown although CBT says not to show it
          Peter Grainge Adobe Community Professional (Moderator)

          <p><?rh-cbt_start condition="Online" ?>Tag Test<?rh-cbt_end ?></p>

           

          Is the closing tag in your HTML?

           


          See www.grainge.org for RoboHelp and Authoring tips

           

          @petergrainge

          • 2. Re: Text is shown although CBT says not to show it
            Louisa_de Level 1

            Hi Peter!

             

            No, that seems part of the problem. The end tag keeps on being deleted. Even if I enter it manually into the html text.

             

            But basically I didn't edit the HTML-Text but conditioned the text by highlighting it and then choosing the right condition from the list (months ago).

             

            The problem is new. A far as I can track it down it must've happened some time between April 7th and April 20th.

             

            Was there an update or something which messed with the conditions?

             

            Some conditions work, some don't.

             

            Can you help?

             

             

            Thank you very much!

             

            Louisa

            • 3. Re: Text is shown although CBT says not to show it
              Peter Grainge Adobe Community Professional (Moderator)

              The 9.0.1 update was released early May but you would have had to OK installation. I've not seen anyone else report this since then.

               

              Right click in some text that has a condition applied and look for Remove Attribute or Remove Atttributes. If the former is what appears it will be the CBT so remove it, then reapply in way you originally did. If the latter click and a dialog will appear, just remove the CBT that way and then reapply it.

               

              Any difference? If not, does a new project have the same problem?

               


              See www.grainge.org for RoboHelp and Authoring tips

               

              @petergrainge

              • 4. Re: Text is shown although CBT says not to show it
                Louisa_de Level 1

                Hi Peter!

                 

                Thanks for your answer.

                 

                I tried what you suggested and with some conditions it works with some it doesn't.

                 

                I can recognize the conditions which will not work because when applying them and hitting the save button I get a window asking whether I want to apply this change to the master topic.

                 

                I don't get this window with the other conditions which work, when I delete and reapply them.

                 

                I haven't tried a new project yet, I don't have a lot of time to put into searching for the problem and I definitely don't have the time to start this project from scratch (250 topics, about 200 CBTs).

                 

                Do you think my RoboHelp installation might be corrupted somehow?

                 

                Thank you!

                 

                Best regards,

                Ute

                • 5. Re: Text is shown although CBT says not to show it
                  Peter Grainge Adobe Community Professional (Moderator)

                  There has been a problem with 8 and 9 giving a warning about master page changes for no apparent reason. Are you always saying Yes or No? Have you tried the opposite answer? I suggest you only do that in a copy of your project.

                   

                  When you don't get this warning, is it because those pages are not linked to the master page?

                   

                  The reason I suggested testing a new project was simply to see if you get the same problem. Without knowing that I cannot say whether it is the installation but I doubt it is. This is more likely to be a project problem. Creating a new project to test that CBTs work OK would take all of five to ten minutes.

                   


                  See www.grainge.org for RoboHelp and Authoring tips

                   

                  @petergrainge